locked
Custom Entity - multiple records RRS feed

  • Question

  • I have created a custom entity that contains a list of different Windows-operativesystems that I want to be able to assign to different accounts that I have.

    I just realized, that I can only assign (for example) Windows 7 to 1 account.
    Then the next one says "this record is already associated with another account"

    I had this working in CRM2011, but now we are running 2013, and I have lost my "solution".
    Can anyone help?
    Thursday, January 2, 2014 2:23 PM

Answers

  • Hi,

    You have created a 1:N relationship between account and your custom entity. You need to delete this 1:N relationship and create a N:N relationship. This will allow you to associate an operating system with multiple accounts.

    Hope this helps,

    Scott


    Scott Durow
    Blog www.develop1.net    Follow Me
    Rockstar365
    If this post answers your question, please click "Mark As Answer" on the post and "Mark as Helpful"

    Thursday, January 2, 2014 2:53 PM
    Answerer

All replies

  • Hi,

    You have created a 1:N relationship between account and your custom entity. You need to delete this 1:N relationship and create a N:N relationship. This will allow you to associate an operating system with multiple accounts.

    Hope this helps,

    Scott


    Scott Durow
    Blog www.develop1.net    Follow Me
    Rockstar365
    If this post answers your question, please click "Mark As Answer" on the post and "Mark as Helpful"

    Thursday, January 2, 2014 2:53 PM
    Answerer
  • I tried just adding a N:N and that didn't work :(

    I'll try deleting it and try again!
    Thursday, January 2, 2014 3:03 PM