locked
Home server restore cant find network driver RRS feed

  • Question

  • Hey all,

    I have a Samsung N120 netbook that I have backed up on HS with two seperate OS's XP and Win7.  When I try and restore one of the backups, the restore process doesn't find a network driver.  I used all of the different Windows Home Server folders (drivers) from the backups on the server.  Most of the backups were backed up via a wireless connection so I did a backup with the wireless adapter disabled and with it using the ethernet connection and used that backup folder, it still didn't find any network drivers. 

    I also tried downloading the different network drivers from the Samsung website for different OS's but unfortunately all of them are setup.exe and don't make folders with the drivers, it installs directly.  Any ideas how to get the drivers that I need?  Any help or advice would be GREATLY appreciated!! :)

    Thanks,

    Steve

    Sunday, March 21, 2010 3:54 AM

All replies

  • You may be able to obtain a better driver if you can find out what network controller is in the netbook. Failing that, the best practical alternative is to remove the drive from the netbook, connect it to some other client PC, and run C:\Program Files\Windows Home Server\ClientRestoreWizard.exe on that PC. This will run the same program the Restore CD uses, but in a fully functional Windows environment.
    I'm not on the WHS team, I just post a lot. :)
    • Proposed as answer by EcurbNosneb Sunday, November 21, 2010 12:23 AM
    Sunday, March 21, 2010 12:00 PM
    Moderator
  • http://org.downloadcenter.samsung.com/downloadfile/ContentsFile.aspx?CDSite=UK&CttFileID=2224796&CDCttType=DR&ModelType=N&ModelName=NP-N120&VPath=DR/200908/20090819142526437/LAN_10.69.2.3.zip

    On another computer install the setup and copy C:\Program Files\Marvell\Miniport Driver to the USB stick and give that a try.


    --

    Sunday, March 21, 2010 7:32 PM
  • Good suggestions but that didn't work either darn it!  I also tried the Win7 version of the same driver as well with no luck, in addtion I also tried copying the drivers folder from the Windows\system32 directory.  When I do the scan, it does detect my USB flash drive, I also tried several different USB flash drives, no luck.  I'm hesitant to try removing the drive from the system since that might void my warranty.
    Sunday, March 21, 2010 8:38 PM
  • Also you could do in the WHS Console open one backup volume and copy "Windows Home Server Drivers for Restore" to your USB disk root.

    In the restore process, plug in your USB disk and try update drivers. If  you still can't get the NIC driver installed, plug USB disk to other computer, open the "Windows Home Server Drivers for Restore" and find some folder like net****, open the folder, change files with extion ._nf to .inf. plug USB disk to your netbook and try again. I experienced the same problem on a HP netboot with Marvell NIC and solved. Hope it could help.

    Monday, March 22, 2010 2:01 AM
  • Well it took a bit of doing but I finally got the darn thing to detect the Marvel network driver.  I had to do a Vista install, copy the drivers folder from windows\system32, any MS'rs that are looking at this might want to address this issue, apparently the win7 drivers and the xp drivers are not compatable with the Home Server.
    Saturday, March 27, 2010 8:30 PM
  • Woo hoo!

    OK, that worked for me.  My drivers (from WHS backup and downloadied from vendor - Acer Aspire 5742Z) were not recognized.  Went to broadcom and downloaded their 32 bit win7 driver.  WHS then recognized it.  Funny, the drivers loaded on my system (and downloaded from Acer) said AMD64 but I have an Intel based system.  

    Thanks a bunch.

    Bruce
    PMToolsThatWork.com

    Saturday, November 20, 2010 11:46 PM