locked
No Data when opening a Dynamic worksheet in Excel in CRM 3.0? RRS feed

  • Question

  • When a user opens a Dynamic Worksheet to Excel, no data appears? Excel opens fine and the columns are there but no other information.

     

    The user is able to export static worksheets and it is not isolated to their terminal. How can I resolve this?

    Friday, May 30, 2008 8:13 AM

Answers

  • It might be a CRM / SQL Permission issue. Is the user an active CRM user with the Restricted Access Mode option not set ?

    Monday, June 2, 2008 10:55 AM
    Moderator

All replies

  • Friday, May 30, 2008 1:31 PM
    Moderator
  • Thank you for the link although I should note that no other users have a problem with exporting dynamic worksheets.

     

    I will read up on the microsoft help/installation guides before I proceed.

     

    Regards

    baynes

     

    Monday, June 2, 2008 8:47 AM
  • It might be a CRM / SQL Permission issue. Is the user an active CRM user with the Restricted Access Mode option not set ?

    Monday, June 2, 2008 10:55 AM
    Moderator
  • The user is an active CRM user and the Restricted Access Mode option is not set. However when was digging out these details I have discovered that the users Domain Logon Name is different to their Last Name details and primary email details i.e. their maiden name is down for their Domain Logon Name.

     

    I know its just a name change, but is it possible that there is a profile conflict causing errors??

    Wednesday, June 4, 2008 9:30 AM
  • The name change is what's causing the problem. CRM identifies the user by matching the AD login name against the DomainName attribute in the systemuser entity in CRM, and if they don't match, no data will be returned (you can see this by looking at the SQL function fn_FindUserGuid).

     

    As to resolving it, I don't think you've got a supported way to do this. What I'd do is update the DomainName attribute of this user directly in SQL, though this is unsupported

    Wednesday, June 4, 2008 10:12 AM
    Moderator
  • Many thanks the issue has now been resolved. Being a bit of an SQL virgin it took a little while to find the database to amend but it's done the trick.

    Thursday, June 5, 2008 9:55 AM