locked
CRM 2011 Install 'There are currently no logon servers available to service the logon request' RRS feed

  • General discussion

  • Hi,

    I uninstalled a CRM deployment with the intention of reinstalling and got the above error.  The error did not happen with the original install. 

    Since many changes had been made on the server, I tried a new server in a new VM and got the same error. 

    I am using separate setup, service and application pool accounts (just to be safe, the first two are domain admins).  I have tried disabling the firewall on the local network, nothing makes any difference.

    Has anyone got received this error on installation and does anyone have any advice?

    Monday, September 19, 2011 2:12 PM

All replies

  • Just to be clear, this is happening at the very end when the install program performs checks and the failure is in the CRM User Input section.  I have verified and reverified all accounts, passwords and privileges.  There do not seem to be any other domain issues and I can ping DC servers without issue.

    Monday, September 19, 2011 2:44 PM
  • From the top of my head, it seems that when set-up tries to validate those credentials against the domain controller.

    However, you did manage to log-in with a domain account in your CRM server in order to run the set-up. Probably because the credentials are cached?

    In order to troubleshoot this I would try logging in into the CRM server with the service accounts you have created. Perhaps you can take it from there?

     


    MCC, MCP, MCTS
    Tuesday, September 20, 2011 10:29 AM
  • The error being raised is clearly not the actual error.  I can logon with any number of accounts to the server; communication with the domain controller outside of this issue is apparently functioning normally.

    In fact, if the password is mistyped for any of the service accounts, the error indicates an invalid account or password.  Otherwise, the error from the subject line results. 

    Also, the other items in the install checklist, including IIS, SQL Server, Reporting Services and Active Directory are all valid.  It does seem odd that there are no logon servers available but AD checks out?  Another indication that the error message is not entirely accurate.

    We have even tried recycling and selectively making particular logon servers available by taking secondary ones offline.

    Tuesday, September 20, 2011 8:05 PM
  • I assume you don't have any firewall rules between the Dynamics CRM server and the Domain Controler, correct?

    Reason I am asking is because a while ago I had a similar issue (if the password is mistyped for any of the service accounts, the error indicates an invalid account or password.  Otherwise, the error from the subject line results) in a network segment behind a Netscreen firewall. Years later I also observed a similar result with a Checkpoint firewall.

    Which account are you using to install Dynamics CRM? Is this account a full domain admin, or did you manually provided this user with the minimum Active Directory rights into the necessary OU?


    MCC, MCP, MCTS If you find this post helpful then please "Vote as Helpful" and "Mark As Answer".
    Wednesday, September 21, 2011 12:38 PM
  • I worked with Microsoft, both CRM and network support, on this issue for a long time.

    CRM server Windows 2008 R2

    SQL Server (running SSRS) 2008 R2 on separate Windows 2008 R2

    Using 3 accounts to install - domain admin to run the install, another to be used for deployment & application services, and a final one to be used for sandbox and async services.

    Final resolution was to apply spn at the domain level to http/crmserver and http/crmserver.domain.com for the account being used to install.  Makes no sense but it worked.

    Appears to be some sort of strange installation bug with CRM - the network support resource was not happy with the final resolution, but it did install successfully.

     

    Friday, October 7, 2011 12:49 PM