The report cannot be displayed.(rsProcessingAborted) RRS feed

  • Question

  • Hi guys,

    Currently I'm facing SSRS problem. When I run the report, it will show like this.

    When I see inside the reporting service log, it show this error.

    processing!ReportServer_0-1!d18!03/06/2014-15:00:08:: e ERROR: Throwing Microsoft.ReportingServices.ReportProcessing.ReportProcessingException: , Microsoft.ReportingServices.ReportProcessing.ReportProcessingException: Cannot create a connection to data source 'Adventure_Works_Cycle_MSCRM'. ---> Microsoft.Crm.Reporting.DataExtensionShim.Common.ReportExecutionException: Immediate caller NT AUTHORITY\NETWORK SERVICE has insufficient privilege to run report as user S-1-5-21-1311266088-118511792-1381041710-500.
       at Microsoft.Crm.Reporting.DataExtension.Common.ExceptionManager.Assert(Boolean condition, String message)
       at Microsoft.Crm.Reporting.DataExtension.Common.DataExtensionConnectionBase.ValidateCaller(SecurityIdentifier user)
       at Microsoft.Crm.Reporting.DataExtension.Common.DataExtensionConnectionBase.<>c__DisplayClass1.<Open>b__0()
       at Microsoft.Crm.Reporting.DataExtension.Common.ExceptionManager.HandleUnsafeException(Action body)
       at Microsoft.Crm.Reporting.DataExtensionShim.Common.ICrmDbConnectionExtension.Open(String userSid)
       at Microsoft.Crm.Reporting.DataExtensionShim.Common.SrsExtConnectionBase.Open()
       at Microsoft.ReportingServices.Diagnostics.DataExtensionConnectionBase.OpenDataSourceExtensionConnection(IProcessingDataSource dataSourceObj, String connectString, DataSourceInfo dataSourceInfo, String datasetName)
       --- End of inner exception stack trace ---;
    Can you guys help me to solve this problem? Already facing this problem for 2 weeks :-(
    Friday, March 7, 2014 1:33 AM

All replies

  • Try running report directly from the server, sometimes it gives you a better error message.

    Damian Sinay

    Friday, March 7, 2014 9:38 AM
  • Hi Damian,

    Will try and give you the result :-)

    Friday, March 7, 2014 9:47 AM
  • Just had a similar issue on a CRM 2013 box. Turns out the data source in the custom reports folder was causing the issue. Running the reports on the report server failed with a more descriptive error. I edited the report properties and pointed it to the data source in the standard reports folder, and it was running.

    This behaviour started after installing UR1.

    Now, solving the issue is a mystery. Turned out that, while trying various things, spinning another organization in the same environment made the reports work again.

    I have no explanation as to why that worked, it doesn't make much sense.

    Friday, March 7, 2014 7:14 PM
  • This seems you create an sql based report and also used main table in reaple of filtered view.

    If you do so , go to your reporting server and click manage on your report ,

    provide database credentials and test the connection.

    then run your report.

    Hope this helps. ----------------------------------------------------------------------- Santosh Bhagat If this post answers your question, please click "Mark As Answer" on the post and "Vote as Helpful"

    Saturday, March 8, 2014 4:14 AM