none
HOw to turn off automatic router config in WHS? RRS feed

  • Question

  • Ok, I guess that this might be the opposite of what people generally wants - but still...

    Bought a Scaleo Home Server yesterday and have been playing with it som since then.

    No I discover that router config with UPnP seems mandatory, and since I want to have control (I mean - what would happen If  I have several servers on my home network) - and most of all have my http-server on another machine - this is really bad.

    I've foud the 'Router Control' Add-In and hoped that this would solve my problem, but unfortunatley not...


    So to the question: Is there a way to turn upp the automatic router config in WHS, and how to do it?

    Regards etc.
    Wednesday, August 5, 2009 11:56 AM

All replies

  • You can't disable UPnp in WHS instead disable UPnp in your router and configure the port forwarding manually.
    Ports 80, 443 and 4125 should be forwarded to your WHS.

    Martin
    LightsOut - Power Management for Windows Home Server http://www.home-server-blog.de/add-ins/lightsout/#en
    Wednesday, August 5, 2009 12:11 PM
    Moderator
  • This unfortunately really isn't all that helpful... I have other things on my router that use uPnP and I'd like them to continue to do so, but I do not want the WHS to try to grab 80 and 443... Other things are using them.

    What I'd really prefer is that it enable its web sites on itself, and allow me to handle how I want them forwarded from the outside, probably through a proxy. A little more complicated of needs than the average user, but I wish it at least supported the option to let me try.
    Friday, August 14, 2009 6:37 PM
  • Its most likely not supported but you can always change the ports of which IIS responds to.  Either change WHS (not supported) or your secondary system.
    Wednesday, August 26, 2009 3:10 PM
  • This unfortunately really isn't all that helpful... I have other things on my router that use uPnP and I'd like them to continue to do so, but I do not want the WHS to try to grab 80 and 443... Other things are using them.

    What I'd really prefer is that it enable its web sites on itself, and allow me to handle how I want them forwarded from the outside, probably through a proxy. A little more complicated of needs than the average user, but I wish it at least supported the option to let me try.
    This is an "either/or" situation if you want to stick with supported configurations. Either you have Remote Access on your server enabled, and UPnP on your router enabled, in which case your server will try to configure ports 80, 443, and 4125 to point to itself, or you disable one, in which case you manually configure all forwarding for servers that are currently using UPnP (if that's what you turn off) or you don't have a Remote Access web site on your server (if that's your choice).

    Your final option is to set up a reverse proxy server and forward everything from your router to that, and then let that take care of forwarding requests appropriately. This is what I would do if I needed to forward some traffic on ports 80 and 443 to one internal machine, and other traffic to a different machine.

    You can also submit a product suggestion on Connect.

    I'm not on the WHS team, I just post a lot. :)
    Wednesday, August 26, 2009 4:26 PM
    Moderator
  • If you are comfortable editing the registry, you can remove ports 80, 443, and 4125 from the UPnP settings of the WHS. Be Sure To Back Up The Registry Before Doing This!

    1. Go to
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows Home Server\Port Forwarding Service
    in the registry

    2. Go to the External Ports subdirectory
    • Remove the entry "80"
    • Remove the entry "443"
    • Remove the entry "4125"
    3. Go to the Internal Ports subdirectory
    • Remove the entry "80"
    • Remove the entry "443"
    • Remove the entry "4125"
    4. Go to the Protocol subdirectory
    • Remove the entry "80"
    • Remove the entry "443"
    • Remove the entry "4125"
    This should stop the WHS from using these ports in the UPnP configuration.
    • Proposed as answer by kingslaye505 Thursday, August 27, 2009 12:47 AM
    Wednesday, August 26, 2009 8:15 PM
  • Just want to add: No, you do NOT want to "back up the registry before doing this"... that's crap newb-helping-newb advice. If you try to "restore" your registry from this "backup" you're quite likely to cripple the whole computer... just FOLLOW THE DIRECTIONS and you can't hurt your computer by editing one value. If you did, you couldn't restore that "backup" anyway.

    Anyway, I'm bumping this to add this comment, as well as to mention my reason for removing auto port forwarding on my WHS system: WHS is giving my router the wrong damn address in UPnP! It's telling my router (192.168.4.1) to forward port 80, 443, and 4125 to a completely off-LAN address used on a VPN adapter (5.x.x.x). I don't know where the heck WHS got the nerve to screw with my port configuration like that, since the port forwarding was already set up correctly using manual settings! So I need to turn this off to prevent WHS from screwing up my port forwarding...

    And yeah, it's probably the exact opposite of what the average Joe home user wants to do, but the average Joe home user probably doesn't have like 5 Internet-facing services running on their home server either ;)

    Tuesday, February 8, 2011 10:19 PM
  • Just want to add: No, you do NOT want to "back up the registry before doing this"... that's crap newb-helping-newb advice. If you try to "restore" your registry from this "backup" you're quite likely to cripple the whole computer


    I disagree, they should backup their registry, but not the entire registry.  Just export that node or branch of the registry that you are modifying.  Don't backup and expect to restore the entire registry, just import that node of the registry that you are modifying if you later need to restore back to the original settings.

     

    FYI,  I disabled UPnP on my linksys e3000 router and WHS would send out annoying portfwd service failing messages which became annoying.  So I following kinglsaye505 instructions which proved very helpful.

     

    Thanks

    Friday, March 25, 2011 7:31 PM