none
Automatically install application on burst Azure nodes

    Question

  • I have several files that I need deployed to the Azure nodes on my cluster.  I have a batch file that sets everything up correctly, except for one application setup that I'm trying to run.  The code in the batch file I use is start /w "%CCP_PACKAGE_ROOT%\App\Setup.exe" /S /v /qn.  if I try to run this manually from a command prompt, the installation is not silent.

    I can run the command clusrun /scheduler:%HEADNODE% /nodegroup:azurenodes "%CCP_PACKAGE_ROOT%\App\Setup.exe" /S /v /qn from the head node.  However the limitation with that is that if I provision more nodes on the fly, I will have to re-run the command.  I would like this step to be automatically handled each time a new Azure node is provisioned and brought online.

    Friday, June 12, 2015 6:17 PM

All replies

  • I suppose there is issue for the setup run correctly in some cases. If it writes logs, you can have a check on that. Also check the exit code. And meanwhile, you can check alternatives. for examples:

    1. As you said it runs fine when install from command prompt. how about try start /w cmd /c .....

    2. Thus you can think about making the app install a one time windows scheduled task.

    3. Use script to bring azure nodes online from the headnode, and within the script to clusrun app install before bring the  azure node oneline.


    Qiufang Shi

    Monday, June 15, 2015 3:07 AM
  • Hi,

    Thanks for the feedback.  However, the issue is not the installation of the software so much as it's getting it to set up silently.  The /qn flag is completely ignored by the Azure cluster.  I'm not sure what is happening on provision but when entering the command manually into a cmd window, the installer Window/wizard pops up.  However, it does run silently if I use the clusrun command from the head node (a local 2012 R2 server).  Since it does work silently in certain circumstances, I would like to know what is the reason behind the discrepancy?

    As for the one-time Windows scheduled task, can I schedule it upon provision of the node?  This is not needed when bringing the nodes online itself, but rather when they are first added to the cluster.



    Running msiexec.exe /i "%CCP_PACKAGE_ROOT%\App\Setup.exe" /qn /Lv* "D:\ManualLog.txt" ALLUSERS=1 at the command line gives me the error MainEngineThread is returning 1620.  However, the application runs fine when using the clusrun command as mentioned in my initial post.
    • Edited by KWilliams1 Monday, June 15, 2015 8:53 PM
    Monday, June 15, 2015 3:28 PM
  • clusrun didn't do any magic, it just run the command as admin on the compute node (Including azure nodes). Please double confirm your user account and environment variables 

    What application you are installing? We may have a check as well at our side.


    Qiufang Shi

    Tuesday, June 16, 2015 3:12 AM
  • I'm convinced it's not a permissions issue because in the same start up batch script, I use the setx command with the -m flag and the environment variables are set without issue.  It's not that the application won't install, it's that it's not installing silently.  The -qn flag is ignored when running it manually from the command line in the Azure node; if I continue to the wizard manually, the software does install without issue.  I'm assuming it's also an issue with the startup script (there is no visual feedback during provisioning so I can't know for certain).  Conversely, the -qn flag works flawlessly using clusrun and installs the software with no UI, as expected/desired.
    Tuesday, June 16, 2015 3:53 PM
  • The issue is currently partially resolved.  The space needed to be eliminated after the /v command and it currently works via the command window.  The oddness there is that the clusrun command ran quietly, even though the space was used in that command call.

    However, the problem remains where the application will not install via batch file on Azure node provision.  If I log in and run the batch file manually, it does install the software, but on startup, not at all.

    i have tried the start command with the /w flag, as well as simply calling the executable and using a timeout command in the next line.  So far to no avail.


    • Edited by KWilliams1 Monday, June 22, 2015 7:16 PM
    Monday, June 22, 2015 7:15 PM
  • Hi,

    You can configure startup script on Azure node template,  please refer to

    https://msdn.microsoft.com/en-us/library/jj899632(v=ws.10).aspx

    Tuesday, June 30, 2015 5:21 PM