locked
NoReplyAllAddin - Not loaded. RRS feed

  • Question

  • Gavin, I tried to install the 3.0 add-in, but I actually had Outlook and Lync running during the install.  No amount of uninstallation or Registry tweaking has got it working for me.  The error the Outlook gives is:

    Load Behavior: Not Loaded. A runtime error occurred during the loading of the COM Add-in.

    One colleague installed it while Outlook and Lync were shut down and was successful, another did it with Lync still running and has the same problem I have.  Do you have any suggestions on how to troubleshoot this?

    Wednesday, February 27, 2013 3:49 PM

All replies

  • Gavin, I am Raymond's colleague who was able to successfully load the add-in. I plan to use system restore to revert a system on which the installation failed back to pre-installation of this add-in. Is there a better process to follow to correct this issue, or is a system restore going to be the best route?
    Wednesday, February 27, 2013 7:39 PM
  • Outlook (or Lync) running should make no difference, though the add-in won't show up until you restart Outlook - so that's not the problem...

    Did you install the .Net runtime? What version of Office are you using? Do you have many other add-ins?

    Thursday, February 28, 2013 6:30 AM
  • Uninstalling the add-in from Progs & Features should remove everything apart from user config, so should be good enough. If you want to zap that config, it's in the registry under HKCU\Software\Microsoft Research Ltd\NoReplyAll.
    Thursday, February 28, 2013 6:34 AM
  • Hi Gavin,

    Having same issues.  Have removed the installation, tried repairing the installation with no affect.   .net 4 installed and VSTO 4 using outlook 2010!

    Any other suggestions?   Other add-ins have installed correctly.

    Thanks,

    Tony

    Thursday, May 9, 2013 12:55 PM
  • Hi Tony

    A few thoughts, but I am clutching at straws, I'm afraid: first, you're not running 64 bit Office, are you? 64 bit Outlook looks in a different part of the registry for add-ins compared to 32 bit - someone raised that specific issue elsewhere in the forum, and there is a workaround - http://social.microsoft.com/Forums/en-US/researchdesktop/thread/595542e6-6564-40b9-ab6a-858fdce830af (and I intend to address this more fully in the next release).

    Second, I'm not quite sure what it meant by ".NET Programmability Support," but when you install Office (or re-run the installer and select "change"), on the details page, each application shows an item of that name. Can you check that this is enabled for Outlook since it might be something the add-in requires to be present. (If it's not enabled, you should be able to set it and continue with the setup process.) Of course, if some of the other add-ins you're using are .NET ones, then this must be present already, whatever it is.

    In Outlook itself, if you go to Options -> Add-Ins, is NoReplyAll on the list at all (perhaps under "Disabled Application Add-ins" at the bottom). If it is, then the thing is available to Outlook, just not running for some reason. If it is there, click "Go" at the bottom of the page and check the box beside the add-in on the dialog box that appears: when you OK that, Outlook will attempt to load the add-in. If it's still not present, repeat that process and see what message appears in that dialog box - sometimes it gives an add-in specific error message which might help with tracking down the problem.

    Finally, it is possible that different add-ins are fighting with each other. For example, one add-in might require .NET 1.1 and when Outlook then tries to load an add-in which requires a later version, it gives up. I can't remember the details, but it certainly used to be the case that some versions couldn't co-exist at all. You could try disabling other add-ins (via the checkboxes mentioned above) to see if NoReplyAll starts - but that only makes sense if NoReplyAll is on the add-in list in the first place; this won't make it suddenly put in an appearance!

    Friday, May 10, 2013 6:20 AM