locked
Loose connection to my WHS RRS feed

  • Question

  • Have a long lasting problem. My WHS loose contact with my network after a couple of hours. Something between 10-24 hours and everyday the same. After that I cannot access it (console or through mstsc.exe).  I do not see the computer on my network.

    Need to manually restart the WHS and then everything is OK

    I have a Dlink router DIR-615.

    I am thankful for ideas on how to troubleshoot this annoying problem.
    magnus
    Friday, December 19, 2008 5:04 AM

Answers

  • Hi Olaf
    Just wants to update you on the problem which I think that I have now solved. The server has worked reliable for over a month now.

    I have done 2 things, one or both have solved the issue.

    • The server was placed in a small room where the temperature could raise. Have managed to get more cold air into the room.
    • Have removed an extra system program that was controling or rather tried to reduce the temperature of the processor, by probably put it into a "sleep-mode". The program was more intending to decrease the noise from the fans.

    Thanks for all your support and help. / Magnus


    magnus
    • Marked as answer by Jagilund Saturday, March 7, 2009 7:25 AM
    Saturday, March 7, 2009 7:19 AM

All replies

  • Have you made any changes to your WHS?  Is it custom or HP?  What LAN card do you have and have you updated your drivers?  Can you look at your logs to see if there are any hints there?
    athlon 3400, 2gb ram, 9 drives totaling about 3.5 tbs.
    Friday, December 19, 2008 6:22 AM
  • Magnus,

    Is this a 'home built' server and if so, what did you use?
    Also, check things like power-saving settings on the server itself, and on the Lan card that you have installed.

    Colin



    If anyone answers your query successfully, please mark it as 'Helpful', to guide other users.
    Friday, December 19, 2008 11:33 AM
    Moderator
  • Hi Magnus,
    as Colin said, check the settings for the network card in the WHS.
    To do that, log in locally to your WHS.
    • In Start menu right click My Computer and select Properties.
    • On the Hardware tab select Device Manager.
    • Double click the network adapter and click the Power Management tab.
    • Uncheck Allow the computer to turn off this device to save power. and click OK.
    You should also apply the latest network drivers to your server and check the event log for network or ressource related errors and post them here for more on the point support.

    Best greetings from Germany
    Olaf
    Friday, December 19, 2008 12:29 PM
    Moderator
  • Sorry for late answer. Been traveling.

    the server is a homebuilt server. AMD Athlon (m) Dual Core, Integrated network connectionon the motherboard (NVIDIA nForce Networking Controller + a separate installed D-Link DGE-528T Gigabit Ethernet Adapter

    Have tried to update all drivers.

    I have the same problem if I use 1 cable in any of the netconnection or even 2 cables. Goes down every time within 24 hours

    Please suggest where to find the correct logs ?
    magnus
    Tuesday, January 13, 2009 10:34 PM
  •  Second answer to all

    I have unchecked the power-saving settings on both cards.


    I have problems to establish the correct time when the server goes down. Anyone knows of a progarm to check the network and get a log (time) when a unit is no longer accessable
    magnus
    Tuesday, January 13, 2009 10:41 PM
  • Jagilund said:

    Sorry for late answer. Been traveling.

    the server is a homebuilt server. AMD Athlon (m) Dual Core, Integrated network connectionon the motherboard (NVIDIA nForce Networking Controller + a separate installed D-Link DGE-528T Gigabit Ethernet Adapter


    Hi Magnus,
    two network cards? Are both connected? Disable one of the cards (multihomed servers have often been the cause for name resolution problems).

    Best greetings from Germany
    Olaf
    Tuesday, January 13, 2009 11:09 PM
    Moderator
  • Hi Olaf

    They are never connected at the same time. But I will try to disable one of them completely and monitor the time. I made yesterday evening a reboot of server and router at the same time. I will try to establish the exact time when the connection is lost and study the logfiles. But I am very unsure of where to look and for what.

    Any ideas ?

    Thanks for your support / Magnus
    magnus
    Wednesday, January 14, 2009 9:20 PM
  • Hi Magnus,
    some more things you could check:
    The network drivers are up to date?
    Can you see the shares of the server if the connection is lost (Shared folders on server shortcut)?
    Can the shares accessed from the server itself, if the clients cannot any more?
    If you ping the server by name and by IP address, what is the result? Would the name still resolve to the proper IP address?
    Best greetings from Germany
    Olaf
    Wednesday, January 14, 2009 10:19 PM
    Moderator
  • Hi Olaf

    Networkdrivers updated.

    when connection is lost
    Cannot see the shares,  (shortcut)
    Cannot access the server through Remote desktop (mstsc.exe)

    Ping works OK both on name and IP-adress

    Additional : Cannot see or even acces the list of the computers in workgroup (when server connection is lost)

    Magnus

    magnus
    Friday, January 16, 2009 5:35 AM
  • Hi Magnus,
    please post the output of ipconfig /all (to be entered in command prompt) on the server and one client.

    You can also try to copy following lines into notepad, save it as pool.reg on a server share and apply it to the server. Although it is only a shot into the blue, it helped me on some clients and servers with network problems (usually there was some message indicating about a lack of ressources if trying to map a network drive to the server).

    Windows Registry Editor Version 5.00

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management]
    "PagedPoolSize"=dword:ffffffff
    "PoolUsageMaximum"=dword:00000030


    Best greetings from Germany
    Olaf
    • Marked as answer by Jagilund Saturday, January 17, 2009 5:45 AM
    • Unmarked as answer by Jagilund Saturday, January 17, 2009 5:45 AM
    Friday, January 16, 2009 7:42 AM
    Moderator
  • Hi Olaf

    I have sent the info as files in a separate mail to you / Magnus
    magnus
    Saturday, January 17, 2009 2:07 PM
  • Jagilund said:

    I have sent the info as files in a separate mail to you / Magnus


    Hi Magnus,
    you can mark text in a DOS box by clicking the system menu (left box in the title bar), select Edit/Mark, mark with the mouse and hit Enter. This brings the marked text into the clipboard.

    I see two things in your screenshots. One is the DNS suffix - try to avoid those in your DHCP configuration. But since you can ping the server, this should not play the primary role.
    The other detail - your client is also multihomed in the same subnet. Disable either wireless or wired connection. Both at the same time can confuse network traffic a lot. I.e. Client requests something from server and expects the answer from the wired interface, server answers, but delivers to the wireless interface to simplify the explanation what could happen without much technical background. (And it's also only speculation, if this is really, what happens.)

    You could also open Network in Control Panel on the client and ensure, that the wanted network interface is on top in Advanced/Advanced Settings menu.
    In the properties of the network cards also check the Power Management tab - and disable the option to allow the computer to turn off the interface.
    Best greetings from Germany
    Olaf
    Saturday, January 17, 2009 5:10 PM
    Moderator
  • Hi Olaf
    Just wants to update you on the problem which I think that I have now solved. The server has worked reliable for over a month now.

    I have done 2 things, one or both have solved the issue.

    • The server was placed in a small room where the temperature could raise. Have managed to get more cold air into the room.
    • Have removed an extra system program that was controling or rather tried to reduce the temperature of the processor, by probably put it into a "sleep-mode". The program was more intending to decrease the noise from the fans.

    Thanks for all your support and help. / Magnus


    magnus
    • Marked as answer by Jagilund Saturday, March 7, 2009 7:25 AM
    Saturday, March 7, 2009 7:19 AM