none
The program '[12104] iisexpress.exe' has exited with code -1073741819 (0xc0000005) 'Access violation'. RRS feed

  • Question

  • My program keeps crashing after a very short time of less then 2 minutes. I would be able to start debugging and it will then crash and in the output it will show me that issexpress has exited and there is access violation. I tried using a different project thinking that it might be my code but the same issue came up. I tried reinstalling visual studio but it still doesnt work. I tried running visual studio with administrator rights and it still doesn't work. Can someone please help thank you
    • Moved by CoolDadTx Monday, January 22, 2018 4:26 PM ASP.NET related
    Monday, January 22, 2018 11:08 AM

All replies

  • It's beyond me as to why IIS Express is even being used. I have never seen it used on any client's development machine.  I don't even use IIS Express in my home development environment, which is no better than the VS Web developer trash that use to be part of VS that IIS Express replaced.

    I always have Web development projects through VS deployed to local IIS so that the solution can be run and debugged through Visual Studio against local IIS and eliminate IIS Express out of the picture.

    https://msdn.microsoft.com/en-us/library/ms178108.aspx

    <copied>

    To specify the Web server for a Web application project

    <end>

    One must start VS using Run As Administrator.

    You can also try the IIS forum about IIS Express.

    https://forums.iis.net/

    Monday, January 22, 2018 12:42 PM
  • Please post questions related to ASP.NET and web development in the ASP.NET forums.

    Michael Taylor http://www.michaeltaylorp3.net

    Monday, January 22, 2018 4:26 PM