locked
Outlook plugin for CRM 4.0 RRS feed

  • Question

  • Hi,

    I have installed CRM 4.0 on my server.

    In order to access the CRM, I use this URL: http://<server IP>:<port>/  - then I get the pop up window to enter my username and password as it is set in my AD.

     

    When I try to configure the Outlook plugin, it asks me for the URL of the system - I enter the same URL as stated above, and then I get an error saying "The configuration wizard cannot connect to the Microsoft CRM server. This might indicate that the server is down".

    This is incorrect since I am using the CRM in the background as well and it is working fine.

     

    What should I do in order to correct this ?

     

    Thanks

     

    Eyal Nevo

    eyal@marketechcorp.com

     

    Tuesday, October 28, 2008 7:31 PM

Answers

  • I am not sure why you are having issues with the Outlook Client.  I found this article on updating Outlook to use a port number so this appears to be supported. 

     

    Maybe you could try loading the Outlook client without the reference to the port number to see if it will load without error.  Then go back and make the update referenced in the article.  I know this is not the preferred method but maybe it would work. 

     

    Here are the steps if you want to try this approach:

    Update the components that are affected by the new Microsoft Dynamics CRM Web site URL

    You must update the Microsoft Dynamics CRM client for Outlook, Microsoft Dynamics CRM Data Migration Manager, and Microsoft Dynamics CRM-Exchange E-mail Router to use the new Microsoft Dynamics CRM Web site URL.

     

    http://support.microsoft.com/kb/947423

    Microsoft Dynamics CRM client for Outlook

    To update the Microsoft Dynamics CRM client for Outlook to use the new URL, use one of the following methods.

    Method 1: Have each client run the Configuration Wizard utility

    1. Click Start, click Programs, click Microsoft Dynamics CRM 4.0, and then click Configuration Wizard.
    2. Follow the steps in the Configuration Wizard utility, and then enter the new URL for the Microsoft Dynamics CRM server.
    Note If you set up the IFD URL, you have to clear the Use the same Web address check box. When you do this, you can use the new IFD URL when you log on to the Microsoft Dynamics CRM Web site over the Internet.

     

    Method 2: Update the registry subkeys on each client computer

    1. Click Start, click Run, type regedit, and then click OK.
    2. Locate the following registry subkey:
    HKEY_CURRENT_USER\SOFTWARE\Microsoft\MSCRMClient
    3. Right-click the following registry entries, click Modify, and then update the value by entering the updated port number:
    IntranetDiscoveryUrl
    IntranetServerUrl
    IntranetWebAppUrl
    PlatformRoot
    Note If you set up the IFD URL, you have to update the following registry entries by entering the updated port number:
    ExtranetDiscoveryUrl
    ExtranetServerUrl
    ExtranetWebAppUrl

     

    Also, check out this post as there are several possible solutions:

     

    http://www.eggheadcafe.com/software/aspnet/31397061/crm-4-outlook-client-can.aspx

     

    Thursday, October 30, 2008 12:46 PM

All replies

  • Hi

     

    Have you tried using the CRM server's IP address instead of the URL?

     

    Regards,

     

    Douglas

    Wednesday, October 29, 2008 10:09 AM
  • Try adding your CRM url to trusted sites in IE.  Have you designated a special port for CRM and that is why you are putting the port number at the end of the URL?  Also, ensure your Intranet settings are set to login automatically.  I think once  you resolve the login prompt with the browser, the Outlook client will work as expected but I could be wrong.  I have seen this clear up the issue.

    Wednesday, October 29, 2008 10:40 AM
  • I am using a port reference because I am using a specific port to access the system.

    I have added CRM to my trusted sites and I have set it to auto-login.

    Now when I browse to the CRM from ID, I am not prompted for a username and password - however, in the outlook configuration tool, I still get the same error.

    Wednesday, October 29, 2008 11:29 PM
  • I am not sure why you are having issues with the Outlook Client.  I found this article on updating Outlook to use a port number so this appears to be supported. 

     

    Maybe you could try loading the Outlook client without the reference to the port number to see if it will load without error.  Then go back and make the update referenced in the article.  I know this is not the preferred method but maybe it would work. 

     

    Here are the steps if you want to try this approach:

    Update the components that are affected by the new Microsoft Dynamics CRM Web site URL

    You must update the Microsoft Dynamics CRM client for Outlook, Microsoft Dynamics CRM Data Migration Manager, and Microsoft Dynamics CRM-Exchange E-mail Router to use the new Microsoft Dynamics CRM Web site URL.

     

    http://support.microsoft.com/kb/947423

    Microsoft Dynamics CRM client for Outlook

    To update the Microsoft Dynamics CRM client for Outlook to use the new URL, use one of the following methods.

    Method 1: Have each client run the Configuration Wizard utility

    1. Click Start, click Programs, click Microsoft Dynamics CRM 4.0, and then click Configuration Wizard.
    2. Follow the steps in the Configuration Wizard utility, and then enter the new URL for the Microsoft Dynamics CRM server.
    Note If you set up the IFD URL, you have to clear the Use the same Web address check box. When you do this, you can use the new IFD URL when you log on to the Microsoft Dynamics CRM Web site over the Internet.

     

    Method 2: Update the registry subkeys on each client computer

    1. Click Start, click Run, type regedit, and then click OK.
    2. Locate the following registry subkey:
    HKEY_CURRENT_USER\SOFTWARE\Microsoft\MSCRMClient
    3. Right-click the following registry entries, click Modify, and then update the value by entering the updated port number:
    IntranetDiscoveryUrl
    IntranetServerUrl
    IntranetWebAppUrl
    PlatformRoot
    Note If you set up the IFD URL, you have to update the following registry entries by entering the updated port number:
    ExtranetDiscoveryUrl
    ExtranetServerUrl
    ExtranetWebAppUrl

     

    Also, check out this post as there are several possible solutions:

     

    http://www.eggheadcafe.com/software/aspnet/31397061/crm-4-outlook-client-can.aspx

     

    Thursday, October 30, 2008 12:46 PM