locked
CRM 2015 Installing fails: Action MicrosoftCrm.Setup.Server.BackupUpgradeDataAction Failed Could not find the file 'C:\intpub\wwwroot\web.config'. RRS feed

  • Question

  • I don't have many issues... but when I do it is usually a bad one.   

    I took my CRM 2013 install running on Server 2008 and did an upgrade to server 2012 R2.  No issues.   All updates applied.  From there I run the CRM 2015 installer to run the upgrade..... Yes, running as admin, and after the "Pre Flight Check"  everything is good.   From there the install starts to copy files.....  I get this error. 

    00:16:43|   Info| CrmAction execution time; BackupUpgradeDataAction; 00:00:03.0020974

    00:16:43|  Error| System.Exception: Action Microsoft.Crm.Setup.Server.BackupUpgradeDataAction failed. ---> System.IO.FileNotFoundException: Could not find file 'C:\inetpub\wwwroot\web.config'.
       at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
       at System.IO.File.InternalCopy(String sourceFileName, String destFileName, Boolean overwrite, Boolean checkHost)
       at Microsoft.Crm.Setup.Server.BackupUpgradeDataAction.Do(IDictionary parameters)
       at Microsoft.Crm.Setup.Shared.CrmAction.ExecuteAction(CrmAction action, IDictionary parameters, Boolean undo)

    I am finding no references to this issue any where.   Looking for suggestions.   It appears that this file does not actually exist.   Somewhere during the upgrade maybe it got deleted.     I have put an old web.config file in this path, rebooted everything and still get the same error.

    Looking for some suggestions.

    Pierre Hulsebus

     

    Wednesday, January 28, 2015 5:49 AM

All replies

  • Nothing?

    Thursday, January 29, 2015 12:51 PM
  • Same issue, you ever get resolved?

    Sunday, April 26, 2015 4:56 PM
  • Sounds like a problem with the information about where the Crm website is installed. Crm uses 2 registry values 'website' and 'websitepath' under HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSCRM. Do these look correct, and is the Crm website under c:\inetpub\wwwroot, or elsewhere ?

    The last part of the 'website' value is the website id, which you can see in IIS Manager


    Microsoft CRM MVP - http://mscrmuk.blogspot.com/ http://www.excitation.co.uk

    Sunday, April 26, 2015 6:41 PM
    Moderator
  • I had this issue recently, in my situation I had CRM and ADFS on the same server. ADFS used the Default IIS website using port 80/443 ... and CRM was using local port 5555 and SSL port 444.

    The CRM IIS website ID was set to 2

    Then:

    under HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSCRM

    I set the registry key "Website" from "/LM/W3SVC/1"  to "/LM/W3SVC/2"

    Same registry location, i changed "LocalSdkPort" to my local port: 5555

    Lastly i set the registry key "ServerUrl" to "https://[Server Name]:444/MSCRMServices"

    Tuesday, August 4, 2015 1:22 AM