locked
Not sending workflow emails through outlook RRS feed

  • Question

  • Hi,

    This is the type of workflow I created:

    When a Lead is created or assigned an email automatically gets send to the Owner of the Lead.

    So to test this I create a Lead and make myself the Owner. The workflow succeeds and I can see the email in the history sent to myself. On that email activity in crm it says "this message has not yet been submitted for delivery. For more information, see help."

    But in Outlook I don't receive the email and it is also not in the sent items box.

    The whole creation of the workflow and the Lead I did in the CRM Outlook client so I was expecting it to work.

    Can anyone help me of how I can receive the email from the workflow in my outlook inbox?
    • Edited by ThunderSon Tuesday, June 30, 2009 10:31 AM
    Tuesday, June 30, 2009 9:46 AM

Answers

  • Normally this should work fine. - you might compare your settings to an unmodified version.

    Also Check to see if the mailserver on the VPC is running -

    You might also check to see if in the CRM menu in Outlook, under "options", "email tab",  if the 'allow email router to use my credentials' box is checked.
    Scott Sewell, CustomerEffective | http:\\blog.CustomerEffective.com | Twitter:@ScottSewell
    • Marked as answer by ThunderSon Tuesday, June 30, 2009 11:45 AM
    Tuesday, June 30, 2009 10:40 AM
    Moderator

All replies

  • Based on your question's title - is this in the demo VirtualPC downloaded from Microsoft?

    Scott Sewell, CustomerEffective | http:\\blog.CustomerEffective.com | Twitter:@ScottSewell
    Tuesday, June 30, 2009 10:17 AM
    Moderator
  • Yes it is...
    Tuesday, June 30, 2009 10:20 AM
  • Normally this should work fine. - you might compare your settings to an unmodified version.

    Also Check to see if the mailserver on the VPC is running -

    You might also check to see if in the CRM menu in Outlook, under "options", "email tab",  if the 'allow email router to use my credentials' box is checked.
    Scott Sewell, CustomerEffective | http:\\blog.CustomerEffective.com | Twitter:@ScottSewell
    • Marked as answer by ThunderSon Tuesday, June 30, 2009 11:45 AM
    Tuesday, June 30, 2009 10:40 AM
    Moderator
  • Ok I did not have the 'allow email router to use my credentials' option on.. I did that now.

    But it is still not working. If i send an email to myself through outlook it works. But when I for instance send a direct email from crm to myself as a crm user nothing happens.

    I have put the e-mail configuration to "microsoft dyanmics crm for outlook" on incoming and outgoing e-mail access.

    Anything else that might cause this problem?

    Tuesday, June 30, 2009 11:34 AM
  • Hhmm after restarting the email router and synchronising with crm it now works.. so the option 'allow email router to use my credentials' must have been the deciding factor.

    It works now :) thanks a lot.
    Tuesday, June 30, 2009 11:45 AM
  • Glad to hear it. Good luck with your evaluation.
    Scott Sewell, CustomerEffective | http:\\blog.CustomerEffective.com | Twitter:@ScottSewell
    Tuesday, June 30, 2009 11:48 AM
    Moderator