locked
Reporting Services: Document Map RRS feed

  • Question

  • Hello Experts,

    Quick question. I've been creating some CRM reports in Reporting Services, importing the rdl into CRM and running them from within CRM. Everything is going great, except that all reports in CRM open with a Document Map on the left side. I've included some matrixes in my reports and it would seem that the Document Map get's populated with the different categories of the matrixes.

    I want to disable these Document Maps - or at least not make them visible on the first screen when someone runs the reports, but I haven't found any parameter in Reporting Services to do so.

    Any ideas?

    Thanks a lot for your help,
    Manuel
    manuel_altermatt@hotmail.com
    Friday, January 8, 2010 2:59 PM

Answers

  • I just dealt with the same problem described in the initial post. In my case I had defined a Label for a matrix group (which you can get to by right-clicking the matrix group and selecting "Edit Group..."). I removed the label from there put it in the expression for group (which you get to by right-clicking the matrix group and selecting "Expression...").

    Thursday, September 23, 2010 7:05 PM

All replies

  • Hi

    Document Map is always on by default. you can turn it off by using any one the below ways. 

    Way 1:

    If you are calling the report through report server URL, you can restrict to hide it in the URL itself as below 
    http://localhost/ReportServer?/reportPath/&rc:DocMap=false

    Way 2:

    1. Open the report definition file in code viewer in Visual Studio or in Notepad. (Extire poece of code will be in XML)
    2. Find (Ctrl+F) the piece of code that has grouping. (Ctrl+F and find Grouping)
    3. Remove the value that is contained within <Lable></Lable> tag. 
        From: <Label>=Fields!Year.Value</Label>
        To: <Label></Label>

        DO NOT Delete the <Label></Label> tags!
    4. Repeat this for all the grouping occurences found.

    Way 3:

    1. Open the report rdl file in the design view.
    2. Select Group option.
    3. Click Edit Group.
    4. Click Gendral Tab.
    5. Remove the values in the "Document Map lable" box
    6. Repeat this steps for all the goups present in report.


    I would recomend Way 2.

    Regards
    Vinoth

    • Proposed as answer by Mayank Pujara Saturday, January 9, 2010 10:00 PM
    • Unproposed as answer by Manuel Altermatt Monday, January 11, 2010 8:03 PM
    Saturday, January 9, 2010 7:32 AM
  • Vinoth,

    Thanks a lot for your help. Given that I am calling the report from within CRM, only option 2 and 3 are valid for me.

    Option 3 makes sense, yet when I perform the steps that you mention (checking the labels), it turns out there are none set. The lable fields are empty. Weird.

    Option 2 I like best. I edited the XML as you said and though the Document Map actually lost it's different entries, it still remained visible upon calling of the report. To be honest, I actually don't care that much if the document map is populated or not. I simply would like it to be hidden upon calling of the report. Your solution seems to remove the entries of the document map but that doesnt hide it.

    Any ideas?

    Thanks
    Manuel
    manuel_altermatt@hotmail.com
    Monday, January 11, 2010 8:06 PM
  • Hi Manuel,

    I suggest open the report in visual studio and see if document label gets displayed when you see out put in  the SSRS Visual Studio..

    If it gets displayed then check which field gets displayed in report...and this field is added as label in document ..go to properties and make document map label blank..

    somewhere is Report document map label  is set so this needs to blank out  and once this is done then report wo'nt display document map..
     
    • Marked as answer by Jim Glass Jr Monday, January 11, 2010 8:53 PM
    • Unmarked as answer by Manuel Altermatt Monday, January 11, 2010 11:55 PM
    Monday, January 11, 2010 8:41 PM
  • MayankP,

    Thanks a lot for your answer. Similar to my other answer on this post, though I have been able to identify and clear the labels in the xml (rdl), unfortunately this has just cleared the document map but not removed it. CRM shows me an empty document map. Somehow I haven't been able to identify a "show document map" switch in the xml file.

    Any ideas?


    manuel_altermatt@hotmail.com
    Monday, January 11, 2010 11:58 PM
  • Hi Manuel.

    Did you solve this issue?

    Morten


    MoGA xrmdeveloper.dk
    Friday, September 17, 2010 9:40 AM
  • No, unfortunately I never did. I had to abandon this path and go for uploading the report on to Report Server and run it directly as a webpage. I couldn't get it to work through the report visualization engine of CRM. Thanks for asking though.
    manuel_altermatt@hotmail.com
    Friday, September 17, 2010 12:26 PM
  • I just dealt with the same problem described in the initial post. In my case I had defined a Label for a matrix group (which you can get to by right-clicking the matrix group and selecting "Edit Group..."). I removed the label from there put it in the expression for group (which you get to by right-clicking the matrix group and selecting "Expression...").

    Thursday, September 23, 2010 7:05 PM