locked
Windows Update capacity is suddenly OOC RRS feed

  • Question

  • This problem began with following error code while attempting to register msxml3.dll:

     

    "DllregisterServer in msxml3.dll failed. Return code was: 0x80004005"

     

    I found a previous thread (http://forums.microsoft.com/Genuine/ShowPost.aspx?PostID=2170252&SiteID=25 )and did the following

     

    1) Click “Start” button, then “Run”
    2) In the Run window, Type: regsvr32 msxml3.dll  <Click OK>
       (Note: This will register the msxml3.dll and the registry entry ‘HKEY_CLASSES_ROOT\MSXML.DOMDocument’ will be generated)
       If this does not work, the msxml3.dll may be missing or corrupt. Follow the below Fix (Part 2), in that case:

     Fix (Part 2):

    1) Go to the Microsoft XML Parser (MSXML) 3.0 Service Pack 7 (SP7) download page at:  http://www.microsoft.com/downloads/details.aspx?FamilyID=28494391-052b-42ff-9674-f752bdca9582&DisplayLang=en
    2) From the files available, download “msxml3.msi”
    3) Double click the file and follow the steps to install.
    4) Click “Start” button, then “Run...”
    5) In the Run window, Type: regsvr32 msxml3.dll  <Click OK> 
     

    The same problem remains unresolved. I then realized that my "Windows Update" (WU) capability went out of commission: whenever I visit the WU website I accept and load the ActiveX application & the website essentailly locks up. I'm not even given a scan button.

     

    I ran the MGA diagnostics executable which produced the following:

     

    Diagnostic Report (1.7.0066.0):
    -----------------------------------------
    WGA Data-->
    Validation Status: Genuine
    Validation Code: 0
    Online Validation Code: N/A
    Cached Validation Code: N/A
    Windows Product Key: *****-*****-9P24D-QPD2P-3DC3Y
    Windows Product Key Hash: NmIcd3FM62dykGhfxSkrHkLWexk=
    Windows Product ID: 76487-016-9431047-22909
    Windows Product ID Type: 5
    Windows License Type: Retail
    Windows OS version: 5.1.2600.2.00010100.2.0.pro
    CSVLK Server: N/A
    CSVLK PID: N/A
    ID: {0BB22ACC-4A8E-4CF4-B5B4-E175E921C7D6}(3)
    Is Admin: Yes
    TestCab: 0x0
    WGA Version: Registered, 1.7.36.0
    Signed By: Microsoft
    Product Name: N/A
    Architecture: N/A
    Build lab: N/A
    TTS Error: N/A
    Validation Diagnostic: 025D1FF3-171-1
    Resolution Status: N/A

    Notifications Data-->
    Cached Result: N/A
    File Exists: No
    Version: N/A, hr = 0x80070002
    WgaTray.exe Signed By: N/A, hr = 0x80070002
    WgaLogon.dll Signed By: N/A, hr = 0x80070002

    OGA Data-->
    Office Status: 100 Genuine
    OGA Version: N/A, 0x80070002
    Signed By: N/A, hr = 0x80070002
    Office Diagnostics: FCEE394C-2989-80070002_025D1FF3-171-1_70AFE6BE-1170-800401f3_70AFE6BE-116-800401f3_63BB5E84-433-800401f3_E2AD56EA-234-800401f3_16E0B333-80-800401f3_B4D0AA8B-911-800401f3

    Browser Data-->
    Proxy settings: N/A
    User Agent: Mozilla/4.0 (compatible; MSIE 6.0; Win32)
    Default Browser: C:\Program Files\Internet Explorer\iexplore.exe
    Download signed ActiveX controls: Prompt
    Download unsigned ActiveX controls: Disabled
    Run ActiveX controls and plug-ins: Allowed
    Initialize and script ActiveX controls not marked as safe: Disabled
    Allow scripting of Internet Explorer Webbrowser control: Disabled
    Active scripting: Allowed
    Script ActiveX controls marked as safe for scripting: Allowed

    File Scan Data-->

    Other data-->
    Office Details:

     

    Monday, November 26, 2007 7:20 PM

Answers

  • Hello Caved1Ver,

     

    Thank you for providing your MGA Diagnostic results for us to analyze.   I have tried different resolves surrounding possible scenarios for WGA based on the feedback and error codes received. The problem which you are experiencing is with Windows Update verses WGA and does not fall within the scope of WGA. 

     

    Your post provided good information. Error code 0x80004005 coupled with messaging DllRegisterServer in msxml3.dll failed.  Briefly I researched the error code you received and would like to provide you with some information. Please visit http://support.microsoft.com/kb/932628/en-usThe error message is a little misleading, because of course the computer is connected with the internet......in reality there is something on the computer or in its settings that is preventing the MS program from working with the MS servers. Quite often the cause may be a personal firewall program that has to be set (often called "creating a rule") to allow the updater program full access to the internet.  Also, some antivirus programs have rudimentary firewalls included and the same applies.  Less often there are antimalware programs installed that may be seeing the Updater's activity and thinking it is malware. Also there may be misconfigured Internet Service Provider (ISP) DNS servers which is out of your control. Maybe contact your ISP and ask if they have had any past compliations communicating with MS Windows Update site. 

    Please follow the Help and Support links on the Windows Updates page to find assistance in solving your Windows Updates difficulties.

     

    Or, visit the WU Solution Center here:  http://support.microsoft.com/ph/6527

     

    Or, have a look at the WU support forum:  http://www.microsoft.com/windowsxp/expertzone/newsgroups/reader.mspx?dg=microsoft.public.windowsupdate&lang=en&cr=US

     

     

        Another alternative should you not find resolve please submit a service request with Microsoft Product Support:  http://go.microsoft.com/fwlink/?LinkId=52029. Hopefully the above information will resolve your problem. Should it not then hopefully I have provided you with enough information to get a resolution. Take care and should you have future WGA problems please visit me again here :-).

     

     

    Thank you,

     

    Stephen Holm, MS

    WGA Forum Manager

    Monday, November 26, 2007 8:28 PM