locked
error when import organization RRS feed

  • Question

  •  

    when i try to impoet my organization after import database he give me this error:

    Code Snippet

    16:12:18| Error| Import Organization (Name=GulfProperty, Id=249716a5-84bc-dd11-913a-001ec9d47998) failed with Exception:

    Microsoft.Crm.CrmException: Unable to find metadata information for attribute new_serviceid

    at Microsoft.Crm.Workflow.ObjectModel.MetadataProvider.GetAttributeMetadata(EntityMetadata entityMetadata, String attributeName)

    at Microsoft.Crm.Workflow.ObjectModel.MetadataProvider.GetAttributeValueType(String entityName, String attributeName)

    at Microsoft.Crm.Workflow.EntityRuleSetDefinition.SetProperty(EntitySpecification entitySpecification, PropertySpecification property)

    at Microsoft.Crm.Workflow.WorkflowDefinitionVisitor.GenerateRuleSet(EntitySpecification entitySpec, RuleSet rules, String localParameterName, WorkflowStep referenceWorkflow, String referenceLocalParameter)

    at Microsoft.Crm.Workflow.WorkflowDefinitionVisitor.Visit(CreateStep createStep)

    at Microsoft.Crm.Workflow.ObjectModel.CreateStep.Apply(StepVisitorBase visitor)

    at Microsoft.Crm.Workflow.WorkflowDefinitionVisitor.Visit(WorkflowStep workflowStep)

    at Microsoft.Crm.ObjectModel.WorkflowServiceInternal`1.CreateDefinitionFromObjectModel(ExecutionContext context, WorkflowEntity definition, List`1 dependencies, List`1 customActivityIds)

    at Microsoft.Crm.ObjectModel.WorkflowServiceInternal`1.PublishInPlace(WorkflowEntity definition, ExecutionContext context)

    at Microsoft.Crm.Tools.Admin.ImportOrganizationInstaller.RepublishWorkflow(ExecutionContext context, WorkflowUIData workflowData)

    at Microsoft.Crm.Tools.Admin.ImportOrganizationInstaller.ProcessWorkflowUIData(ExecutionContext context)

    at Microsoft.Crm.Tools.Admin.ImportOrganizationInstaller.Import(Guid organizationId, String organizationUniqueName, String organizationFriendlyName, String sqlServerName, String databaseName, Uri reportServerUrl, String privilegedUserGroupName, String sqlAccessGroupName, String userGroupName, String reportingGroupName, String privilegedReportingGroupName, ICollection`1 users, MultipleTenancy multipleTenancy)

    16:12:18|Warning| Attempting to cancel a long running process: ProgressWizard. This might leave the data in an invalid state and the application might not function correctly.

     

     

    i delete this new_servicesid

    but still show me the error?

    please need help

    Thursday, November 27, 2008 2:04 PM

Answers

  • Add the SQL OLEDB timeout funtions to the registry:

    http://support.microsoft.com/kb/918609

    Open the deployment wizard on the previous server and make sure the Org names are spelt exactly the same.
    Tiaan van Niekerk http://crmdelacreme.blogspot.com Skype:tiaan.van.niekerk1
    • Marked as answer by Jim Glass Jr Friday, April 10, 2009 6:52 PM
    Friday, April 10, 2009 8:20 AM

All replies

  • Add the SQL OLEDB timeout funtions to the registry:

    http://support.microsoft.com/kb/918609

    Open the deployment wizard on the previous server and make sure the Org names are spelt exactly the same.
    Tiaan van Niekerk http://crmdelacreme.blogspot.com Skype:tiaan.van.niekerk1
    • Marked as answer by Jim Glass Jr Friday, April 10, 2009 6:52 PM
    Friday, April 10, 2009 8:20 AM
  • OK, here is the deal with your error.  Your attribute new_servicesid was referred to in a workflow or a duplicate detection rule.  You have since deleted this attribute.

    This is an issue if you are rollup 1 or 2.

    You have several options to make this work.

    1.  Uninstall/reinstall crm on the server that you are trying to import to.  When you install, do not update the install files and do not install the rollups until after you import. Then it should import ok

    2.  Try it with rollup 3.  it seems to work better.

    3.  recreate the attribute new_servicesid in the database that you are importing, then it will import ok

    4.  on the database that you are importing, delete any records that refer to this attribute from the duplicaterecordbase table and the workflowdependencybase tables.  then it will import ok.

    Monday, April 13, 2009 1:37 AM
    Moderator
  • Just to agree with Joel, we had the same issue and Joels comments are what we found.

    Rob
    Thursday, April 16, 2009 9:29 AM