locked
BLE 4.2 connection failing due to access being denied RRS feed

  • Question

  • Hi,

    We are running into a connection issue on multiple windows 10 computers (regardless of the version) when attempting to connect (pairing/bonding/connecting) to a ble 4.2 device using our wpf application (the issue can also be reproduced with the Bluetooth LE Explorer app). It appears that access to a specific service (that does not exist on our device) is being denied. The service could be protected by the OS as this happens even when the device has already been successfully paired.

    Steps:
    - Initiate connection or pairing if not yet paired

    - Once connected (IsConnected=True), try to get Services (GetGattServicesAsync(Uncached))

    - Subscribing to specific characteristics after accessing the specific services (battery, data, firmware version)

    Result:

    - The BLE connection state (IsConnected) randomly changes to False

    - ReadValueAsync fails as a result of the connection state switching to false (unable to read GattCharacteristic) 

    The app always uses BluetoothCacheMode.Uncached for all services and characteristics operations. We have attached all the requested files (bluetooth tracing and system information). Please let us know if there is a way to know why the access requests are being denied as this randomly happens. This is critical for us as a few of the hospitals who use our devices have reported this issue that we were able to replicate internally on some laptops. Please let us know if you need more information. Thank you for your help.

    Please find the traces at 

    Regards,

    KM

    Friday, October 30, 2020 9:40 PM

All replies

  • "Please find the traces at "
    where?
    Saturday, October 31, 2020 7:15 AM
  • Hi EckiS,

    Could not post the link as I need to verify my account. 

    Regards,

    KM

    Saturday, October 31, 2020 5:54 PM