locked
Rollup 10 upgrade problems RRS feed

  • Question

  • Hi,

    I'm not sure anyone can help but as a last resort I thought I'd post here.  We have just updated our Development machine with rollup 10.  After we did this our CRM website is not working properly.  We don't get the top nav area, all we get is a CRM error stating:

    Microsoft CRM Error Report:
    Error Description:
    An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

    Error Details:
    Exception of type 'System.Web.HttpUnhandledException' was thrown.

    Full Stack:
    [MissingMethodException: Method not found: 'System.String Microsoft.Crm.Application.Utility.Util.GetSecureWebServerUrl()'.]
       at Microsoft.Crm.Application.Menus.AppGlobalWebMenuBar.BuildMenuBar()
       at Microsoft.Crm.Application.Menus.AppGlobalWebMenuBar.Execute()
       at Microsoft.Crm.Application.Pages.Root.TopBar.ConfigureMenus()
       at Microsoft.Crm.Application.Controls.AppUIPage.OnPreRender(EventArgs e)
       at System.Web.UI.Control.PreRenderRecursiveInternal()
       at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) 

    After further investigation it appears that this method is new in the Microsoft.Crm.Application.Components.Core.dll which got upgraded.  I have checked all these DLL's on the system and they are all the correct version.  So it appears CRM is using the old version somehow...not too sure how it would do this.  I have restarted the server to no avail.

    Cheers,

    Craig

    Thursday, May 13, 2010 10:24 PM

Answers

  • This s obviously not picking up the correct dll to use with CRM so you can either repair you CRM install or attempt to remove this dll from the GAC (although you may need to remove it from the regsitry too.) and then apply rollup 10 again.
    MSCRM Bing'd - http://bingsoft.wordpress.com
    Friday, May 14, 2010 8:24 AM
    Moderator

All replies

  • Have you tried reinstalling the rollup, and make sure you run it in admin mode.
    MSCRM Bing'd - http://bingsoft.wordpress.com
    Thursday, May 13, 2010 10:32 PM
    Moderator
  • Yes I have done that.  It didn't fix the problem though.
    Thursday, May 13, 2010 11:08 PM
  • Do you have rollup 7... any other details to provide what customizations do you have?
    Friday, May 14, 2010 12:01 AM
  • Yes we have been updating the rollups as we have been going along. 7, 8, 9, and now 10.  We have pretty much customized everything that can be customized with CRM so its going to be hard to pin point exactly what has caused it.

    Friday, May 14, 2010 1:23 AM
  • This s obviously not picking up the correct dll to use with CRM so you can either repair you CRM install or attempt to remove this dll from the GAC (although you may need to remove it from the regsitry too.) and then apply rollup 10 again.
    MSCRM Bing'd - http://bingsoft.wordpress.com
    Friday, May 14, 2010 8:24 AM
    Moderator