locked
Whats rights are required to run plugin registration tool mscrm 2011 on-premises RRS feed

  • Question

  • Dear all;

    what rights we required to run plugin registration tool on premises on mscrm 2011

    Friday, November 22, 2013 12:24 PM

All replies

  • Hi,

    You need to be Deployment Administrator in the Deployment Manager tool of CRM 2011.

    I hope this resolves your issue.

    Thanks & Regards,


    Anubhav Bajpai

    Friday, November 22, 2013 12:26 PM
  • i am deployment administrator but still the plugin registration is not working it was working before but i don't know what happened suddenly it stopped working
    Friday, November 22, 2013 3:32 PM
  • what error message you are getting ?

    Hope this helps. If you get answer of your question, please mark the response as an answer and vote as helpful !
    Vikram !

    Friday, November 22, 2013 3:51 PM
  • Hi vikram the error is 

    unable to retrieve organization from discovery services

    i searched for this error on internet and people are saying that delete liveDeviceID.xml the wired thing is that i can not find that file under user folder on the server 

    Monday, November 25, 2013 8:54 AM
  • Hello,

    Try to restart asyn service and then check.


    Our Website | Our Blog | Follow US | My Facebook Page | Microsoft Dynamics CRM 2011 Application Design
    Make sure to "Vote as Helpful" and "Mark As Answer",if you get answer of your question.

    Monday, November 25, 2013 9:03 AM
    Moderator
  • Hi,

    Are you able to browse Discovery service ? 

    http://SERVERNAME/XRMServices/2011/Discovery.svc

    did you try to open pluginregistration.exe using right click and Run as Administrator ?


    Hope this helps. If you get answer of your question, please mark the response as an answer and vote as helpful !!!
    Vikram Singh. !!!  My Blog

    Monday, November 25, 2013 9:08 AM
  • Hi,

    Can you provide the details of the error message by clicking on the "Yes" to see more details of the error message:

    for example: the details might look like:

    In case you receive the same error as shown, then it is related to the discovery service and you might not be able to browse the discovery service from the discovery url mentioned in the developer resources. This is usually caused of misconfiguration done in IIS.

    If the error details are different then let me know.

    Thanks & Regards,


    Anubhav Bajpai


    Monday, November 25, 2013 9:14 AM
  • Hi Anubhav ;

    i am receiving the same error how to solve it any idea

    Tuesday, December 10, 2013 1:01 PM
  • Hi,

    Are you able to browse the discovery service under Settings --> Customizations --> Developer Resources?


    Anubhav Bajpai

    Tuesday, December 10, 2013 2:09 PM
  • Hi Anwar,

    Try by recycling the CRM App Pool as some posts have suggested.


    or Try by closing and reopening and recreating the connection in the plugin registration tool. At times we face this issue when the credential of the logged in user have been changed.

    Regards,

    Shraddha Dhingra

    http://blogs.msdn.com/b/shraddha_dhingra/

    Tuesday, December 10, 2013 2:50 PM
  • Hi Anubhav;

    yes i can browse the discovery service

    Tuesday, December 10, 2013 2:57 PM
  • I experienced this same issue about a week ago. The registration tool was working fine and then the company I work for forces everyone to update their password every so often. Once I reset my password I was unable to access the plugin registration tool. I was receiving a similar error message as above pointing to the discovery service. What I found out was somehow my rights to the file had been switched to read only. I corrected that and everything worked fine again. Perhaps it is a similar issue for you?

    Start > cmd > right-click Run as Admin > cd (file location) > attrib –R (filename)

    Tuesday, December 10, 2013 10:14 PM
  • I also have ever faced this problem, I am Deployment Administrator as well.

    This is sometimes because of your CRM website has multiple bindings so that cannot resolve.

    And also sometimes in the Deployment Manager, you have to change in the Properties.

    Saturday, May 10, 2014 8:09 PM