locked
Dlink DIR-655 Router Setup RRS feed

  • Question

  • This one has really got me stumped. I use to consider myself an advanced computer user. Not anymore.... After many failed attempts at this user freindly operating system. I'm just dumb founded. Please help!!!!! Website and remote access are available locally but not outside the local network. Yes port forwarding has been setup manually (80,443,4125) as WHS could not configure. Well I take that back it say configured but not verified. I verified it does not work! The NAT settings are as loose as I can set them, port forwarding has been set, rebooted OS and router many many times. I'm just at a lose as to what to try next. My router Bios firmware is 1.21 without Secure Spot. Any ideas or suggestion? PLEASE.........
    Wednesday, April 15, 2009 7:28 PM

Answers

  • Boy it keeps getting better and better. I went to the shieldup website to check ports. Well all ports (80,443,4125) all show they are open! Now I am really lost as to what to try next..... HELP!
    If Shields Up! is reporting port 4125 as open, your router is probably not pointing to the correct IP address.  Double check your port forwarding on your router and make sure it's pointing to the IP address of your server.  Also, you may have uPnP enabled on your router (which could inadvertently be pointing to another computer in your LAN).  If nothing else, you could try doing a factory reset of your router, then manually configure it after that.
    Thursday, April 16, 2009 4:36 AM
    Moderator
  • stx_killer, to confirm, your WAN IP address (the address your ISP has assigned you) is 192.168.78.100? That's a "private" IP address, one that is only issued inside a private network, and points to the source of your problems. There are a couple of possibilities: Most likely, your cable or DSL modem is acting as a router as well as your D-Link router. If so, you have what is termed "double NAT", where multiple devices are taking an external IP address and translating it for use on the other side.

    Assuming this to be the case, you don't say which cable/DSL modem you have, but you should probably contact your ISP and find out how to place your modem in "bridge" or "passthrough" mode.

    There is also a possibility that your ISP is using NAT to allow it's subscribers access to the Internet through a limited pool of public IP addresses. This also leads to a double NAT situation, but if this should prove to be the case, your only option if you want to use your Remote Access web site when off your own network will be to get your ISP to provide you with a public IP address.

    Also, when you run your port scan on Shields Up!, what IP address is it reporting?

    I'm not on the WHS team, I just post a lot. :)
    Friday, April 17, 2009 4:28 PM
    Moderator
  • The answer is the new dish. The new dish will not assign the external IP the 208.XXX.XX.XXX. It has a static IP. So the WAN IP and the WHS IP will match. I can hardly wait. I feel ike a chid on Christmas Eve.
    Friday, April 17, 2009 9:44 PM

All replies

  • Have you asked your ISP if they are blocking any of the ports?
    Wednesday, April 15, 2009 8:02 PM
  • yes just got off the phone. They claim they are notblocking any ports. Also I am using DHCP reservation to maintain static ip for network. Any other ideas?
    Wednesday, April 15, 2009 8:26 PM
  • You might want to mention the name of your ISP here. Someone may then recall a pecularity with that ISP.
    If you've forwarded 80, 443 & 4125 to the WHS, and the WHS has a static IP reserved, then there's no good reason for it not to work.
    Also, you might do a search in this forum & the related software one. This problem has been discussed several times before.
    Wednesday, April 15, 2009 9:25 PM
  • I doubt knowing my ISP can hep as I live in the U.S. Virgin Islands. But here you go it is Broadband VI. I havesearched the forums high and ow for hep for a week now and i can not locate anything that helps. Setting up a Unix Server was easier than this Microsoft Blunder. I just liked some of the features of WHS. But not sure the install probems are worth the headache!
    Thursday, April 16, 2009 12:14 AM
  • Boy it keeps getting better and better. I went to the shieldup website to check ports. Well all ports (80,443,4125) all show they are open! Now I am really lost as to what to try next..... HELP!
    Thursday, April 16, 2009 12:41 AM
  • Boy it keeps getting better and better. I went to the shieldup website to check ports. Well all ports (80,443,4125) all show they are open! Now I am really lost as to what to try next..... HELP!
    If Shields Up! is reporting port 4125 as open, your router is probably not pointing to the correct IP address.  Double check your port forwarding on your router and make sure it's pointing to the IP address of your server.  Also, you may have uPnP enabled on your router (which could inadvertently be pointing to another computer in your LAN).  If nothing else, you could try doing a factory reset of your router, then manually configure it after that.
    Thursday, April 16, 2009 4:36 AM
    Moderator
  • Boy it keeps getting better and better. I went to the shieldup website to check ports. Well all ports (80,443,4125) all show they are open! Now I am really lost as to what to try next..... HELP!
    If Shields Up! is reporting port 4125 as open, your router is probably not pointing to the correct IP address.  Double check your port forwarding on your router and make sure it's pointing to the IP address of your server.  Also, you may have uPnP enabled on your router (which could inadvertently be pointing to another computer in your LAN).  If nothing else, you could try doing a factory reset of your router, then manually configure it after that.

    i thought uPnP was suppose to be enabed. I'll turn it off and see what happens.Thanks for the idea. I've got my fingers crossed. Another all nighter trying to get this working. I do know that the Tool kit shows it as an error if uPnP is not enabed. But at this point I'll try anything. Thanks again.
    Thursday, April 16, 2009 1:00 PM
  • Well no luck... I disabled uPnP on the router. No WAN side connections yet. Then I re-enabled uPnP and tried to let it reconfigure no luck either. But now shield up shows port 4125 as stealth. How do I change this?
    Thursday, April 16, 2009 4:59 PM
  • Well no luck... I disabled uPnP on the router. No WAN side connections yet. Then I re-enabled uPnP and tried to let it reconfigure no luck either. But now shield up shows port 4125 as stealth. How do I change this?
    Sounds like you went from bad to worse. ;)  Have you ever changed the firewall settings on your server?  If not, I'm guessing it's still not pointing at your server's IP address (it's probably pointing to a non-existent IP now).  My suggestion is to unconfigure your Remote Access settings in your Console, do a factory reset of your router, then do the port forwarding in your router manually (don't even attempt to use uPnP as it clearly is not going to work).  At that point, go back to Shields Up! and check ports 80, 443, and 4125 then post the results here.
    Thursday, April 16, 2009 7:15 PM
    Moderator
  • kariya thanks for a the help on this. i noticed something that maybe is the problem. See what you think about this! On my router status page where it shows this:

    WAN

    DHCP Client

    Active

    Connected

    Online

    Established

    0 Day 5 Hour 37 Min 35 Sec

    00:24:01:39:A9:10

     

    192.168.78.100

    255.255.255.0

    192.168.78.10

    192.168.78.10

    My concern is the IP address @ xxx.xxx.78.100   Now the WHS Server shows an IP 192.168.0.196 and this is where I forwarded the ports. If I go to a web browser on my network to xxx.xxx.78.100 I get the WHS web page. Is this okay? I am going to try your previous suggestion. Post soon on outcome. Thanks Again
    • Edited by stx_killer Friday, April 17, 2009 3:24 AM typo
    Friday, April 17, 2009 3:20 AM
  • Okay I reset everything in the order you specified. Went and checked ports again. If I use the common port check tool port 80 & 443 show they are open! But when I use the custom probe to check the 3 ports 80,443,4125 then it shows they are a Stealth. The test was ran with the firewall on and off. No change. Oh boy....
    Friday, April 17, 2009 4:39 AM
  • stx_killer, to confirm, your WAN IP address (the address your ISP has assigned you) is 192.168.78.100? That's a "private" IP address, one that is only issued inside a private network, and points to the source of your problems. There are a couple of possibilities: Most likely, your cable or DSL modem is acting as a router as well as your D-Link router. If so, you have what is termed "double NAT", where multiple devices are taking an external IP address and translating it for use on the other side.

    Assuming this to be the case, you don't say which cable/DSL modem you have, but you should probably contact your ISP and find out how to place your modem in "bridge" or "passthrough" mode.

    There is also a possibility that your ISP is using NAT to allow it's subscribers access to the Internet through a limited pool of public IP addresses. This also leads to a double NAT situation, but if this should prove to be the case, your only option if you want to use your Remote Access web site when off your own network will be to get your ISP to provide you with a public IP address.

    Also, when you run your port scan on Shields Up!, what IP address is it reporting?

    I'm not on the WHS team, I just post a lot. :)
    Friday, April 17, 2009 4:28 PM
    Moderator
  • stx_killer, to confirm, your WAN IP address (the address your ISP has assigned you) is 192.168.78.100? That's a "private" IP address, one that is only issued inside a private network, and points to the source of your problems. There are a couple of possibilities: Most likely, your cable or DSL modem is acting as a router as well as your D-Link router. If so, you have what is termed "double NAT", where multiple devices are taking an external IP address and translating it for use on the other side.

    Assuming this to be the case, you don't say which cable/DSL modem you have, but you should probably contact your ISP and find out how to place your modem in "bridge" or "passthrough" mode.

    There is also a possibility that your ISP is using NAT to allow it's subscribers access to the Internet through a limited pool of public IP addresses. This also leads to a double NAT situation, but if this should prove to be the case, your only option if you want to use your Remote Access web site when off your own network will be to get your ISP to provide you with a public IP address.

    Also, when you run your port scan on Shields Up!, what IP address is it reporting?

    I'm not on the WHS team, I just post a lot. :)

    Thanks for the response. My IP is 208.84.198.26 which will take me to my router page if tried from inside network. Outside it will not be found at all. As far as another modem or router there is not I use a satellite broadband connection. Cat5 goes straight from the dish to the router, then from the router to the server. My (Server) dynamic IP 198.196.0.196.
    Friday, April 17, 2009 5:00 PM
  • I'm confused. When you go to the Shields Up! site and run a standard port scan, what IP address does it report? When you run a custom port scan (since you say you get different behavior) what does it report? And in your router's setup pages, what does it report for it's WAN address? If your router is reporting 192.168.xxx.yyy for it's WAN interface, there's a second layer of NAT between you and the Internet, in addition to the layer that your router provides automatically.
    I'm not on the WHS team, I just post a lot. :)
    Friday, April 17, 2009 5:34 PM
    Moderator
  • I'm confused. When you go to the Shields Up! site and run a standard port scan, what IP address does it report? When you run a custom port scan (since you say you get different behavior) what does it report? And in your router's setup pages, what does it report for it's WAN address? If your router is reporting 192.168.xxx.yyy for it's WAN interface, there's a second layer of NAT between you and the Internet, in addition to the layer that your router provides automatically.
    I'm not on the WHS team, I just post a lot. :)

    okay when I go to Sheilds Up it reports the IP as 208.84.198.26. It repots the same IP for custom and for common port check. Now the WAN on the router status page is reported as 192.168.78.100 if I go to the 208 address http takes me to the router page https can not be found. If I go to the WAN IP reported by the router xxx.xxx.78.100 with http or https I get the webpage from WHS. Any Ideas?
    Friday, April 17, 2009 6:06 PM
  • Ideas? Yes and no. I'm sure about what's going on now, but not about how you'll be able to correct it. 

    What's going on: The WAN ip address reported by your router is being supplied by some device that's doing an additional layer of NAT. The 208.xxx.yyy.zzz address is the external (public) address of that device.

    You should contact your ISP to find out how (and if) you can resolve this. It may be that it's the satellite box that's doing it by acting as a broadband modem/router, in which case it's (theoretically) under your control, or it could be a device elsewhere on your ISP's network. I don't have enough information to be able to make an informed guess in either direction, I'm afraid.

    Contacting your ISP is going to be a bit of a crapshoot, I'm afraid. It's likely that running a server is against their terms of service, so they may want to charge you for a business class of service (if they offer one) or they may just decline to help you.

    I would start by explaining that you're having trouble with an application because you have "what an acquaintance referred to as double NAT" and you were wondering if there is any way that either your ISP can configure you, or you can configure yourself, to avoid the problem. If asked, explain the situation you're seeing at Shields Up! (it's remorting one WAN address, your router reports a different one in a private address range). Be candid about your level of technical knowledge and skill, as otherwise they'll fill your head with technobabble worse than anything you've seen here so far. :)

    I'm not on the WHS team, I just post a lot. :)
    Friday, April 17, 2009 6:28 PM
    Moderator
  • Okay thank you and this forum for all it's help. I'll contact the ISP today and post findings here. I was wondering though I have used dyndns.com before with a Debian server without these problems. Hope they have some idea as to how to make this work.... thanks again
    Friday, April 17, 2009 6:51 PM
  • Thank you Thank you, Finally the answer I've been banging my head for over a week now.... It seems that this dish has a built in firewall. They are coming out to but the newer model dish ( at no charge ) WOW! Then they can give me a static IP. For some reason it can not be done with this dish. So I have to wait unti Monday to begin the adventure again. I think at this point I'll go ahead and do a clean install of WHS and reset the router and wait for my new dish. Double NAT say goodbye. Thanks again for all your help...
    Friday, April 17, 2009 7:34 PM
  • (I've unmarked my last reply as an answer; it's likely that you'll get the answer from your ISP by yourself. Please post it back here, though. :) )

    I can't tell you why your Debian server worked with no hassles and Windows Home Server doesn't, to be honest, because I don't have any experience with Debian specifically, and not a lot with linux in general. I kind of suspect more than one thing has changed singe you were using Debian, but it would be very hard to pin down even if I knew exactly what all has changed...

    I'm not on the WHS team, I just post a lot. :)
    Friday, April 17, 2009 8:14 PM
    Moderator
  • The answer is the new dish. The new dish will not assign the external IP the 208.XXX.XX.XXX. It has a static IP. So the WAN IP and the WHS IP will match. I can hardly wait. I feel ike a chid on Christmas Eve.
    Friday, April 17, 2009 9:44 PM