locked
Crm 2011 - Report Parameter Issue - Enabling Data Pre-filtering in Fetch-based Reports RRS feed

  • Question

  • Hi,

    I've created a report and added a report paramter, everthing works fine in development studio.  When I upload the report it error's with the following:

    >System.Web.Services.Protocols.SoapException: Microsoft Dynamics CRM has experienced an error. Reference number for administrators or support: #3DB12EC0: System.Web.Services.Protocols.SoapException: System.Web.Services.Protocols.SoapException: '@CRM_FilteredInvoice' is not a valid report parameter name. Names of objects must be CLS-compliant identifiers.
    at Microsoft.ReportingServices.WebServer.ReportingService2005Impl.CreateReport(String Report, String Parent, Boolean Overwrite, Byte[] Definition, Property[] Properties, Warning[]& Warnings)
    at Microsoft.ReportingServices.WebServer.ReportingService2005.CreateReport(String Report, String Parent, Boolean Overwrite, Byte[] Definition, Property[] Properties, Warning[]& Warnings)
    >  at System.Web.Services.Protocols.SoapHttpClientProtocol.ReadResponse(SoapClientMessage message, WebResponse response, Stream responseStream, Boolean asyncCall)
    >  at System.Web.Services.Protocols.SoapHttpClientProtocol.Invoke(String methodName, Object[] parameters)
    >  at Microsoft.Crm.ReportingServices2005.ReportingService2005.CreateReport(String Report, String Parent, Boolean Overwrite, Byte[] Definition, Property[] Properties)
    >  at Microsoft.Crm.Reporting.RuntimeReportServer.UploadReport(String path, Byte[] reportDefinition, String name, String description, Boolean overwriteExistingReport)

    This issue is with CRM online and my local dev enviroment.

    Does anyone know how to get around this issue please?

    Kind regards

    Si

    Sunday, March 13, 2011 10:03 PM

Answers

  • Hi Simon

    The report parameter name that you have used to create the report doesn't seems to have a CLS compliant name. Could you rename is from '@CRM_FilteredInvoice' to 'CRM_FilteredInvoice'. A name to be CLS-compliant, you cannot have '@' in the name.

    I hope this would solve your problem. Let me know if it doesn't work, then I would need to have a look at your RDL.

     

    Thanks

    Kunal

     

     

    • Proposed as answer by Kunal Garg Tuesday, March 15, 2011 4:32 AM
    • Marked as answer by Jim Glass Jr Tuesday, March 15, 2011 2:21 PM
    Monday, March 14, 2011 4:07 AM
  • Thanks Simon,

     

    I will open a documentation bug to correct the SDK.

    Thanks

    Kunal
    • Marked as answer by Jim Glass Jr Tuesday, March 15, 2011 2:21 PM
    Tuesday, March 15, 2011 12:27 PM

All replies

  • Hi Simon

    The report parameter name that you have used to create the report doesn't seems to have a CLS compliant name. Could you rename is from '@CRM_FilteredInvoice' to 'CRM_FilteredInvoice'. A name to be CLS-compliant, you cannot have '@' in the name.

    I hope this would solve your problem. Let me know if it doesn't work, then I would need to have a look at your RDL.

     

    Thanks

    Kunal

     

     

    • Proposed as answer by Kunal Garg Tuesday, March 15, 2011 4:32 AM
    • Marked as answer by Jim Glass Jr Tuesday, March 15, 2011 2:21 PM
    Monday, March 14, 2011 4:07 AM
  • Your right that was the issue.

    The SDK appears to be incorrect to adding parameters manually.  See Using Filters in Report, Enabling Data Pre-filtering in Fetch-based Reports, list item 1, it states:

    1. Set the value of the enableprefiltering parameter to 1 for the required entity or linked entity, and specify a unique parameter name for the prefilterparametername property.

     
    <fetch distinct="false" mapping="logical">
      <entity name="account" enableprefiltering="1" prefilterparametername="@CRM_FilteredAccount">

    Tuesday, March 15, 2011 11:12 AM
  • Thanks Simon,

     

    I will open a documentation bug to correct the SDK.

    Thanks

    Kunal
    • Marked as answer by Jim Glass Jr Tuesday, March 15, 2011 2:21 PM
    Tuesday, March 15, 2011 12:27 PM