locked
SyncToy only runs 2 of 4 folderpairs RRS feed

  • Question

  •  

    Hi,

     

    I use Synctoy to echo new/changed files from 4 remote servers to a single central server. This morning when I tested the results (I know a particular file is supposed to appear every day) only 2 of the 4 folder pairs had been sync'ed. In the log file a single line in the bottom stated that:

     

    SYNC: 07/03/2008 04:18:57:539: SyncToyCmd has detected that the folder pair Upernavik has not been synchronized yet. Please run SyncToy.exe to complete the initial synchronization.


    This is pure nonsens as it has been running daily for over a month - I even ran it manually a few days ago since it chrashed last week with a message about "a user defined breakpoint"!

     

    Finally, I wonder why the inability to run the third folder pair stops SyncToy from even trying to run the fourth folderpair?

    Thursday, July 3, 2008 7:39 AM

Answers

  • You are right - any failure on the third folder pair should not affect the fourth folder pair and we have been unable to repro this. Can you fire up the UI and do a all folder pair sync and check if all 4 are run?

     

    I suspect folder pair #3 has permission issues that is why it is unable to run from a script.

     

    Thanks

    Deepa

    Wednesday, July 30, 2008 2:56 AM

All replies

  •  arleth69 wrote:

    Finally, I wonder why the inability to run the third folder pair stops SyncToy from even trying to run the fourth folderpair?

     

    Will this be fixed in the RTM?

    Tuesday, July 29, 2008 9:18 AM
  • You are right - any failure on the third folder pair should not affect the fourth folder pair and we have been unable to repro this. Can you fire up the UI and do a all folder pair sync and check if all 4 are run?

     

    I suspect folder pair #3 has permission issues that is why it is unable to run from a script.

     

    Thanks

    Deepa

    Wednesday, July 30, 2008 2:56 AM
  •  Deepa Choundappan wrote:

    You are right - any failure on the third folder pair should not affect the fourth folder pair and we have been unable to repro this. Can you fire up the UI and do a all folder pair sync and check if all 4 are run?

     

    I suspect folder pair #3 has permission issues that is why it is unable to run from a script.

     

    Thanks

    Deepa

     

    The error happened almost a month ago and I run the job on a daily basis so the UI check was not an obtion - however I inspected the logfile once more (this time a little more carefully it would seem) and in the top of that days log-entries the 4th folder pair was also listed as "not previously syncronised"

     

    I suspect that the underlying reason is that the folder pairs consists of two UNC paths - each of which requires username&password to access. When this access for some reason is lost (poor connections) a renewed login is needed to avoid the error. Maybe a more descriptive error message like: "Left folder not accessible!" should be thrown instead but basically it does not look like it is not a fail of SyncToy

    Wednesday, July 30, 2008 11:57 AM
  • We have fixed this in RTM to tell you that basically that folder structure cannot be found ( we cannot specifically tell you accessibility).

     

    Thanks

    Deepa

    Wednesday, July 30, 2008 8:18 PM