locked
FTP Server on WHS? RRS feed

  • Question

  •  

    Does WHS come with an FTP Server? If not, can someone suggest one - preferably free!

     

    I only want access from inside my network, so I probably don't need much in the way of security features.

     

    Tuesday, June 10, 2008 10:20 AM

All replies

  • You can use the FTP service that is part of Windows Server 2003, but file shares are going to be a lot more convenient for just about every purpose.

    To install the FTP service:
    • Use Remote Desktop to connect to your server.
    • Open Control Panel.
    • Click on Add or Remove Programs.
    • Click on Add/Remove Windows Components.
    • Select Applicaiton Server and click Details...
    • Select Internet Information Services (IIS) and click Details...
    • Check off File Transfer Protocol (FTP) Service, and work your way back out.
    You will likely be asked for your installation media. Use your Windows Home Server installation DVD. If you have an HP MediaSmart Server, or other OEM product without installation media, you'll need to obtain a copy of Windows Server 2003 so you can copy the I386 folder to a location that you can access from the server.
    Tuesday, June 10, 2008 11:51 AM
    Moderator

  • One reason for having an FTP server is that there are a lot of possibilities for easy Internet access to files on the Homeserver without having to go through the Website
    . SyncBack SE is for example able to synchronize files to an FTP directory and there are tools out there that provide one-click uploads to FTP servers.
    Or am I missing something and that is also possible with the standard WS setup?

    Related question: how do I add a WHS shared folder to the FTP server? I can not add the shares with their network path and if I add them as a mapped network drive they just do not show up...

    Tuesday, June 10, 2008 2:22 PM
  •  Ken Warren wrote:
    You can use the FTP service that is part of Windows Server 2003, but file shares are going to be a lot more convenient for just about every purpose.

    To install the FTP service:
    • Use Remote Desktop to connect to your server.

      How do I do that?

      Tuesday, June 10, 2008 2:31 PM
    • You can connect from any computer on your home network, using Microsoft's Terminal Services Client:
      Start → Run → mstsc → Enter

      Use Administrator for the user name, and the Windows Home Server Console password for the password. Be careful; it's possible to damage your server severely with some of the tools available when you access your server this way. But installing the FTP service is pretty safe.

      Or you can log in locally, using a physical keyboard, mouse, and monitor.
      Tuesday, June 10, 2008 3:27 PM
      Moderator
    • You can do it from the Home Server Console using the add-in  Advanced Admin Console AddIn to load Control Panel -> Add or Remove Programs -> Add/Remove Windows Components. I think this is the best way to do it.

       

      Advance Admin Consle AddIn

      Tuesday, June 10, 2008 8:40 PM
    • A bit more detail to make live easier:

       

      To install the FTP service (From WHS helpfiles) login to WHS using RDP or KVM, then:

      1. From the Start menu, click Control Panel.
      2. Double-click Add or Remove Programs.
      3. From the left pane, click Add/Remove Windows Components.
      4. From the Components list, click Application Server, and then click Details.
      5. From the Subcomponents of Application Server list, click Internet Information Services (IIS), and then click Details.
      6. From the Subcomponents of Internet Information Services (IIS) list, select the File Transfer Protocol (FTP) Service check box.
      7. Click OK.
      8. Click Next. You might be prompted for the Windows Server 2003 family CD or the network install path.
      9. Click Finish.

      NOTES:

      a. At "8." you may need to point to X:\SVR_2003\i386 where X is DVD drive (or local copy of  i386 folder)

      b. You have to allow the FTP SERVICE in the WHS firewall, open windows firewall settings, ADVANCED tab, Select Local Area Connection, Settings, Allow FTP server

      c. Properly configure access rights to ftp folders in IIS and also set NTFS folder access rights accordingly

      d. For security it's best to allow access from computers on local network (Directory security, unless you require remote FTP access; All computer access denied except, use add button to allow computers on your local subnet (enter ip-address / netmask) from DHCP server (router) for example 192.168.1.1 and 255.255.255.0

      e. Allow FTP in client firewall (port 21, unless you configured another port for FTP access in IIS)

      Tuesday, June 10, 2008 10:34 PM
      Moderator
    • How to obtain the copy of Windows Server 2003? I have a licensed Windows Home Server installation DVD. But it still asked me to insert another disk, windows server 2003.

       

       

      Friday, January 28, 2011 5:07 PM
    • The WHS DVD is the Win2k3 disk. If you click on OK you should get a new dialogue box indicating what file it is looking for and the option to browse to find it. Navigate to the dvd drive \i386 folder. It should list the subfolders with the file it is looking for at the bottom of the list but possibly ending with an underscore (_) Click on OK and the install should continue.

      As well as allowing FTP through the Windows Firewall if you want off LAN access you will need to set up NAT port redirection and firewall rules on your router. This would be beyond a WHS issue.


      25 years of loving (and too often hating) everything Microsoft.
      Friday, January 28, 2011 8:05 PM
    • I received the same request, gave up and cancelled. Then I decided to try one more time, this time when it asked me for the "Windows Server 2003 Small Business Server" or something similar, I clicked on browse, the file it was looking for was listed, I clicked on it anyway, then selected Ok, and it continued the installation. I believe I had to go through the same procedure one or more times for a some other files, and then it worked. Hope that it might help someone coming here even though this is quite an old topic.
      Thursday, September 8, 2011 2:29 AM