locked
WHS Backup Fails with Ghost 15 installed on Windows 7 PC RRS feed

  • General discussion

  • I upgraded two computers from Vista to Windows 7.  I was using Norton Ghost 12 on both PC's with Vista and doing double backups (One of these PC's is used in a home business and the other has all our pictures, so two image-based backups provided peace-of-mind).  Ghost 12 does not work with Windows 7, so I updated to Ghost 15. 

    WHS backups immediately stopped working on both PC's.  After trying connector reinstalls and cleaning up the backup database, I finally uninstalled Ghost 15 from one of them.  Backup started working perfectly.

    Has anyone else seen this?

    Update to add info: The server has PP3 installed.  Also one of the PC's was converted to Windows 7 several weeks ago and in the interim was running without Ghost installed.  During this time, WHS backups worked great.  When the 2nd PC was updated to Windows 7, I installed Ghost 15 on both of them and the problem surfaced.  Ghost was not performing a backup when the WHS backups failed on both PC's.  Backup status is at 0% and a message that the backup has failed due to a connector problem (which is why I tried to reinstall it several times).
    Thursday, December 31, 2009 4:28 AM

All replies

  • Well, Ghost installs it's own VSS providers, so it sounds like they're interfering with the Microsoft providers that Windows Home Server's backup feature relies on. Unfortunately, this isn't a Windows Home Server issue per se , it's a Ghost issue. You can do some searching here in the forums or using Google, but I don't know that you'll discover a complete solution online. You'll probably have to contact Norton's support to see what can be done from their end to keep Ghost but prevent it from interfering with the Microsoft VSS providers.
    I'm not on the WHS team, I just post a lot. :)
    Friday, January 1, 2010 5:24 AM
    Moderator
  • Problems with third party backup or imaging software have been reported in this forums a few times, for example in this thread
    Friday, January 1, 2010 7:31 AM
    Moderator
  • Thanks Ken and Brubber,

    I have posted the problem in Norton's forum also.  I agree that it is Symantec's problem, but wanted to warn the WHS community that the problem exists for us "belt and suspenders" types.

    If I get a resolution from Norton I will post it here.

    In the meantime, I have to decide which product to use.
    Friday, January 1, 2010 2:45 PM
  • I actually *seem* to have both Ghost 15 and WHS backups working on Win 7 x64, though I do get warnings about cache flushing:

    http://social.microsoft.com/Forums/en/whssoftware/thread/e7f97798-6183-4278-b0ec-3dcd9abff321

    I have verified several Ghost image files.  I also at one point did a full system restore using my WHS backup.

     

    Wondering if anybody else has experience with this issue?

     

     

     

     

     

    Wednesday, May 26, 2010 12:09 PM
  • If you delete the Symantec VSS Provider key from the registry of Windows 7, you may successfully backup using WHS and still be able to use Norton Ghost 15. 

    I haven't tested all the scenarios, so I'm not sure limitations this solution has (for example, if WHS backup is in process, Ghost can't connect to the service -- probably because both programs need to use the MS VSS provicer -- and in one instance, I couldn't use Ghost right after a WHS backup without rebooting); however, it works for my purposes.  Note that the conflict seems to manifest itself primarily when these three programs are installed: (1)WHS, (2) Norton Ghost 14 or 15, and (3) NIS 2009, NIS 2010, Norton 360, or Comcast Norton Security Suite. Symantec said on their forum in June 2009 that they reproduced the problem but didn't have a fix (and didn't fix it with Ghost 15 since then).

    Here are the steps I used and a previous thread on the subject: http://community.norton.com/t5/Other-Norton-Products/Ghost-15-causes-Windows-Home-Server-Backups-to-Fail/m-p/238809

    http://social.microsoft.com/Forums/en/whssoftware/thread/0ca220b7-e728-4a8b-ba16-5b527fc134bb

     

    Wednesday, June 9, 2010 3:32 PM