locked
W2K deployment - 'cannot create file mapping' error. RRS feed

  • Question

  • Hi All,

    In testing an established 2003 deployment on win svr 2008, we encountered the above error when opening any form within an ISV custom web app, having an iframe section.

    Assuming the problem was pg-specific we added a further iframe which linked to a dummy asp.net pg containing a label with the text 'hello' - this too generated the same problem.

    Googling brought us the following:

    http://msdynamicscrmblog.blogspot.com/2009/06/resolving-cannot-create-file-mapping-on.html

    ...which although exactly describing the problem, proved not to be our answer.

    What's most interesting here, is that on several occasions we thought we'd fixed it - i.e. we changed the account under which the relevant app pool was running (from networksvc -> a local admin acc), and it worked for a while - before suddenly stopping working. We also removed the web app ~ IIS and recreated it, and again that fixed the error...until a few hours later when the problem reverted. Re-trying the same action - i.e. delete + re-create web app - then no longer made any difference - the error persisted. In this vein we've tried a few other things, some of which have worked for a finite period before the error has returned.

    I realise this all sounds bizarre...but if anyone has a suggestion - or even bettter has encountered the same - we'd love your input.

    Tamim.


    T Sadikali
    Friday, February 4, 2011 11:49 AM