locked
live search switched to another language RRS feed

  • Question

  • somehow, livesearch now pulls up all french, even when manually switched to english, and selected USA and all other prompts to english it defaults back to french. Under properties, the URL is Live.com/france? could not find how to change that URL, so it would quit defaulting to french.

    Thanks 

    Monday, May 11, 2009 4:34 PM

Answers

  • Rody,

    We saw behavior similar to this a few months ago.  A customer had installed an "Emoticon" software package from Windows Live in France.  This software package created a duplicate "Live Search" entry for the browser's search box in the top of the browser.  This search box box appended a "mkt=fr-FR" to every search query that originated from the browser's search box.  Any time a query was issued from the search box, the rest of the session was in French, since Live Search remembers changes to the market for the rest of the browser session.  The fix was to remove the duplicate Live Search entry that was created by this Emoticon package and use the original entry which did not append a market.  If you have reset the browser accept language and cleared all cookies, something like this seems the likely culprit.  It really had a bunch of us scratching our heads trying to get to the bottom of it.

    There is also a mechanism called the "worldwide" page that is accessible via the link at the top of the page that has the current country name, in this case "France".  If you click on a link on the worldwide page, your market selection will be changed to your selected country and language and will be remembered in persistent cookies.

    Something else that might be happening is IE8 has a check box you have to leave blank when clearing cookies that "Preserves Favorites website data" (including cookies) on your favorite websites and doesn't delete them when you delete "all".  This would leave the persistent cookies from the worldwide page intact, keeping you in the French market.

    - Jim
    Tuesday, May 12, 2009 7:13 PM

All replies

  • Hi,

    Live.com auto-sets the language based off of your browser default language settings.  

    In IE, click Tools > Internet Options.  On the General tab, click Languages.   Make sure that "English (United States) [EN-US]" is the first language on the list.  If not, move it to the first position.   It's recommended that you then clear your cache (Tools > Internet Options - General tab, Delete History > Delete Temporary Internet Files).  When you return to the site, it should come up as English by default.

    - Jason
    Jason Garza, Program Manager
    Monday, May 11, 2009 4:51 PM
  • i went to the language box under setting your homepage to Msn and the default is in english, often I get a pop up for MSN in french asking for a switch, everything appears in english normally, however as soon as I type a search word it flips to french, and the top right buttons states France, options, and under options you can select language, which is alredy english, and region which is Florida (but then it adds a french word ater that) you have to manually select show only english at the top to actually have english.  I have spent hours trying to figure what seems to be so simple out, but I have had no luck! 
    Monday, May 11, 2009 6:43 PM
  • Hi, it sounds like you are attempting to change the language on the website itself not in the browser language settings.    If you are changing the language from a webpage that you reach by selecting a link on live.com or msn.com, you are not affecting the browser default language.

    To change the browser language (which can be done from any website) click "Tools" on the menu bar, then select "Internet Options."  On the control pop-up, click the languages button, then ensure that "English (United States) [EN-US]" is the first on the list.  You can also delete any languages that you do not use from this list.   After doing this, return to the Internet Options control and under Browse History, click "Delete..."  From here delete both the Temporary Internet Files and Cookies.   Close your browser, and reopen it.   When you return to live.com, the language should be in English.

    Please verify that you are following the steps listed above exactly.   





    Jason Garza, Program Manager
    Monday, May 11, 2009 7:18 PM
  • hi,
    thanks so much for your time in helping me, however I followed you instructions, and attempted to do so from the control panel, from MSN and from another website, I also attempted to do so from a french website. They all have the same language default which is set to English-United states en-us and there are no other languages in the selection. I deleted all temp files and cookies, and cleared history! As stated above, this has been done from everywhere I know how to reach it.
    everything is in english, my home page is MSN, I even tried to set my home page to Google, and switch back.  The problem is while in MSN, (everything is in English) you enter any search word and click live search(as I normally do when I browse the net) it pulls up everything french, I would have to manually click show only in english button, also go to options(under the live search page) and change the country. I would enter florida or zip code as an option, then it would automatically add some other french words behind it.!  This has gotten the best of me.
     Again thanks for your feedback. 
    Rody
    Monday, May 11, 2009 10:51 PM
  • Weird.  I'm not sure what would be causing that, but I've forwarded this information to some contacts over in Live Search to see if they can help.  


    Jason Garza, Program Manager
    Tuesday, May 12, 2009 6:29 PM
  • Rody,

    We saw behavior similar to this a few months ago.  A customer had installed an "Emoticon" software package from Windows Live in France.  This software package created a duplicate "Live Search" entry for the browser's search box in the top of the browser.  This search box box appended a "mkt=fr-FR" to every search query that originated from the browser's search box.  Any time a query was issued from the search box, the rest of the session was in French, since Live Search remembers changes to the market for the rest of the browser session.  The fix was to remove the duplicate Live Search entry that was created by this Emoticon package and use the original entry which did not append a market.  If you have reset the browser accept language and cleared all cookies, something like this seems the likely culprit.  It really had a bunch of us scratching our heads trying to get to the bottom of it.

    There is also a mechanism called the "worldwide" page that is accessible via the link at the top of the page that has the current country name, in this case "France".  If you click on a link on the worldwide page, your market selection will be changed to your selected country and language and will be remembered in persistent cookies.

    Something else that might be happening is IE8 has a check box you have to leave blank when clearing cookies that "Preserves Favorites website data" (including cookies) on your favorite websites and doesn't delete them when you delete "all".  This would leave the persistent cookies from the worldwide page intact, keeping you in the French market.

    - Jim
    Tuesday, May 12, 2009 7:13 PM