locked
CRM 2015 - Admin Role but cant create records RRS feed

  • Question

  • Hello folks,

    I've been setup with access to a CRM account through my IT department. None of them are familiar with CRM, my role is to learn it. They said that they've made me an administrator across the board. But even so I can't create new records and I can't seem to view records or data. 

    It will allow me to customize forms, and entities. So I know I at least have some admin rights. But we're not sure why I can't view and create contacts and accounts.  Here are some screenshots of what I see when logged in:

    You can see here, under the Sales section I don't have any options to view leads. If I access the Dashboard it just tells me that I don't have permission to view the data.

    Here is another screenshot:

    Anyone have any idea what we might be missing here? And please note we're new to the CRM world, so avoid too much jargon. Thank you very much.

    -Marshall

    Tuesday, May 19, 2015 8:17 PM

All replies

  • Looks like maybe you have the wrong license type?  See if you can go to Settings -> Security -> Users.  Go to your login record and look for the Access Mode setting (by default it's under Administration).  It should be set to Read-Write.
    Tuesday, May 19, 2015 8:24 PM
  • Thank you for the reply Chris.

    Here are my Access Mode Settings. I'm not sure if they're correct or not.

    Wednesday, May 20, 2015 2:36 AM
  • Hello Marshall,

    I can see that User's Access Mode is set to Administrative. However you still need to give a System Admin Security Role, as with Administrative Access Mode, they will not be able to create or update any records.

    Try giving Security role to user and I am pretty sure that shall work.

    Hope it helps!


    Regards, Abhishek Bakshi If you find this post helpful then please Vote as Helpful and Mark As Answer. Check my blog on https://mydynamicscrmblog.wordpress.com/

    Wednesday, May 20, 2015 4:56 AM
  • As I suspected, your access mode should be sent to read-write. If you are not able to change it, you may need to get the people that setup your account to do it.
    Wednesday, May 20, 2015 10:03 AM
  • That did the trick. Thank you for the help. 
    Wednesday, May 20, 2015 9:48 PM