locked
Home Server newbie; Unable to use remote access RRS feed

  • Question

  • I just got the Home Server trial version up and running. It seems to be working just fine except for remote access. I think it might be my router setup? Anytime I use <name>.homeserver.com or even the IP 192.168.2.100 itself; I get a login window asking for my router credentials which when I enter I can get into my router setup. Of course what I want is to get to my WHS remote access screen. It is acting like it is forwarding the necessary ports to the router IP instead of the WHS IP address? I have checked my router which is a NetGear box and it reports it has an address of 192.168.2.1 and I manually setup Port Forwarding for the WHS to be setup for 192.168.2.100

    Any ideas?

    FYI; On WHS Under my User Accounts  I have a user setup with "allowed" remote access set and the status is "enabled" .
    Under the Windows Home Server Settings screen the Remote Access is Turned On and the status reports "Available"
    Router IP address: 192.168.2.1
    Home Server IP address:  192.168.2.100

    Domain name https://<name>.homeserver.com

    Monday, November 9, 2009 4:41 AM

Answers

  • Port 3389 is not a necessary port to be forwarded. Only in the rare and unsupported scenario to use a direct Remote Desktop connection to your WHS instead of the Remote Access Web Interface this port plays a role.
    You should disable the Remote Administration capabilities of your router, maybe those get the preference over forwarding of ports. Also ensure, that the router firmware is up to date.
    What happens if you attempt to connect via https instead of http?
    From where do you try to connect? If from inside of your home - not each router model supports loopback (connecting to the internal network from the internal network via external network).

    Best greetings from Germany
    Olaf
    • Marked as answer by dcoffing Wednesday, November 11, 2009 5:45 AM
    Monday, November 9, 2009 11:05 PM
    Moderator

All replies

  • Right have you got the ports open in your router, these ports are

    (HTTP) port 80
    (HTTPS) port 443
    (RWW) port 4125
    (RDP) port 3389

    Also there is a chance that your router is not fully uPNP compatible, like mine its a netgear DG834G router, so I did a small work around, but I am having problems at the moment with it.

    Just to edit, that I may have got the Router to work by updating the firware.

    HMG
    Monday, November 9, 2009 10:30 AM
  • Right have you got the ports open in your router, these ports are

    (HTTP) port 80
    (HTTPS) port 443
    (RWW) port 4125
    (RDP) port 3389


    Thanks for the reply! My NetGear box is a RangeMax Wireless Router model WPN824

    I had http port 80, https port 443, RDP proxy port 4125 opened but not  port 3389. I will give this a try but I was thinking I only needed port 3389 opened on the firewall of the PC I was trying to access not the router itself. This stuff is confusing to me...

    I made the change and it still has the same problem. I am at home using one of the other PC's and I use IE with the http://<name>.homeserver.com and I get a window popup asking for my credentials to login to the NetGear router. After entering my credentials I get access to the NetGear setup not the home server. I am unable to even get this far if I attempt to access using the https://<name>.homeserver.com then I get the IE cannot display the webpage.
    Monday, November 9, 2009 5:48 PM
  • You appear to have a problem with your router configuration. Probably you have an option in your router's setup screens (consult your router manual for specifics) that allows remote router administration. If so, you should turn it off, as it exposes your router to the internet, allowing the potential for someone to take control of your router for (presumably) nefarious purposes.

    Note: Windows Home Server does not require port 3389 to be open in your router's firewall.
     


    I'm not on the WHS team, I just post a lot. :)
    Monday, November 9, 2009 7:19 PM
    Moderator
  • Thanks for the suggestions Ken. I went into the router setup and like you thought it does indeed have the ablity to be set for remote administration however mine is indeed off. :-(

    I did turn off the 3389 port also. Thanks for the feedback.

    How about the comcast cable modem...  Is there something I am supposed to do there that I haven't done maybe?

    I have only had the server running for a couple of days and I can tell I am going to like it. I will love it if I could just get the remote access to work along with remote desktop. However I liked it enough to upgrade the server drives and I ordered the Home Server DVD. Time to install the new WD 1TB drives :-)

    Any other ideas to try on my remote access issues?
    Monday, November 9, 2009 11:02 PM
  • Port 3389 is not a necessary port to be forwarded. Only in the rare and unsupported scenario to use a direct Remote Desktop connection to your WHS instead of the Remote Access Web Interface this port plays a role.
    You should disable the Remote Administration capabilities of your router, maybe those get the preference over forwarding of ports. Also ensure, that the router firmware is up to date.
    What happens if you attempt to connect via https instead of http?
    From where do you try to connect? If from inside of your home - not each router model supports loopback (connecting to the internal network from the internal network via external network).

    Best greetings from Germany
    Olaf
    • Marked as answer by dcoffing Wednesday, November 11, 2009 5:45 AM
    Monday, November 9, 2009 11:05 PM
    Moderator
  • Good points Olaf... I have only attempted to connect from inside the home thus far. I will try soon from outside. Right now When I try to connect using https:// then IE simply gives me the typical
    ***************
    Internet Explorer cannot display the webpage
    This problem can be caused by a variety of issues, including:

    • Internet connectivity has been lost.
    • The website is temporarily unavailable.
    • The Domain Name Server (DNS) is not reachable.
    • The Domain Name Server (DNS) does not have a listing for the website's domain.

    **************

    What use to happen was when I use the http:// a small dialog box pops up that actually lets me enter credentials but it gets me to the network router admin setup screens NOT the Home Server home web page which I assume the port forwarding is supposed to get me to

    Tuesday, November 10, 2009 9:43 PM
  • Just a side question...

    I ordered the full licensed copy of WHS. Is it best if I uninstall the trial version I currently am using and reinstall the full version or do I just need to simply register the trial version using the product key from the full version I am receiving? I just don't know if the trial version I downloaded form Microsoft is the real deal or not.
    Tuesday, November 10, 2009 9:47 PM
  • Just a side question... 
    FAQ: How do I upgrade from the evaluation/trial to a full copy of WHS?
    I'm not on the WHS team, I just post a lot. :)
    Tuesday, November 10, 2009 9:49 PM
    Moderator
  • Thanks for the link... I feel a little dumb and I should have done a search. It only makes sense it would have been an FAQ
    Wednesday, November 11, 2009 5:48 AM
  • ....
    From where do you try to connect? If from inside of your home - not each router model supports loopback (connecting to the internal network from the internal network via external network).

    Best greetings from Germany
    Olaf

    YEA ! ! ! Olaf that was the problem!  As soon as I got outside my internal network and went offsite to connect in to the WHS it worked like a champ! So apparently it was my router that was tricking me and wouldn't allow me to test the remote access from inside the network. Thanks to you and everyone else that took the time to help me troubleshoot this pesky problem.  You made a first timer WHS guy very happy. :-)
    Wednesday, November 11, 2009 5:53 AM