locked
Request.form stops working after clicking on page with Integrated Windows authentication -- where do I ask this? RRS feed

  • Question

  • Hello,

    I am using asp on a Windows 2003 server, with IIS 6.0, for a large organization.

    I need to collect user names for some pages on the website (which are restricted to a certain number of users), and am using request.servervariables(LOGON_USER) to get those names.  To do this, I have turned off "enable anonymous access" and turned on Integrated Windows authentication for a gateway page (i.e. just for one page in the whole website).

    I can't use Integrated Windows authentication for the whole site because then some important users who are outside the forest (? or domain??) are presented with username/password requests, which they aren't under anonymous access.  So, I pre-identify those users by ip address, and steer them around the gateway page.

    The strategy works fine, except for one problem.  There is an asp page elsewhere on the site that requests form variables used in search requests from another asp page.  The requesting asp page works fine until a user clicks on the page which has Integrated Windows Authentication applied.  From that point on, request.form stops working.  There's no error; but all the results are blank.

    Somehow, clicking on the page with the different access permission breaks request.form until the user closes all instances of the browser (IE 6) and then starts over.

    Does anyone have a suggestion about why this is happening and how I can solve it? 

    Many thanks!

    P.S.  An alternative way to determine the user name would also solve this for me -- the server is part of a large internal network. 
    Wednesday, December 16, 2009 5:22 PM

Answers

All replies