locked
Authenticating against CRM 2011 IFD from Custom Web Application with the CRMServiceHelper Class RRS feed

  • Question

  • For anyone that has experienced this before and was able to resolve it plese help!!!

    I would like to know how to authenticate a user on an external application, through ADFS, for our IFD CRM 2011 installation. We have an external web app that was working just fine with our On-premise installation since it was non-IFD. We used the system.configuration appsettings to get the currently logged in username and password to authenticate. Now our CRM has been converted to IFD and I am trying to figure out how the authentication happens then. Anyone with any ideas and samples will be greatly appreciated. We are using the crmservicehelper class from the SDK for this potion of the application. Thanks

    Friday, February 21, 2014 9:23 PM

All replies

  • This helper class should still work on IFD.  Are you getting an error?
    Friday, February 21, 2014 9:28 PM
  • Yes, I am getting a remote returned error. The error says, the metadata contains a URL that cannot be resolved. When the application tries to get the discovery proxy it throws that error, so bacically when it uses the IServiceManagement to get the discovery URL its not finding it. Maybe our IFD was not set up correctly in our case because that is the only other thing I can think of at the moment. Before IFD was set up, our discovery URL in CRM was something like http://ourcrmbox.ourdormain.com/xrmservices/2011/disconvery.svc using the default port 80. After IFD this has changed to https://icrm.ourdormain.com/xrmservices/2011/discovery.svc. ICRM has taken the name of ourcrmbox. Was the discovery url supposed to change in our environment? I think this might be where our initial problem is. I can give you more background information on this if it helps in your understanding of the issue. Thanks

    Friday, February 21, 2014 11:16 PM
  • Hello Friend , 

    i am also got stuck into the same issue, but in my scenario this is for crm 2013 and custom web application is integrated with crm 2013

    did you got the solutions for this.

    Wednesday, August 5, 2015 7:41 AM
  • Hello Friend , 

    i am also got stuck into the same issue, but in my scenario this is for crm 2013 and custom web application is integrated with crm 2013

    did you got the solutions for this.

    use the simplified connection instead

    http://stackoverflow.com/questions/15929879/ms-dynamics-crm-online-2011-authentication-issues/15930366#15930366


    My blog: www.crmanswers.net - CRM Theme Generator

    Wednesday, August 5, 2015 7:46 AM