none
Xbox360 RRS feed

  • Question

  • I am having some issues wiht my WHS and Xbox360.

    My layout is as follows:

    Eeerything on the 192.168 <-> Each other have ZERO firewall.

    I have linux based firewall for the incooming/outgoing etc.

    So we can rule firewall issues out right off the bat.

    I have a Media Center 2005 PC that I have connected to my 360.

    When I try and add Video or anything for that matter it does not give me my home server as an option but it does in fact show everything else on my network.

    To make this stranger if I drop out to the "media BLade" and hit "Pictures'  I can connect to my WHS server and actually view pictures.

    If I try to view Video or Music I get NOTHING.


    Can anyone shed some light on this extremely wierd issue?

    If there is antyhing I missed in my configuration or layout please let me know and I will provide you with as much info as possible.
    Saturday, December 1, 2007 3:28 PM

Answers

  • You have sharing turned 'on' for the media shares, yes?
    If = yes, do you also have the Guest account in WHS enabled, and have you given it (Guest) read permission (at a minimum) on the media shares?

    The problem that the 360 runs into is that it doesn't have an account on the WHS, and there's no way to give it one.
    So, you need to enable Guest so that the 360 has an account that it can login under.

    Saturday, December 1, 2007 8:30 PM

All replies

  • In WHS then settings make sure you have Media Sharing on?

    Saturday, December 1, 2007 5:13 PM
  • Yup . Turned on and also Picutres are working just not music and video.
    Saturday, December 1, 2007 5:52 PM
  • You have sharing turned 'on' for the media shares, yes?
    If = yes, do you also have the Guest account in WHS enabled, and have you given it (Guest) read permission (at a minimum) on the media shares?

    The problem that the 360 runs into is that it doesn't have an account on the WHS, and there's no way to give it one.
    So, you need to enable Guest so that the 360 has an account that it can login under.

    Saturday, December 1, 2007 8:30 PM
  • I am trying to give the Guest Account access to the Vidoe files now.

    I am sur ethat is the issue.

    But man  isn't silly that it can't emulate the MCX user that the xbox360 software creates when it connects up to the media server?

    Like MCE MCX User <-> WHS

    Just figured it would be smart enough to emulate or to create a matchin account you know what I mean?

    Thanks for the input!
    Sunday, December 2, 2007 12:45 AM
  • OK SO I enabled the Guest account.

    This allowed me to actually SEE there share when adding Videos.

    However when I select it and hit finish it does not add the item to the list.

    Just nothing happens.

    I checked and I have Guest perms on The Share and UNder Security for d:\shares\Video

    Do the Video's HAVE to be in the root?

    Because I have them under a directory so its like...

    d:\shares\Videos\movies\Appolo13

    Does it look recursive or should I move all MPGs to root of Video's and name them by file?

    I didn't have a problem browsing with my local drives on the media center with directory structure but not sure if it changes with WHS

    Your help is much appreciated!!
    Sunday, December 2, 2007 1:36 AM
  • Got it!

    Needed to disable emdia sharing. Reboot then start them back up and it worked.
    Sunday, December 2, 2007 1:53 AM
  • Good deal.  Glad you got it working.  Smile

    Sunday, December 2, 2007 5:44 PM
  • JonTheTeck - good to hear that you got it working - does the 'Album Art' show for either music or videos?

     

    Friday, December 14, 2007 4:19 PM
  • Yes.

    The guest account is the magic account.

    For some silly reason Microsoft decided NOT to allow us access to the MCX account password.

    That would have solved everything.

    Very poor documentation on this as well.
    Friday, December 28, 2007 3:40 PM
  • Did you need to disable media sharing after all?  Just curious if this has to be turned off for XBox 360 access.

     

     

     

    Friday, December 28, 2007 7:20 PM
  • No.

    That must be turned on as well.

    But Guest must be given read access to it.
    Friday, December 28, 2007 7:27 PM