locked
Port forwarding = no internet access RRS feed

  • Question

  • Hi

    I am currently running WHS successfully with remote access enabled and functional.  The system setup is a Billion 5120Sv3 single port ADSL router 192.168.0.253 connected to a gigabit switch, a Gigabyte BR03G wireless router 192.168.0.254 connected to the switch, WHS 192.168.0.1 connected to the switch, all static IP’s, port-forwarding is enabled on the 5102 pointing to 192.168.0.1.  This is done manually, as uPnP did not work.

    My question relates to the first two configurations I tried, which did not work, and I need to understand why as I may want to go back to them in order to use DHCP.  At the moment I cannot use DHCP, as the wireless router does not allow DHCP relay and therefore forces me to put the ADSL router into bridge mode on its WAN port if I want to use its DHCP server (in other words, the wireless router always uses its own IP as the gateway address).  If I enable DHCP elsewhere in the network, it will then only work for wired connections as the wireless router will not relay the DHCP requests.  In theory this should be fine, however in practice it does not work for the single issue described below.  It is also interesting to note that if I use a different ADSL router, a Billion 7300A, that I get the same problem.

    The issue, simply, is that if I enable port-forwarding on the wireless router or 7300A, that I cannot access the internet from my LAN.  I have left the static IP gateway on the clients at 192.168.0.253 if I use the 7300A, or 192.168.0.254 if I use the wireless router + bridged ADSL, but always get the same result.  Port forwarding on the 5210S works 100%, I can access the internet without any problems and WHS remote access.

    I find it difficult to believe that only 1 out of 3 routers works, and 1 out of two from the same manufacturer (more so that the 7300A is actually the newer of the two), so I must be doing something else wrong.  Does anyone have any ideas how to get internet access back with port forwarding enabled?  Should I be pointing the gateway to WHS instead (doesn’t really make sense, given that it’s currently working as described in the first paragraph)?

    I know it sounds like a hardware issue, but I’m 100% sure I’ve done the port forwarding correctly, so the manufacturers are not going to help me – I’m hoping someone has had a similar issue before and has a fix which allowed WHS and LAN to work, hence me posting in a WHS forum.  Search, unfortunately, didn’t seem to reveal any suitable answers.  I've tried ensuring the routers are as open as possible (firewalls off etc. etc.).

    Monday, July 20, 2009 9:03 AM

All replies

  • Windows Home Server is not designed to work in a complex network environment, which you have. :)

    In a typical home network, all computers are on the same subnet, and there's only one router handing out DHCP leases, mediating between the Internet and home computers, etc. In your case, you have two routers. My recommendation would be to configure your wireless router as an access point, rather than a router. Probably everything will work fine in that configuration.

    For example: my own netowrk configuration includes a broadband modem (in bridge mode), a router which functions as DHCP server, network edge firewall, etc., and a wireless router in AP mode. Everything at home is on one subnet.

    I'm not on the WHS team, I just post a lot. :)
    Monday, July 20, 2009 4:22 PM
    Moderator
  • Thanks Ken.  My description probably makes it sound more complex than it is, I was trying to be thorough.  Actually, I tried firstly to do exactly what you described - i.e. put the modem into bridge mode, then hang it onto the wireless router directly, so that there would be only 1 router (wireless) which could then hand out IP addresses - that would be the ideal solution which I am aiming towards, hence the purpose of my question, if I can get it to work I will be very happy indeed.  The problem though is that if I use port forwarding on that router, it would appear that ALL requests, including outgoing requests, get forwarded to WHS (i.e. I cannot access the internet from the LAN).  If I turn off port forwarding, then I get internet access, but no remote access to WHS.

    That's when I decided to keep the modem separate and use it in non-bridge mode as a gateway.  The wireless router effectively acts as an access point, as you described, but in that mode is unable to relay DHCP, so I'm forced to use static IP's.  The first modem I tried in this configuration gives me the same issue with no access to the internet if port forwarding is enabled.  Luckily I had a spare modem (the 5120S), which was a last resort which happily worked.  The 5102S is capable of running as a DHCP server, but as noted the wireless router (access point in this case) will not relay this, so all my wireless devices will still need to be static IP's, which is defeating the purpose.  They are all set to use 192.168.0.x, subnet 255.255.255.0.

    I guess I could simplify the whole question down to this: if I only have one modem/router, no wireless, and it gives me the problem of no internet access with port forwarding correctly enabled, what would the recommendation be to fix the situation?
    Tuesday, July 21, 2009 8:44 AM
  • The configuration I use (pardon the lousy ASCII graphics):
    Internet
        |
        V
    Broadband modem in bridge mode
        |
        V
    Router
        |
        V
    gigabit switch
        |    |
        |    V
        |   wireless access point or router in bridge mode
        |    |
        |    V
        |   wireless devices (laptops, smartphones, etc.)
        V
    Other devices (computers, NAS, network printers, etc.)
    Let me know if this isn't clear.

    I'm not on the WHS team, I just post a lot. :)
    Tuesday, July 21, 2009 4:37 PM
    Moderator
  • Quite clear, thanks!

    That's exactly what I'm trying to achieve, as I can then use the router for DHCP.  However, the problem is here:


        V
    Broadband modem in bridge mode
        |
        V
    Router
      
    The router, if configured to port-forward, then prevents internet access from the LAN.  My current config looks like this:



    Internet
        |
        V
    Broadband modem (wired only) in router mode*
        |
        V
    gigabit switch
        |    |
        |    V
        |   wireless router (can't set as AP or bridge, therefore can't use as DHCP controller)
        |    |
        |    V
        |   wireless devices (laptops, smartphones, etc.)
        V
    Other devices incl WHS

    This works 100% if the router marked * is the Billion 5102S.  If I put the 7300A in its place, but leave everthing else identical, it also prevents me from accessing the internet via the LAN.  I have also tried removing the wireless router from the network completely, it makes no difference.  So the weird thing is, port forwarding should only affect WAN -> LAN links (i.e. broadband -> NAT -> router).  It should not affect LAN -> WAN (i.e. outgoing internet requests).  This is really frustrating!  Looks like a new wireless broadband router with DHCP may be the only solution.
    Thursday, July 23, 2009 11:46 AM
  • Unfortunately, we're reaching the point where in order to further debug your network issues, I would need to have complete control of your network. Probably you need a different broadband router, and possibly you need one that does MAC address spoofing. Does your ISP lock your connection to a particular MAC address? Some providers here in the US do so, though usually they wind up locking you to the MAC address of your broadband modem...
    I'm not on the WHS team, I just post a lot. :)
    Thursday, July 23, 2009 4:08 PM
    Moderator
  • Hi Ken

    No, not locked to a MAC address.  I'm  100% sure as I was using the 7300A router for the last two years with this ISP, and only changed to the 5102S two weeks ago when I installed WHS, and port forwarding issues aside they both work flawlessly.  One thing I have done is try to lock an IP address to my ISP account, so I get a "sort-of" static IP, but I may disable that as it probably doesn't add any value.  I'm only aware of one ISP here which does that.

    Something else which may be worth considering, I use Norton 360 v3 which has never given me any hassles and is in exactly the same config firewall-wise between all the hardware scenarios I've indicated above (only installed on the client machines, not WHS) - including the currently functioning config.  I don't suspect a problem, since it is currently working, and I tried disabling it too, but perhaps you've come across an issue with this somewhere?
    Friday, July 24, 2009 12:22 PM
  • Well, that it works with one device at the edge of your network, but not the other, argues that it's that device that's the key. I'm betting that there's something about the way your Internet connection needs to be configured that isn't happening when you put your broadband modem in bridge mode and use a router as your edge device, but I honestly don't know what. You may want to explain your problem to your ISP, who presumably have helped other clients with similar issues.
    I'm not on the WHS team, I just post a lot. :)
    Friday, July 24, 2009 3:37 PM
    Moderator