none
Test MPI Ping-Pong: Quick Check fails (unable to connect to headnode) RRS feed

  • Question

  • Hello,

    I'm trying to validate a Windows HPC Server 2008 R2 installation as a first step to fix a parallel application issue. The MPI Ping-Pong: Quick Check test fails when run in all nodes. The result tab says the following:

    MPI Ping-Pong: Quick Check

    Test results by node

    Summary (Failure)

    Message: Unknown option: -c

    Credentials for localdomain\Administrator rejected connecting to HEADNODE

    Aborting: Unable to connect to HEADNODE

    back to top

     

    When I run it in the compute nodes (there are 3 of those) I receive no error but the test is running forever (or a long time as it seems). I've tried using the PowerShell command Set-HpcTestCredential and reentered it, also changing the insallation credentials in the To-Do List, but nothing changes.

    Thursday, May 19, 2011 8:29 AM

Answers

  • Hi lukasm,

    Should I check also if the power cable is properly plugged in?

    Oops, wait... it wasnt LOL

    I'm curious about your statement about it being an "invalid installation". I know it is. I was asking here because I hoped that we could find a solution that could help other users in the future. What did you mean with "invalid installation"? Should I reinstall from scratch?

    Anyway. I fixed it.

    I was having some problems also with credentials when running MPI jobs. I had an Intel MPI installation from Ansys (btw, too poor the integration of Ansys with HPC Server, every component should be configured separately and some don't provide connection to Job Scheduler). From the Intel MPI installation document I retried the step where they ask to add your password to the register running the following in a CMD terminal:

    "%I_MPI_ROOT%\em64t\bin\wmpiregister"

    This made the trick and fixed many problems with MPI jobs, including the Ping-Pong test issue. It's weird because this is a tool provided by Intel MPI installation, but I suppose that this affects other MPI installations since it's written to the registry.

    Some precission from MS on this would be appreciated.

    Thanks

    • Marked as answer by drioja Friday, May 20, 2011 8:25 AM
    Friday, May 20, 2011 8:24 AM

All replies

  • Hi

    Could you specify version of the HPC? Also is it English version?

    Can you run other diagnostics tests and this is the only one failing? If you can't then it's invalid instalation.

    Basically the user you set using the Set-HpcTestCredential should be a domain account (not a local account) and this user should be added to the user list (Configuration->Users) as an admin.

     

    So you could start this test on CNs only (you provided the list of nodes to use?) and it seems to be working. How long did you wait? With just 3 nodes it shouldn't be longer than a minute or two depending on you connection.

     

    Regards,

    Lukasz

    Thursday, May 19, 2011 8:28 PM
  • Hi lukasm,

    Should I check also if the power cable is properly plugged in?

    Oops, wait... it wasnt LOL

    I'm curious about your statement about it being an "invalid installation". I know it is. I was asking here because I hoped that we could find a solution that could help other users in the future. What did you mean with "invalid installation"? Should I reinstall from scratch?

    Anyway. I fixed it.

    I was having some problems also with credentials when running MPI jobs. I had an Intel MPI installation from Ansys (btw, too poor the integration of Ansys with HPC Server, every component should be configured separately and some don't provide connection to Job Scheduler). From the Intel MPI installation document I retried the step where they ask to add your password to the register running the following in a CMD terminal:

    "%I_MPI_ROOT%\em64t\bin\wmpiregister"

    This made the trick and fixed many problems with MPI jobs, including the Ping-Pong test issue. It's weird because this is a tool provided by Intel MPI installation, but I suppose that this affects other MPI installations since it's written to the registry.

    Some precission from MS on this would be appreciated.

    Thanks

    • Marked as answer by drioja Friday, May 20, 2011 8:25 AM
    Friday, May 20, 2011 8:24 AM