locked
File sharing problem with Firewall RRS feed

  • Question

  • This problem is a variation of the problems I have had for a year with v1x with sharing files on three computers in a WiFi home network where all three computers on are the same subnet. Support and the product group have not been able to fix the problem.

     

    I removed WOC v1.x from all three computers and installed v2.0 Beta. Two of the PCs are WinXP Home and one is WinXP Media Center. All are on a proven WiFi subnet via a Linksys AP.

     

    The WOC 2.0 Beta firewall is set to "Work or Home" configuration on all three PCs. I'm using the default configuration for WOC. The "Ports and protocols" have the "File and Printer Sharing - for local network (subnet)" checked.

     

    From all three PCs, the contents of all shared folders folders are visible.

     

    However, from the Media Center, when attempting to copy files fom one of the WinXP Home PCs, an error is consistently thrown. Also, this error occurs only in one direction depending on which machine you where you start to perform the copy.

     

    If I am on the Media Center PC and browse the Network Neighborhod for the source files on the WinXP Home PC and attempt to copy the files to the disk on the Media Center PC (in this example a single file in a subdirectory on the source PC and a child subdirectory that is in the same directory as the single file), the copy process starts, the single file is copied to the destination disk (on the Media Center PC) and the child subdirectory is also created at the destination. Then, when attempting to copy the files in the child directory from the source PC the very first file in the child directory from the source PC, an error occurs. The error says, "Error Copy {filename} - Access is denied. Make sure disk is not full or write-protected and that file is not in use."

     

    The destination disk that is internal to the Media PC is not full (over 60 GB free space). Also, the same error occurs if I attempt a copy on a large USB 2.0 external drive connected to the Media Center PC (with 200 GB free space) is made the destination. Same error.

     

    The file is not is use on the source PC and, just to make sure, the source machine was rebooted. Same error on retrying the copy.

     

    If I turn WOC off, the copy happens without error.

     

    If I go to the WinXP Home PC and start the copy from there, the copy completes without error. In this case, I use the same procedure. I browse the Network Neighborhood for the destination folder on the Media Center PC and start the copy and the copy is completed without error.

     

    With variations, this exact same problem (WOC being directionly sensitive for file sharing) existed with WOC v1.x.

     

    Bill

    Monday, October 15, 2007 7:32 PM

Answers

All replies

  • It sounds like the problem is at the Media Center PC. Perhaps the file copy is failing due to OneCare scanning while copying. In any event, I would file a bug  on Connect: https://connect.microsoft.com/site/sitehome.aspx?SiteID=168

    See the Bug Submission Guide - http://connect.microsoft.com/content/content.aspx?ContentID=3480&SiteID=168 - for details on how to create and submit the Support Log zip file with your bug.

     

    You've been the support route, so I won't offer that to you.

     

    -steve
    Monday, October 15, 2007 11:51 PM
    Moderator
  • I will file a bug report.

     

    FYI, OneCare is not scanning at the time, I've checked. This problem is repeatable every time a copy is tried in this pair (No joy when copy attempted from WinMCE with Soure = WinXP Home PC #1; destination = WinMCE but sucessful copy when copy attempted from WinXP PC #1 with Soure = WinXP Home PC #1; destination = WinMCE).

     

    I'm too new to 2.0 Beta to see if there are other permutations of the problem. With v1.x this would same problem (as well as others related to file sharing) would occur among same the three PC when WinMCE wasn't in the loop.

    Tuesday, October 16, 2007 12:19 AM
  • I forgot to offer one other thing that I think you may already have tried since you've seen the problem in 1.x, too, and have been the support route. Have you set the option for File and Printer Sharing to share with *all* computers and not just the local subnet? Are the results the same?

    -steve

     

    Tuesday, October 16, 2007 1:31 PM
    Moderator