locked
Super slow data transfer speeds between drives RRS feed

  • Question

  • So about a week ago I set up my WHS 2011 Server.  I had previously been using WHS v1, but this new server has all 3Tb hard drives, and I was having problems getting WHSv1 to use them properly.

    anyways, I've been moving files around now for a week.  I'll get them where I want them, then realize I want the drives laid out differently (thank you lack of drive extender).  So I'll shift things around, and restructure my drives.

    During all this, I'd move extremely large amounts of data (~1Tb here, ~1Tb there)...and they'd transfer just fine.  Usually around 80-100Mbs.

    I want to move one more thing around (I want to merge two volumes together...so I need to copy stuff off of each into a temporary drive, merge the two, then copy from the temp drive back).

    However...all of a sudden, I'm seeing HORRIBLE transfer speeds.

    From the server (not on a remote PC..but physically at the server), I'll copy a bunch of files from drive M to drive N.  It'll start out the normal 80-100Mbs ... but then after a couple files, it just screeches down to ~25Mbs...and stay there...for hours!

    WHY all of a sudden, am I getting such slow transfer speeds between the drives?  I've added no new hardware, I've made no real changes...

    Some key points to please remember when responding:

      - I'm physically AT the server, I drag from one drive to another (both of which are INTERNAL, and the exact same model drives).  This isn't a transfer from a remote computer or another computer on the network.  just from one drive on the server to another drive on the server.

      - The Transfer's start out pretty quick (80-100Mps)...then come to a crawl.  For hours...

      - The folders/files I'm trying to move are NOT configured for backup.  I'm fine with this, and want it this way.  But they are NOT shadowed, backed-up, etc.

    Any help would be appreciated.

    Monday, March 18, 2013 9:38 PM

Answers

All replies

  • Bump...

    I've discovered...it's not just transfers.

    I kicked off a chkdsk last night on a 3Tb drive, and in 10 minutes, it was at 15%...but that's about when it game to a crushing crawl.  Taking about 10 hours to finish...

    Then, later, I simply went to open the recycling bin, and that took about 10 minutes just for the window to open.

    There's obviously a disk access issue...any tips on where to start looking?  Again, all chkdsk's have shown no errors...most of these drives are brand spanking new.

    They WERE running fine and fast a week ago.  Now all of a sudden, they CRrrraaaawwwlll.

    Is there possibly some service running in the background that's causing drastic reductions in I/O time?  Some "feature" that's defaulted to on that might cause this?  (i.e. Shadowing or backing up?  Both of which I *believe* I have turned off for most of these drives...but maybe there's some other enhancement in WHS '11 that's similar?)

    ANY help would be appreciated.

    Tuesday, March 19, 2013 4:42 PM
  • Hi skeetyborphus,


    Firstly, in my experience, it seems to be hard drive issue. Other than using chkdsk, would you please use such tools from the manufacturer of your hard drive to check your disk.


    In addition, you can try to update the chipset driver, use resource monitor to troubleshoot the issue and check if there is any related error in event log.


    More information:


    How to speed up your slow computer

    http://support.microsoft.com/kb/2746761


    Hope this helps.


    Jeremy Wu
    TechNet Community Support

    Wednesday, March 20, 2013 8:06 AM
  • Have a look at the DiskCheckup tool from Passmark. It is compatible with Server 2008 R2 on which WHS2011 is based and it is free for personal use. It can also execute built-in Disk Self Test (DST) routines implemented by the disk vendor to detect drive failures.

    http://www.passmark.com/products/diskcheckup.htm

    Luc.

    Wednesday, March 20, 2013 9:46 AM
  • Thanks for the tips guys.  I'll try your suggestions.

    And I agree...in my experience too, it's usually a bad drive.

    But the reason I don't think that's the case here is...I have 5 drives in the server, and no matter WHICH drive I'm transferring to/from...I'm seeing this same behavior.  Granted, I bought all the drives at the same time...so maybe I got a bad batch. haha

    Another part that puzzles me is...for the first few mintues, I'm seeing xfer rates near 100.  then it slows down.  like there's a bottleneck, or suddenly the xfer has so much processing overhead...that there's churn.  I don't know.

    Again, if it were a bad drive, I'd think I'd see the slow speeds right out the gate, rather than 10-15 minutes into the transfer.

    But in any case, I'll do some more disk diagnostic work, and see if that turns anything up.  Thanks again for the input!

    Thursday, March 21, 2013 2:32 PM
  • One other item of note...I've been playing around...

    When I transfer 1 movie (~5Gb)...it transfers from one drive to the other at about 90Mbs...the whole time.  In about a minute...

    When I select an entire directory of movies which may contain 20-30 movies, it starts out at 90Mbs...then after a file or two, drops down to ~25Mbs...and stays there for the rest of the transfer.

    So I REALLY believe it's an I/O overhead issue...like WHS '11 doesn't know how to handle large file transfers...

    When I get time, I'm still going to try the suggestions provided a couple posts back...just to be sure.

    But like I said, I REALLY believe it's a processing issue, not a HW issue.

    Thursday, March 21, 2013 11:03 PM
  • Hi yubeck1,


    Is there any update?


    Also, please try to use this tool to transfer large files.


    RichCopy

    http://technet.microsoft.com/en-us/magazine/2009.04.utilityspotlight.aspx


    Hope this helps.


    Jeremy Wu
    TechNet Community Support

    • Marked as answer by Jeremy_Wu Tuesday, April 2, 2013 3:11 AM
    Sunday, March 24, 2013 5:38 AM
  • It just stopped doing it.

    I didn't make any changes...and can't attribute it to anything.

    Just one day, it stopped doing it, and now I'm seeing transfer speeds above 100MBs.  Really wish I knew what changed.

    Tuesday, April 2, 2013 3:32 PM
  • I have a very similar issue.  Moving a TV series collection.  Transfers begin at 110Mbps for about a second then fall to 300Kbps??

    Going to try the utility above--Disk utilisation is 25% and cpu 4%

    OK tried the utility-more visibility but same result. Three files began to move at high speed then stopped followed by 'progress' every 4 seconds at 300kbps then 4 second gap.  the last 11Mb took over 3 minutes to complete.

    Seems as if some internal buffer of 1G is filling then being emptied really slowly.

    All HDDs involved have passed the manufacturers tests.

    • Edited by Gr11zzly Tuesday, December 31, 2013 8:32 PM
    Tuesday, December 31, 2013 7:34 AM
  • Hey I am having the same issue!! IT'S REALLY FRUSTRATING!!

    My hard disk is of 7200 RPM. When I copy data within internal hard drives the speed first jumps to 80 MBps and the it drops to 25 MBps! However if I transfer data to an external hard drive the transfer rate is 80 MBps! Please help me!!

    Friday, January 10, 2014 6:14 PM
  • Same issue here on windows 8.1 pro.  copying 20gb directory from a 2tb drive to another 2tb drive, OS is running off a SSD.  Starts at 110 MB/s, drops to 20-30 MB/s after 1st 30seconds, and stays there until complete.


    Sunday, March 9, 2014 12:08 AM