locked
Help...Backup not accessible RRS feed

  • Question

  • OK here is my issue.

    I have had WHS installed and running for 1 month now. Every night I have a backup run and all was well. Then 2 days ago I tried to access WHS while traveling using the connector....it did not work. I got home later that day...tried uninstalling WHS connector on my laptop and reinstalling it. I finally figured out it was some port forwarding on my router.

    In any case... backups were working last week. I could even explore the backups fine... no problems...

    Today I finally lost a file on the client and figured.. no problem I  have a backup, this is why I got WHS...

    I get home...

    Run the WHS connector.. It connects..but when I go to explore the back-up ...3% into the process I get:

    Cannot connect to the backup service on the server. Verify that all services are running.


    I have spent the last 3 hrs. Googling this.

    I found this MSFT article: http://support.microsoft.com/kb/939218

    I tried every single "fix" they suggested..I get the same error message.

    I even tried running the Power Pack update to WHS but apparently that is already installed on my server.


    I am now stuck... I now have 1 month worth of backups and no way to access them. Can anyone help me to open my backups. I know it has something to do with keys that WHS uses to authenticate the client but the fixes I have tried so far have all failed. It there some other solution out there or have I lost all the last month's worth of backups?
    Tuesday, June 9, 2009 1:17 AM

All replies

  • Please note that the message occurs after exactly 3% of the backup is processed. I just followed the following:

    To turn off the policy that restricts access to the keys

    Method 1: All versions of Windows XP

    Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall the operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.
    1. Click Start , click Run , type regedit , and then click OK .
    2. Locate and then click the following registry subkey:
      HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa
    3. In the details pane, right-click nodefaultadminowner , and then click Modify .
    4. In the Value data box, type 0 (zero), and then click OK .
    5. Exit Registry Editor, and then reinstall Windows Home Server Connector.
    6. After Windows Home Server Connector has been reinstalled, modify the registry to set the nodefaultadminowner registry entry to 1 (one).

    No success.

    I have installed, resinstallled the connector like 3 times now.
    Tuesday, June 9, 2009 3:33 AM
  • Please note that the message occurs after exactly 3% of the backup is processed. I just followed the following:

    To turn off the policy that restricts access to the keys

    Method 1: All versions of Windows XP

    Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall the operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.
    1. Click Start , click Run , type regedit , and then click OK .
    2. Locate and then click the following registry subkey:
      HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa
    3. In the details pane, right-click nodefaultadminowner , and then click Modify .
    4. In the Value data box, type 0 (zero), and then click OK .
    5. Exit Registry Editor, and then reinstall Windows Home Server Connector.
    6. After Windows Home Server Connector has been reinstalled, modify the registry to set the nodefaultadminowner registry entry to 1 (one).

    No success.

    I have installed, resinstallled the connector like 3 times now.

    Have you tried rebooting the server?  Do you have another client in your LAN that you can use to access the backup database?
    Tuesday, June 9, 2009 4:17 AM
    Moderator
  • Yes I actually have a desktop that can access the backup database and I got the file back at 1 AM last PM.

    If I delete the database backups, then delete the computer in the database and then readd it and then do a new FULL backup, will I then be able to open the newly created backup.

    I am resigned now to losing the database. It seems that the key policy does indeed work, but in my case it seems to have worked a bit too well and locked my laptop (the machine that it was trying to guard) out of the ability to access the backup. A bit of a Catch-22. I can make all the backups I want, I just have not yet discovered a way to regain the ability to access them from that machine.

    I though the Microsoft KB article would help. I actually ended up trying all the methods they described with no success.

    I am on my 10th server reboot but I will give it one more try. Sometimes the 10th times a charm I suppose.

    Tuesday, June 9, 2009 1:23 PM
  • Yes I actually have a desktop that can access the backup database and I got the file back at 1 AM last PM.
    ...
    If you have been able to access the backup from any computer, the issue is not with the backup databas. Please don't delete it.

    The issue is with the specific computer that's experiencing the error. I'm puzzled as to the actual cause, though; if you followed the directions in the KB article carefully you shouldn't have caused any issues.

    Could you submit a bug report on Connect? Include logs from the client with the issue and the server, both collected using the Windows Home Server toolkit.

    I'm not on the WHS team, I just post a lot. :)
    Tuesday, June 9, 2009 3:47 PM
    Moderator
  • I tried this from the Microsoft KB article:

    To manually set permissions on the private keys

    Use the CACLS command to grant all administrators Full Control access to all computer-level keys.

    Note Any administrator can take ownership of the keys. Therefore, this action does not significantly reduce security although this action gives all administrators complete access to the computer-level keys.

    Important To modify the permissions of these keys, you must be logged on to the computer by using the account of the administrator who installed Windows Home Server Connector.

    To grant all administrators Full Control access to all computer-level keys, follow these steps:
    1. Log on as the administrator who installed Windows Home Server Connector.
    2. Exit Windows Home Server Console.
    3. Click Start , click Run , type cmd , and then click OK .
    4. At the command prompt, type the following command, and then press ENTER:
      cacls "%allusersprofile%\Application Data\Microsoft\Crypto\RSA\MachineKeys\*" /C /E /G Administrators:F
    5. Exit the command prompt, and then log on the computer by using the administrator account that you want to use to restore the backed up files.

    The command actually seemed to do its job but when I open Home Connector (I am logged into  the client as Administrator and the account that installed the Home Connector) I can see all the backups, I try to open it and at exactly 3% the process generates the error message:

    Cannot connect to the backup service on the server. Verify that all services are running.

    I will submit a report. I too am puzzled. It seemed there are multiple ways to turn off the policy that restricts access to the keys. I have worked my way through them one at a time. My suspicion is that the initial backup used one key, the reinstall of Home Connector installed another key and WHS is unable to reconcile the existence of the new key with the old key.
    Tuesday, June 9, 2009 6:08 PM