Cloud Shell Sandbox / Microsoft Learn RRS feed

  • Question

  • Hi all,

    Since today, I'm not able to use the cloud shell sandbox on https://docs.microsoft.com/en-us/learn/ . It claims that I use different accounts on the website and in the cloud shell session but I do use the same account.

    Error : You're signed into the cloud shell with an account that's different from your docs account. Please sign out of the cloud shell to retry accessing the sandbox.

    Thereby, I can't complete some modules, any idea ?


    • Edited by clem75 Thursday, March 7, 2019 9:46 PM
    Thursday, March 7, 2019 4:37 PM

All replies

  • Hi, 

    I'm getting the same error. Any solutions?


    Sunday, March 10, 2019 10:03 PM
  • Hi,

    Try the steps again by signing in through a new, private browser window. If that fixes the issue, we recommend clearing your browser’s cache/cookies before you try again in your normal browser window.

    Fore more information, see:

    Troubleshooting known issues

    Best regards,

    Blog: https://thesystemcenterblog.com LinkedIn:

    Monday, March 11, 2019 9:28 PM
  • I have the same problem as well.  Both IE and Chrome browser same issue.  Tried tossing my cookies and such but same issue.
    Tuesday, March 12, 2019 6:08 PM
  • I have same issue, both Edge and Chrome....   
    Wednesday, March 13, 2019 5:05 PM
  • I tried it from home last night (to eliminate corporate restrictions as the culprit) and got the same thing.

    I can open Cloud Shell from my portal account but not from docs.microsoft.com.

    Wednesday, March 13, 2019 5:16 PM
  • Same for me, going through a training path on the learning platform and when creating a virtual machine with the same login I get "You're signed into the cloud shell with an account that's different from your docs account"

    .. which is annoying so I need to jump on a different machine to stay logged in an do the actions on my corporate account which isn't ideal.

    Thursday, March 14, 2019 12:23 AM
  • Troubleshooting guide says to do it in a private browser.  I tried that at home as well (they have that option disabled at work).  In IE I did "InPrivate" and got the same results.
    Thursday, March 14, 2019 11:30 AM
  • So you got yours to work under your work account?

    Can you transfer the credit of completion back to your regular account?


    Thursday, March 14, 2019 11:31 AM
  • Sadly, I tried my work account and got the same results.
    Thursday, March 14, 2019 11:36 AM
  • Have the same issue for a week already :( No answer from support to the email.
    Friday, March 15, 2019 8:42 AM
  • same problem here.... with different browsers and also private browser window the same error message

    Friday, March 15, 2019 3:36 PM
  • I got past the Cloud Shell modules with some finagling...

    1.) Go into the Microsoft Learn module that requires the Cloud Shell sandbox.

    2.) Activate the sandbox.  You will get that error message but don't quit...

    3.) In another browser window, login to your https://portal.azure.com account and select the Microsoft Learn Sandbox directory.  If it doesn't prompt you, click the Book/Filter icon at the top between the Cloud Shell icon and the Bell icon.  If the sandbox (whether portal or cloud shell) was properly created on this account you are logged in with, you should have a separate directory called "Microsoft Learn Sandbox" for learn.docs.microsoft.com.

    4.) Once you are in there, you can dig down the Resource Groups (which you should have one named c24f5517-9ebc-4167-ad9a-410b91a73bf4).  Under that you will need to know the Storage account name & location (there should be just one) and also under that you will need to know the file share name.

    5.) Open another tab in your browser and go to https://shell.azure.com.  If prompted, use the same account and directory you have selected above.

    6.) It's going to complain now about needing a storage device or something.  The only subscription available is called "Concierge Subscription" but if you tell it to create the storage device you will get an error because you don't have permission.  The truth is, it is already there - you just need to give it the details.  If you click the link to display advanced details, you can fill in the existing storage account name and location and also the file share name (in my case those two names were the same).

    7.) After that, the Cloud Shell came up and I was able to run the commands.  At the end, I clicked the button to "Check Your Work" at the bottom of the learn module and it marked the module as complete for me.

    In my case, they block something required for the Cloud Shell on our network at work.  So I had the Microsoft Learn module open at work and remotely logged in to my home PC and did the Cloud Shell piece and I still got credit for it after doing the check my work option.

    Hope this helps.

    I wish I could give more details on step #6 but once I did that, now it doesn't prompt me anymore even if I logout, close the browser and go back in.  It might reset after the sandbox expires and has to be recreated and if that happens I'll try and update with more details if I missed anything.

    I found the https://shell.azure.com in another learn module I just went through.

    • Edited by Timothy Garay Friday, March 15, 2019 7:04 PM
    • Proposed as answer by K17ch3n Friday, March 15, 2019 8:38 PM
    Friday, March 15, 2019 7:02 PM
  • Looked good, but failed for the following reason :

    The user setting is invalid and has been removed. Error: Storage account location is not correct. Expect: eastus Actual: westus

    Edit: I deleted the Storage Account and it recreated automatically with the correct location.
    • Edited by K17ch3n Friday, March 15, 2019 8:57 PM Update
    Friday, March 15, 2019 8:49 PM
  • Hello Timothy,

    Thanks for your help.

    Unfortunately I already saw it was possible to configure a cloud shell from the "learning" directory. But it's not reliable because the configuration will have to be done for each new sandbox instance.

    I confirm I was able to run command from this manually configured shell, and then, validate the result back in the "Docs" website but I still can't use the shell from there

    What I saw in comparing with a working account, is that the storage account should be created automatically in the "Learning" directory (which is the case for me), and the storage account fileshare should also be populated with a ".cloudconsole" folder, which should contains an img file.

    In my case, the ".cloudconsole" folder is not created until I create it manually with the process you described (You also can initialize the shell directly from the "learning" directory).

    • Edited by clem75 Friday, March 15, 2019 9:31 PM
    Friday, March 15, 2019 9:03 PM
  • I noticed that mine was created in WestUS as well even though my default is EastUS.  That's why I copied and pasted the location as well with the account name and file share name.

    I only needed it to complete two Cloud Shell modules which I was able to do in the 60 minute activation window.

    I went back to the "Create a Virtual Machine" module tonight and I still get the error so I'm guessing that you are correct in that each time you will have to do the same process.  It's not a fix by any means but at least a workaround to get credit for those and move on.
    Saturday, March 16, 2019 1:10 AM
  • March 26, and still getting the same error.  Tried multiple browsers, multiple computers, multiple accounts.  Wasted a couple hours trying to take a basic sales introduction to their product.

    I think I found a work around.  This may not work for you though.  However I went back to the client and told them we are going to do the project in Amazon Web Services. 

    That fixed the problem.

    • Edited by C S S Tuesday, March 26, 2019 6:36 AM
    Tuesday, March 26, 2019 6:29 AM
  • This is ridiculous Microsoft. When will this issue be fixed? It is now April 10th.
    Wednesday, April 10, 2019 5:43 PM
  • Same error here for four days now... my error is just like most people here...
    Thursday, April 11, 2019 5:34 AM
  • Same here too, I mailed them yesterday, no response.
    Thursday, April 11, 2019 4:00 PM
  • For god sake Microsoft, as a partner, how the hell am I supposed to sell your cloud services when I can't even get it to work myself. This is ridiculous!
    Friday, April 12, 2019 10:47 PM
  • I get the same error, private window or different browsers don't help.

    I also get sign in error when trying to book a certification!

    Sunday, April 14, 2019 4:28 PM
  • there should be a Microsoft learn only for errors lol

    still no response...

    also, why do we need a docs account? didn't even know that was a thing
    • Edited by sxarthur Tuesday, April 16, 2019 1:04 PM
    Tuesday, April 16, 2019 1:01 PM
  • hi Timothy,

    your solution works. Though it took me numerous attempts.

    Saturday, April 20, 2019 8:57 PM