none
100% cpu hike issue with .net core application after migration from .net framework to .net core RRS feed

  • Question

  • We are migrating the existing asp.net web api service from .Net Framework to .Net Core SDK 2.1.500 to make it cloud native and run on PCF. We are experiencing issues while running the existing end to end integration tests locally, with problematic CPU utilization and Memory. after running few tests CPU utilization max out (reaches 99% - 100%) and it doesn't come down at all. These tests (~700) run in parallel and work fine with the existing solution(.Net Framework). The service/application is run locally. the system configurations is as follows Windows 10 Enterprise Precision 5820 Tower RAM : 32 GB processor: Intel(R) Xeon(R) w-2135 CPU @ 3.70 GHZ Core I-7 64 bit OS Running on Visual Studio 2017 Enterprise using kestrel-IIS webserver
    • Moved by May Luo-MSFT Monday, November 26, 2018 6:55 AM off-topic issue
    Wednesday, November 21, 2018 6:20 PM

All replies

  • Hi MM,

    Welcome to the MSDN forum.

    Based on your description, it seems be related to ASP .NET core issue. Since our forum is mainly discussing with .NET Framework Setup and Servicing issue. I recommend you redirect to the ASP .NET core forum and start a new thread to share your question for a more professional supporting.

    Thank you for your understanding.

    Best Regards

    May


    MSDN Community Support Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com

    Thursday, November 22, 2018 6:39 AM