locked
Slow File Access With Whs RRS feed

  • Question

  • My setup is brand new

    Chenbro ES34069 Case http://usa.chenbro.c...tail.php?sku=79
    2 x Hitachi Deskstar 1 TB Internal hard drive - 300 MBps - 7200 rpm
    Motherboard - Intel® Desktop Board DQ45EK http://www.intel.com...EK-overview.htm
    OS - Home server with all latest patches

    The drives on the home server are setup in a Raid 1 from the motherboard raid software.

    I have two users connected to this server and when they try to access files it takes about 10 sec for the files to open. These are XP machines.

    If i move the file to the external nas box then the files open quickly.

    Can ne1 help me start by troubleshooting if this is at the network layer. I wouldnt think so because the file access was fast when i used the NAS box.
    Thursday, June 3, 2010 10:38 PM

All replies

  • why have you got your HDDs setup as Raid 1 WHS cannot manage RAID drives, please disable Raid and let WHS manage the drives
    HMG
    Thursday, June 3, 2010 11:07 PM
  • That is what i dont understand. I see people saying that Raid 1 is not supported. But from my understanding is that the raid is done at the hardware level (Motherboard Supports it) so it should be invisible to the os. I have intel storage manager install and it seems ok. Can you explain if hardware raid is not supported by the os.
    Friday, June 4, 2010 1:37 AM
  • Another issue i just noticed is that i can not transfer files from the workstations to the server share. I get an error cannot copy the path is too deep. From the testing i am doing these issues all clearly point to the server.

    Friday, June 4, 2010 3:21 AM
  • That is what i dont understand. I see people saying that Raid 1 is not supported. But from my understanding is that the raid is done at the hardware level (Motherboard Supports it) so it should be invisible to the os. I have intel storage manager install and it seems ok. Can you explain if hardware raid is not supported by the os.
    RAID is not supported on WHS, no matter what type (hardware or software) or configuration (0, 1, 5, 10, etc.) it is.  However, it sounds to me like a network issue (flaky NIC, out-of-date driver, etc.)
    Friday, June 4, 2010 4:42 AM
    Moderator
  • Despite what Kariya21 said, although the answer could be right, I had 2 SATA PCI Cards in mine and it cause slow acess to them and slow at moving files from one HDD to another.

     

    Just make sure that the raid is removed and make sure your network adapter is up to date.


    HMG
    Friday, June 4, 2010 8:10 AM
  • RAID is "unsupported" in the sense that Microsoft doesn't test Windows Home Server on RAID configurations and doesn't promise it will work. In addition, there are known issues with Windows Home Server and dynamic drives (you're not using this), they're required for OS level RAID, and data loss is a likely result in that case. That said, it's certainly possible to use a RAID array with Windows Home Server. There are limitations of doing so, but usually you can install and configure just fine.

    In your case, I tend to agree with the other poster who suggested you might have a problem with your network. It's also possible that you have flawed drivers for your RAID HBA which are resulting in your issue. I would recommend you consider taking the RAID drivers out of the equation by configuring for either Legacy IDE (preferred because it maximizes compatibility at the cost of a small amount of performance you won't see anyway; given your server's use as a network file server other bottlenecks will mask the performance anyway) or AHCI mode, without RAID. This involves reinstalling, however, and may require "from scratch" installation depending on how your RAID HBA handles a mirror set.


    I'm not on the WHS team, I just post a lot. :)
    Friday, June 4, 2010 12:40 PM
    Moderator
  • I am going to redo everything from scratch.

    What would be the best way to configure the drives? I have 2 1 TB drives. Also do you think that because the motherboard is not supported that could be the issue. I am having a hard time finding itx boards that support WHS.

    Friday, June 4, 2010 5:31 PM
  • 2 harddisks of one TB each are fine (of course depending from the amount of data in the shared folders and the volume of the client backups).

    If your onboard SATA controller supports IDE compatibility mode I recommend to use it, since it simplifies setup (and later server recovery, if it should be necessary).
    For the shared folders you see as important enable duplication - this option helps the data in these shares to survive a single disk dead, as RAID would also do, but with less overhead.

    On top you should also have a bunch of external disks (recommend two so that if the server dies due to overvoltage just during a backup, still a disk with data exists), which you use for the Server backup. So you can put one disk to a secure place (outside of your house) and still have the data, even if the server died, got lost or whatever for catastrophic things do happen to computers.

    Best greetings from Germany
    Olaf

    Friday, June 4, 2010 6:09 PM
    Moderator
  • I do not think it is the motherboard, does all you driver install properly when WHS boots up or did you have to install XP drivers? Just let WHS sort your HDDs,


    HMG
    Friday, June 4, 2010 6:27 PM
  • i do have an external backup drive. That reminds me how to you schedule the server backups, I could not find that.
    Friday, June 4, 2010 6:27 PM
  • When it booted up from what i can remember i had to load the nic drivers, then the others from windows update but there are two pieces that i cant find drivers for they are listed at PCI devices. I think its the Intel ME and the TPM Driver. Here is what i plan to do when i get the box.

    1st connect the server to my laptop and try to transfer files to see if i get the same issues,

    2nd Assuming i get the same results, Use a different driver for the NIC, or add a new NIC and perform the test.

    3rd Try to remove the Raid with out a reinstall and perform the test

    4th Assumeing i get my watt meter in i will check to see if i am killing the PSU.

    5th IF all fails im going to take a 12lb Sledge hammer and end this BS and go with a 2008 server.

    Friday, June 4, 2010 6:38 PM
  • your going to have to start from scratch, because there is no way to add or remove raid without the drive being wiped.

    Did you have to use a XP driver for the Nic? you could try a Server 2003 compatible Nic and see if that is what caused it.

    WHS V2 will be out probably before the end of the year (NOT SURE) and that is based on Server 2008 but its waiting that long for it.


    HMG
    Friday, June 4, 2010 8:15 PM
  • Well i got the server at my office and connected it to the exact make and model of the switch. I then tried to transfer a file that was 1.7gb to the software folder from a xp client and it went with no problems. I connected a usb external HDD and tried to copy the users share to the external and got a Error can not copy. I am hoping that is because of the RAID Setup. As far as the NIC Driver i used a 2003 server driver. The two devices that i can not find drivers for are called PCI Device and PCI Communications Device. I am worried if that has something to do with it. But i found this company sells the exact same setup http://www.cybertronpc.com/Customkititems.asp?kc=SVSXR20&Group=HOME&iQty=1&Source=&show=0

     

    Saturday, June 5, 2010 1:39 AM
  • On 6/4/2010 1:27 PM, daniel5455 wrote:
    > i do have an external backup drive. That reminds me how to you schedule
    > the server backups, I could not find that.
     
    If I Remember Correctly, when you plug the drive in and you go into the
    Connector software, and click on Storage, it will show up. You would
    click on it, and choose "Add" and select the option to use it for
    backups. Then it will go through the server backup, and when you're
    ready to remove the drive, you just remove it through the Connector also.
     
    You may want to post this as a separate question though, just because it
    appears to have gotten lost in the thread. And someone with more
    experience in doing the server backups will help you out.
     
    Have a great day:)
    Patrick.
     
    --
    Smile... Someone out there cares deeply for you.
    Have you updated your OS and Antivirus today?
     

    Smile.. Someone out there cares deeply for you.
    Saturday, June 5, 2010 6:14 AM
  • To let you know that it cant be the motherboard, I did a search on google and found a few paged describing use of the Intel® Desktop Board DQ45EK motherboard with WHS, the only thing is that I found no reference to any problems with the two pieces of hardware you can not get drivers for.

     

    http://www.xiirus.net/articles/article-custom-windows-home-server-build-putting-it-all-together-e1g2y.aspx

    at the bottom of the page someone asked about proper drivers but had no reply

    I really dont think all drivers on WHS are need aslong as the Nic card is up to data, I use a XP driver myself for my Gigabyte motherboard, because that has no Server 2003, to tell you the truth I think all mine are XP drivers aswell.
    HMG
    Saturday, June 5, 2010 7:26 AM