locked
CRM 2011 - Workflow not getting triggered RRS feed

  • Question

  • I have created a simple process that used to worked that no longer triggers

    Here is the setup:

    Process:   Record field is change  (Statuscode)   Status Reason

    If  Entity: Status Reason equals = Completed  

          Send Email

    The Process is saved and published

    Workflow in the Entity  is "in progress" and the changed "Completed" 

    Notes: You do see the changes in the workflow made for the job in the Audit History
               Old Value and New Value   for the Statuscode

               However in the Process section, there is nothing for Workflow

    Any help would be greatly appreciated

    Thanks


    Nick M

    Monday, April 18, 2016 7:09 PM

Answers

  • I changed a setting from Business Unit to Organization and republished it and it started to work again.

    I also simplified it by just using status = Inactive  on change


    Nick M

    • Marked as answer by NickMangioros Tuesday, April 19, 2016 7:50 PM
    Tuesday, April 19, 2016 7:50 PM

All replies

  • does 2011 not have an option for status change?  if so, try using that one rather than looking a the statuscode field change.  note that successful system jobs don't remain if you have the delete system job on success checked.  (assuming that's what you mean by Process section)

    sorry, can't hazard a guess on why your behavior changed.

    Monday, April 18, 2016 11:17 PM
  • Check if scope of the process i.e. Organization Level or Individual level causing this. Process session log can only be seen if you have  uncheck “Automatically delete completed workflow jobs (to save disk space)” in case of “Background workflow” and in case of “Real time workflow the process session log not created unless and until if any error encountered".

    Thanks,

    Sam 


    Dynamics CRM MVP | Inogic | http://inogic.blogspot.com| news at inogic dot com

    If this post answers your question, please click "Mark As Answer" on the post and "Mark as Helpful"

    Tuesday, April 19, 2016 7:13 AM
  • I do not have Automatically delete completed workflow jobs (to save disk space).

    Note: It was working a few weeks ago with no changes made to the system which is the weird part.


    Nick M


    I tried other options with the same behaviour
    Tuesday, April 19, 2016 3:38 PM
  • I changed a setting from Business Unit to Organization and republished it and it started to work again.

    I also simplified it by just using status = Inactive  on change


    Nick M

    • Marked as answer by NickMangioros Tuesday, April 19, 2016 7:50 PM
    Tuesday, April 19, 2016 7:50 PM