locked
MsMpEng does not release extra memory after scan/tune up RRS feed

  • General discussion

  • Problem occurs under the following:

    Windows XP SP2 (fully updated) and SP3 RC2 (fully updated)

    AMD 3200+ w/1.0 Gb memory.

    WLOC version 2.0.2500.22 (when will Windows ever let us copy from an "About" box? I'm getting old.) 

    First I want to say that since the latest version of WLOC 2.0 was released my experience with the program has been nearly flawless. The only "problem" that I've been seeing since I installed the latest version (about 11/30/2007) is that MsMpEng.exe, which usually runs at around 42-47 Megs normally, runs up to 58.xx Megs during a tune up or virus scan, which is reasonable in my opinion, but WLOC 2.0 does not release that excess memory once the tune up or virus scan has completed. The high memory use after a scan or tuneup that MsMpEng.exe continues to use does not continue to climb at all but it should release the extra 10-15 megs back to the system once the scan/tune up is complete.

    Upgrading my system from SP2 to SP3 RC2 has not affected WLOC 2.0 performance in any way just so you know. I also took the time to attempt to research and locate any possible confllicts but none have been found. I beleive this is the normal behavior of the program in it's current version. Dissenting opions always welcomed of course.

    Is it possible that this issue might be addressed in the next release? I'll also supply any info you might need to check this out.

    Thanks!
    Wednesday, March 26, 2008 1:55 PM

All replies

  • Thanks for your feedback and the explanation of what you've observed. I'm going to move this over to the tune-up folder and leave it as unanswered.

    I don't know if there is a universal problem, but do recall others mentioning the slow climb of msmpeng memory usage over time, so it may well be something being worked on for a future release.

    -steve

     

    Thursday, March 27, 2008 12:54 AM
    Moderator