locked
The "System Jobs Waiting" Enigma RRS feed

  • Question

  • Hi

     

    Has anyone managed to resolve the system jobs "status waiting" issue yet? There seems to be loads of posts about it that all lead to dead ends.

     

    My circumstances are as follows:

     

    • This is a fresh install not a migration from 3.0
    • Microsoft CRM Asynchronous Processing Service is running fine. It is not using excessive CPU nor has it recorded any errors in the event viewer
    • Full Text Catalog job and SQM Data Collection tasks have succeeded OK but a simple data import remains as "waiting" despite restarting the APS numerous times
    • We have re-imaged the server and re-installed MSCRM twice making sure that the host headers issue that appears to cause problems is left in IIS as "unassigned" (i.e.not host headers - just a single IP address for the the MSCRM service)
    • No other tools have neen installed or run except for the main MSCRM application itself. We have run the IFD tool though but the systems jobs was not working before this anyway

    If I select a waiting job and click "resume" it says waiting for resources. What actual resources is it waiting for?

     

    I also noticed that it has been reported to MS but can't seem to find anyone who has successfully fixed the problem.

     

    I found this fix from Microsoft that entails making changes in the registry, the DeploymentProperties table in the MSCRM_CONFIG database and the ports in IIS http://support.microsoft.com/kb/947423/. Basically the ports all move up by 1 everywhere to 81. Restarted IIS and Async...... nothing!  - still stuck on waiting

     

    Any help on this one would be appreciated - we seem to have hit a brick wall :-(

     

    Thanks

    Saturday, November 8, 2008 5:55 PM

Answers

  • I managed to fix it using this method:

     

    In the DeploymentProperties table of the MSCRM_CONFIG database make sure that the AsyncSdkRootDomain field has the <servername colon port> entered into the NVarCharColumn coulmn. In our case it was <S15259967:80>, initially that field was empty after the MSCRM install took place. As this fix is directly on the Database though it is unsupported...

    Sunday, November 9, 2008 5:25 PM

All replies

  • I managed to fix it using this method:

     

    In the DeploymentProperties table of the MSCRM_CONFIG database make sure that the AsyncSdkRootDomain field has the <servername colon port> entered into the NVarCharColumn coulmn. In our case it was <S15259967:80>, initially that field was empty after the MSCRM install took place. As this fix is directly on the Database though it is unsupported...

    Sunday, November 9, 2008 5:25 PM
  • I have the same problem. I've tried editing the record mentioned in the 'Accepted' post.  It was blank in my database, but adding the crm url did not change my problem.  It has since been removed at the request of MS support.  The support person I'm working with hasn't figured it out either.  I've been working with Microsoft for 4 days now.

    Any other ideas?

     

    Thursday, November 13, 2008 6:15 PM