none
VS2008 Cluster Debugger Configuration error after installing MSMPI debugger - Could not load Microsoft.Hpc.Scheduler RRS feed

  • Question

  • I installed the MSMPI debugger on my XP dev station using VS2008 and I'm getting the following error.

    Cluster Debugger Configuration - Could not load file or assembly 'Microsoft.Hpc.Scheduler, Version=2.0.0.0, Culture=neutral, ...

    I am trying to develop the first of a suite of apps that will use MPI to control multiple other apps on Linux boxes controlling specialized hardware. The control apps will use Matlab on Windows XP. There is no MS server in this configuration. The dev environment on the Windows side is spec'd as Visual Studio 2008.

    Before loading the debugger I was able to run an MPI app but now I'm getting the above error any time I try to run the same app even with the Local Windows Debugger. I have even tried building a fresh app with just the following. It builds but won't debug without the error. 

    int

     

    _tmain(int argc, _TCHAR* argv[])

    {

    MPI_Init(&argc, &argv);

    MPI_Comm_size(MPI_COMM_WORLD, &totalnodes);

    MPI_Comm_rank(MPI_COMM_WORLD, &mynode);

    MPI_Finalize();

    }

    I can run this app successfully using the command below.

    "C:\Program Files\Microsoft HPC Pack 2008 SDK\Bin\mpiexec.exe" -np 1 C:\Projects\MSMPI-Project2\Debug\MSMPI-Project2.exe

    Additional information:

    Visual Studio 2008 crashes on exit. Error reported.

    I get the error most times I try to debug. Occasionally F5, F10 or F11 will work first time and fail thereafter. This behavior is inconsistent.

    Removing and re-installing Visual Studio 2008 did not help. I still get the same error.

    Removing the HPC 2008 SDK did not help. I still get the same error.

    Removing the 2008 HPC Debugger clears the problem as expected, but now I dont have the parallel debugger.

     
    • Moved by Nancy Shao Wednesday, May 26, 2010 8:58 AM Debugger question (From:Visual Studio Extensibility)
    • Edited by Stephen D. Metcalfe Wednesday, May 26, 2010 11:01 PM
    • Moved by Hongye Sun - MSFT Thursday, May 27, 2010 3:52 AM HPC Debugger Issue (From:Visual Studio Debugger)
    Tuesday, May 25, 2010 9:52 PM

Answers

All replies

  • Hi Stephen,

    Thanks for your post.

    I am moving this thread from Base "Visual Studio Extensibility" forum to the "Visual Studio Debugger" forum, since the issue is related to Visual Studio Debugger. There are more VS2010 Debugger experts in the "Visual Studio Debugger" forum.

    Regards,

    Nancy Shao [MSFT]
    MSDN Subscriber Support in Forum
    If you have any feedback on our support, please contact msdnmg @ microsoft.com


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework! If you have any feedback, please tell us.
    Wednesday, May 26, 2010 8:57 AM
  • Hi Stephen,

    Besides HPC Pack 2008 SDK, do you install the Client Utilities on your dev machine? The HPC Debugger depends on it to submit job to the cluster for debugging.

    Thanks,

    Qing

    Monday, May 31, 2010 1:02 AM
  • No additional information was received on this issue. Assuming it has been resolved & closing.
    Friday, February 4, 2011 10:25 PM
    Moderator