locked
Changing port 4125? RRS feed

  • Question

  • Can I change port 4125 to something else, maybe in the registry? I know this can be done with Remote Desktop. Thanks
    Wednesday, April 25, 2007 12:27 AM

Answers

  • No I don't think this is possible.  I remember reading somewhere it is hard coded. I am just curious why you would want to change this?

     

    Wednesday, April 25, 2007 12:29 AM
  • Quote from the Windows Home Server Team

     

     Dileep K wrote:

    If the port 4125 is blocked at the remote location (work place in your case), currently there is no way to work around this.

    Currently port for remtoe desktop 4125 is hard coded. You may file a feature request to get it into the settings page. (It is kind of strange that 4125 is blocked at your work site though, may be all ports except http and https are blocked for inbound connections?)

    Wednesday, April 25, 2007 12:32 AM
  • That is one of the functions of Remote Access.  Using port 4125, the WHS machine acts as a proxy server, allowing to you to be able to connect, via RDP, to the machines on your LAN that support it, only using one IP address.  You don't need to change the ports that those clients listen on.  In fact, you'll break the ability of WHS to allow you to access these machines.  It expects the clients to be on port 3389.  You might be able to dig around in the ASPX pages and find an entry that will allow you to change the port used for RDP, but it would be the same for all the machines on your LAN.

     

     

    Wednesday, April 25, 2007 2:05 PM

All replies

  • No I don't think this is possible.  I remember reading somewhere it is hard coded. I am just curious why you would want to change this?

     

    Wednesday, April 25, 2007 12:29 AM
  • Quote from the Windows Home Server Team

     

     Dileep K wrote:

    If the port 4125 is blocked at the remote location (work place in your case), currently there is no way to work around this.

    Currently port for remtoe desktop 4125 is hard coded. You may file a feature request to get it into the settings page. (It is kind of strange that 4125 is blocked at your work site though, may be all ports except http and https are blocked for inbound connections?)

    Wednesday, April 25, 2007 12:32 AM
  • I don't like to leave anything on default ports. As you might have guess, I changed all my remote desktop ports for 2 reasons. Security, and I can connect to more than 1 computer with 1 IP.  Also, I guess I am paranoid.

    Wednesday, April 25, 2007 12:37 AM
  • No this is not currently possible. I don't think you have much to be worried about with leaving 4125 on its default port, and all of your traffic to your server is done with SSL so you will be safe.
    Wednesday, April 25, 2007 12:40 AM
    Moderator
  • That is one of the functions of Remote Access.  Using port 4125, the WHS machine acts as a proxy server, allowing to you to be able to connect, via RDP, to the machines on your LAN that support it, only using one IP address.  You don't need to change the ports that those clients listen on.  In fact, you'll break the ability of WHS to allow you to access these machines.  It expects the clients to be on port 3389.  You might be able to dig around in the ASPX pages and find an entry that will allow you to change the port used for RDP, but it would be the same for all the machines on your LAN.

     

     

    Wednesday, April 25, 2007 2:05 PM
  • It seems that my ISP Comcast is blocking port 4125 so it would nice to be able to change it.

    Friday, November 16, 2007 4:21 AM
  • In RC1 of WHS port 4125 was hard coded and could not be changed. For the RTM version things might have changed. Check the following two Microsoft KB Articles that may help you.
    KB886209 and KB306759.

    Friday, November 16, 2007 3:55 PM
    Moderator

  • Has this changed at all since the OEM release?   Wondering if anyone was sucessful with the 2 above KB Articles before I go tearing around the registry in my HS trying to change the WebConsole RDP port from 4125 to something else.


    Wednesday, March 5, 2008 1:32 PM