locked
Two WHS on same network/router RRS feed

  • Question

  • I have two WHS(s) set up on a single ethernet network - both working fine.  I have the first WHS set up with port forwarding and can access it via the internet.  Can anyone help to set up a second set of port forwarding settings so that BOTH servers can be accessed from the interet without conflicting?

    At the moment I can either set port forwarding to one of the IP addresses and do not know how to set forwarding to both.

    Thanks
    Tuesday, February 17, 2009 12:46 PM

Answers

  • In your router you simply choose a different port for the secondary connection.  For example, In you router you set up port forwarding for the first Home Server something like this:

    external port 3389 forward to internal port 3389 on IP address 192.168.1.2 (Home Server 1 IP address.  (I know 3389 is the RDP port, I'm simply using it as an example.)

    So for the second server you would do the same thing but choose a different external port, like this:

    External port 3390 forward to internal port 3389 on IP address 192.168.1.3 (Home Server 2 IP address)

    Then when you want to access the second server, you would need to include the port number you chose.

    If you access the first Home Server like this:  remote.homeserver.com

    You would access the second one like this:   remote.homeserver.com:3390
    • Marked as answer by Stainmore Todd Tuesday, February 17, 2009 3:37 PM
    Tuesday, February 17, 2009 3:17 PM

All replies

  • In your router you simply choose a different port for the secondary connection.  For example, In you router you set up port forwarding for the first Home Server something like this:

    external port 3389 forward to internal port 3389 on IP address 192.168.1.2 (Home Server 1 IP address.  (I know 3389 is the RDP port, I'm simply using it as an example.)

    So for the second server you would do the same thing but choose a different external port, like this:

    External port 3390 forward to internal port 3389 on IP address 192.168.1.3 (Home Server 2 IP address)

    Then when you want to access the second server, you would need to include the port number you chose.

    If you access the first Home Server like this:  remote.homeserver.com

    You would access the second one like this:   remote.homeserver.com:3390
    • Marked as answer by Stainmore Todd Tuesday, February 17, 2009 3:37 PM
    Tuesday, February 17, 2009 3:17 PM
  • Hi and thanks very much for the advice.

    I understand what you have said and will try this out shortly.  If I have a problem, I would very much like to ge back to you.

    Thanks again for your post.

    Rgds
    Tuesday, February 17, 2009 3:39 PM
  • That would be fine, just let me know.
    Tuesday, February 17, 2009 11:34 PM
  • Hi

    Still having problems I am afraid.  I may be a little out of my depth here.

    I am using a Netgear ADSL Modem/Router with UPnP enabled.  I have created HTTPS, HTTP and Remote services with their default port addresses and have linked them to the IP address of WHS Server1.  The Remote Access tab of Settings on the WHS Console of Server 1 then sets everything up to the WHSServer1.homeserver.com.  All is well and the web address takes me to my WHSServer1 login page.

    I have created a second set of HTTPS(2), HTTP(2) and Remote(2) services with the port number incremented by 1 in each case and have linked them to the IP address of WHSServer2.  In the Remote Access tab of WHSServer 2, I have set up WHSServer2.homeserver.com and used the Remote Access tab to set up the link to WHSServer2.homeserver.com.  After a bit of messing about, this too works and I can get remote access to WHSServer2 on WHSServer2.homeserver.com.

    But....

    I then loose the link to WHSServer 1 on WHSServer.homeserver.com and get a link to WHSServer2 instead.


    In other words the latest setup seems to override the former.

    Can you see wher I am going wrong?

    Thanks for any advice.
    Wednesday, February 25, 2009 12:25 PM
  • If you need both your servers configured to support Remote Access, then you will probably have to turn off UPnP on both servers and your router, and configure your router manually. Better would be to simply configure one server, and leave the other as an internal server for computers you don't need remote desktop access to.

    To configure your router manually, consult your manual, or the guides on PortForward.com.

    I'm not on the WHS team, I just post a lot. :)
    Wednesday, February 25, 2009 2:58 PM
    Moderator
  • I would agree with Ken that when you configure the second address it appears to me overriding the first address.when you try to access the servers, thy adding the prot numebrs on the end of the address.  For Example:
    homeserver1.homeserver.com:3389
    homeserver2.homeserver.com:3390

    See if that gives you better results.
    Tuesday, March 3, 2009 7:14 PM