locked
VSS error after upgrade to Windows 10 RRS feed

  • Question

  • I recently upgraded my Win 8.1 Pro to Win 10 Pro. Previously backup to my WHS 2011 was running perfect. After upgrade to Win 10 I encountered problems with the upgrade and had to go back and install Win 8 Pro then Win 8.1 Pro then finally again upgrade to Win 10 Pro. Now I cannot backup as I get an error"an error prevented backup from creating a snapshot of the volumes on this computer. Also I seem to have 3 recovery partitions and 1 EFI system partition all on my C drive. I am almost sure this is causing the error. Also when I expand each recovery partition they show duplicates. When I open the customize backup for this computer it shows a recovery disc, 2 Local Disks and the C disk as well as the other drives on my PC. It seems like I have a big mess and do not where to turn. What shows in Disk Management and my choices in the WHS console do not match. I sent some pics to clarify. Please anyone with any ideas is much appreciated.

    https://www.dropbox.com/s/r18y0nbzou8q21v/Screenshot%20%2814%29.png?dl=0

    https://www.dropbox.com/s/rchf88xatbgqy0j/Screenshot%20%2819%29.png?dl=0

    https://www.dropbox.com/s/2c96sp3mob0rdzv/Screenshot%20%2820%29.png?dl=0

    https://www.dropbox.com/s/k9nnmebnpk11k9i/Screenshot%20%2821%29.png?dl=0

    https://www.dropbox.com/s/j8sf2a8ww9vusd5/Screenshot%20%2822%29.png?dl=0

    https://www.dropbox.com/s/tzt58ixe54972ez/Screenshot%20%2823%29.png?dl=0

    Thursday, August 20, 2015 2:52 AM

Answers

  • Installed the UEFI fix. There were three and was not sure which one to use or if it mattered but I used the first one.. Installed it and ran Windows on the server after UEFI fix install and it found 1 update. Rebooted server. Ran my PC connector software. First time it go to installing connector software and suddenly the server rebooted on me? Then tried it again and my PC tried to install software but it failed. During this time for some reason the server lost internet connectivity. Disabled and renabled LAN adapter which caused server to freeze. Rebooted server and all seemed back to normal. Then rebooted my PC. Ran connector software again and VOILA it worked. Now I configured backup(it had my old backup confit already there) and ran manual backup. This time activity LED on server started blinking and backup moved past the 1% mark. backup completed several hours later. Maybe the missing UEFI HOTFIX was the problem.
    Saturday, August 22, 2015 12:58 PM

All replies

  • Thursday, August 20, 2015 2:56 AM
  • Maybe this would shed some light on the situation?

    Thursday, August 20, 2015 2:59 AM
  • Log Name:      Application
    Source:        VSS
    Date:          8/20/2015 12:39:55 AM
    Event ID:      8194
    Task Category: None
    Level:         Error
    Keywords:      Classic
    User:          N/A
    Computer:      Jackie-PC
    Description:
    Volume Shadow Copy Service error: Unexpected error querying for the IVssWriterCallback interface.  hr = 0x80070005, Access is denied.
    . This is often caused by incorrect security settings in either the writer or requestor process.

    Operation:
       Gathering Writer Data

    Context:
       Writer Class Id: {e8132975-6f93-4464-a53e-1050253ae220}
       Writer Name: System Writer
       Writer Instance ID: {48e4639f-2d75-425c-a02b-4ec95b9b2a2f}
    Event Xml:
    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
      <System>
        <Provider Name="VSS" />
        <EventID Qualifiers="0">8194</EventID>
        <Level>2</Level>
        <Task>0</Task>
        <Keywords>0x80000000000000</Keywords>
        <TimeCreated SystemTime="2015-08-20T04:39:55.000000000Z" />
        <EventRecordID>3925</EventRecordID>
        <Channel>Application</Channel>
        <Computer>Jackie-PC</Computer>
        <Security />
      </System>
      <EventData>
        <Data>0x80070005, Access is denied.
    </Data>
        <Data>

    Operation:
       Gathering Writer Data

    Context:
       Writer Class Id: {e8132975-6f93-4464-a53e-1050253ae220}
       Writer Name: System Writer
       Writer Instance ID: {48e4639f-2d75-425c-a02b-4ec95b9b2a2f}</Data>
        <Binary>2D20436F64653A20575254575254494330303030313239362D2043616C6C3A20575254575254494330303030313235302D205049443A202030303030313339322D205449443A202030303031303439362D20434D443A2020433A5C57494E444F57535C53797374656D33325C737663686F73742E657865202D6B204E6574776F726B53657276696365202020202020202D20557365723A204E616D653A204E5420415554484F524954595C4E4554574F524B20534552564943452C205349443A532D312D352D3230</Binary>
      </EventData>
    </Event>
    Thursday, August 20, 2015 12:27 PM
  • Microsoft Windows [Version 10.0.10240]
    (c) 2015 Microsoft Corporation. All rights reserved.

    C:\WINDOWS\system32>vssadmin list writers
    vssadmin 1.1 - Volume Shadow Copy Service administrative command-line tool
    (C) Copyright 2001-2013 Microsoft Corp.

    Waiting for responses.
    These may be delayed if a shadow copy is being prepared.

    Writer name: 'Task Scheduler Writer'
       Writer Id: {d61d61c8-d73a-4eee-8cdd-f6f9786b7124}
       Writer Instance Id: {1bddd48e-5052-49db-9b07-b96f96727e6b}
       State: [1] Stable
       Last error: No error

    Writer name: 'VSS Metadata Store Writer'
       Writer Id: {75dfb225-e2e4-4d39-9ac9-ffaff65ddf06}
       Writer Instance Id: {088e7a7d-09a8-4cc6-a609-ad90e75ddc93}
       State: [1] Stable
       Last error: No error

    Writer name: 'Performance Counters Writer'
       Writer Id: {0bada1de-01a9-4625-8278-69e735f39dd2}
       Writer Instance Id: {f0086dda-9efc-47c5-8eb6-a944c3d09381}
       State: [1] Stable
       Last error: No error

    Writer name: 'ASR Writer'
       Writer Id: {be000cbe-11fe-4426-9c58-531aa6355fc4}
       Writer Instance Id: {dfeac5b1-a06c-4c12-b330-581b94ea0229}
       State: [1] Stable
       Last error: No error

    Writer name: 'System Writer'
       Writer Id: {e8132975-6f93-4464-a53e-1050253ae220}
       Writer Instance Id: {48e4639f-2d75-425c-a02b-4ec95b9b2a2f}
       State: [5] Waiting for completion
       Last error: No error

    Writer name: 'Shadow Copy Optimization Writer'
       Writer Id: {4dc3bdd4-ab48-4d07-adb0-3bee2926fd7f}
       Writer Instance Id: {9d23129b-8501-4a5e-a2f4-f20df6ca9c8e}
       State: [1] Stable
       Last error: No error

    Writer name: 'Registry Writer'
       Writer Id: {afbab4a2-367d-4d15-a586-71dbb18f8485}
       Writer Instance Id: {0d90dc52-5f51-4a67-a039-442457796de0}
       State: [1] Stable
       Last error: No error

    Writer name: 'COM+ REGDB Writer'
       Writer Id: {542da469-d3e1-473c-9f4f-7847f01fc64f}
       Writer Instance Id: {925956f7-7c27-48ae-ad1a-0d5d8ba1d93b}
       State: [1] Stable
       Last error: No error

    Writer name: 'WMI Writer'
       Writer Id: {a6ad56c2-b509-4e6c-bb19-49d8f43532f0}
       Writer Instance Id: {a38091da-4d24-49d3-8699-d58b3ea0d5c7}
       State: [5] Waiting for completion
       Last error: No error

    Writer name: 'MSSearch Service Writer'
       Writer Id: {cd3f2362-8bef-46c7-9181-d62844cdc0b2}
       Writer Instance Id: {e9f10f0c-cf57-441c-8d6b-a5aedb88ee25}
       State: [5] Waiting for completion
       Last error: No error

    Writer name: 'SqlServerWriter'
       Writer Id: {a65faa63-5ea8-4ebc-9dbd-a0c4db26912a}
       Writer Instance Id: {5c691913-82a6-4867-9c36-1b4f0d6c916b}
       State: [1] Stable
       Last error: No error


    C:\WINDOWS\system32>
    Thursday, August 20, 2015 12:34 PM
  • Hi,

    According to your description, my understanding is that WHS failed to back client computer which has newly upgraded to Windows 10, with Event ID 8194.

    You may confirm that if you have installed the hotfix(mentioned in below link) on WHS 2011:
    https://support.microsoft.com/en-us/kb/2781272

    Besides, try to re-install the connector after upgrading to Windows 10. And, verify that the Volume Shadow Copy Service is started.

    Best Regards,
    Eve Wang

    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Saturday, August 22, 2015 6:14 AM
  • Installed the UEFI fix. There were three and was not sure which one to use or if it mattered but I used the first one.. Installed it and ran Windows on the server after UEFI fix install and it found 1 update. Rebooted server. Ran my PC connector software. First time it go to installing connector software and suddenly the server rebooted on me? Then tried it again and my PC tried to install software but it failed. During this time for some reason the server lost internet connectivity. Disabled and renabled LAN adapter which caused server to freeze. Rebooted server and all seemed back to normal. Then rebooted my PC. Ran connector software again and VOILA it worked. Now I configured backup(it had my old backup confit already there) and ran manual backup. This time activity LED on server started blinking and backup moved past the 1% mark. backup completed several hours later. Maybe the missing UEFI HOTFIX was the problem.
    Saturday, August 22, 2015 12:58 PM
  • Hi,

    Thank you for taking the time to let me know the result. Your sharing might be helpful for other people who has the similar problem.

    Best Regards,
    Eve Wang

    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Thursday, August 27, 2015 1:12 AM