locked
CMS Error when trying to edit webpage RRS feed

  • Question

  • Hi, I have Customer Portal installed with SqlMembership provider. 
    When pressing the edit button, a box appears with "An error has occurred while saving you content. Your changes have not been saved." I have followed the steps in this discussion but it didn't resolve the issue.
    The edit button is working when debugging in VS and I'm able to edit content but when I add the site to IIS I'm getting the error above.
    I'm getting a 404 in Fiddler when trying to access the Services/cms.svc file - http://website:8888/Services/Cms.svc/Adx_webpageSet(guid'0c324fff-405c-4c70-9692-f9d9b19efba9')/Adx_Copy
    Is anybody else having this issue?
    Brian
    Friday, March 25, 2011 5:30 PM

Answers

  • I need to know what the error you see when you trace the call to the Cms.svc call.  The portal gives a generic error - I need the actual error thrown by the service.  If the service redirects you to a 404 page, the problem is likely that you installed Windows 2008 R2 SP1 on your machine, which has introduced a breaking change in ASP.NET, of which there is a workaround (see www.shanmcarthur.net) and a hotfix...  In the meantime, please post the error that is thrown when you make a call to the Cms.svc url. 
    Shan McArthur www.shanmcarthur.net Check out the commercial edition of xRM portals @ www.adxstudio.com
    • Marked as answer by iSite-BS Monday, March 28, 2011 1:16 PM
    Saturday, March 26, 2011 1:28 AM
    Moderator

All replies

  • I need to know what the error you see when you trace the call to the Cms.svc call.  The portal gives a generic error - I need the actual error thrown by the service.  If the service redirects you to a 404 page, the problem is likely that you installed Windows 2008 R2 SP1 on your machine, which has introduced a breaking change in ASP.NET, of which there is a workaround (see www.shanmcarthur.net) and a hotfix...  In the meantime, please post the error that is thrown when you make a call to the Cms.svc url. 
    Shan McArthur www.shanmcarthur.net Check out the commercial edition of xRM portals @ www.adxstudio.com
    • Marked as answer by iSite-BS Monday, March 28, 2011 1:16 PM
    Saturday, March 26, 2011 1:28 AM
    Moderator
  • Hi Shan - You were right I have Windows 2008 R2 SP1 installed so I installed the "GDR Update" and it fixed the issue, the extionless handler routing was the problem! Thanks alot for the reply, your blog was very helpful.

    My only problem now is when I'm editing a section its not picking up the xrm/css/editable.css - Any idea why this is happening? Again im getting a 404 in Fiddler when trying to access the CSS.

    Thanks again.
    Brian
    Monday, March 28, 2011 1:16 PM
  • Please open a new thread.  I will need more information on the problem as I am unable to reproduce it.  I would probably need the fiddler trace for the page and the subsequent request for the css file to troubleshoot.
    Shan McArthur www.shanmcarthur.net Check out the commercial edition of xRM portals @ www.adxstudio.com
    Monday, March 28, 2011 5:51 PM
    Moderator