Urgent: error message "Unable to refresh Restore Wizard from your server . . . " preventing volume restore RRS feed

  • Question

  • I purchased and installed WHS on some surplus hardware with a new HD last spring.  I have done the PowerPack 1 update and set other updates to Automatic.  I just did a manual update today and only an IE7 security update installed.  Backups have been going smoothly as far as I can see.  I have not used WHS for other functions since I primarily installed it for backup.

    Here's the glitch.  My son's system got infected by a sticky malware (virtumond) which we could neutralize for a time, but not eliminate.  We finally used Partition Magic  8 to delete all partitions on the drive, overwrote the first 5% of the drive with Drive Scrubber 2.5, then recreated the partitions on the drive with Partition Magic 8.  When I went to the folder on WHS to burn a current copy of the Home Computer Restore CD I found a text file saying I needed to download a new copy from a MS link.  I found the page, downloaded the .msi file, and used it to create an .iso file which I then burned to a CD with Nero 8.  I transferred the drivers from my son's computer backup on WHS to my USB key.  I then shut his system down and started afresh with the new Restore CD Dual Boot CD (files dated 7/12/08).  Everything went fine at first: chose the >500Mb option (he has 4 Gb), scanned the USB for the drivers, and selected restoring the whole boot volume, and started the restore.  The only odd thing at the start was it estimated the entire job would take 15-20 minutes which seemed very short.  The restore proceeded for some minutes and reached approximately 5% on the bar graph, then popped up the message:

        "Unable to refresh Restore Wizard from your server.  Your server may be an older version of Windows Home Server than this CD or your server may be damaged, we will attempt to restore with an older version."

    I clicked OK, was led through the same preliminary steps as before, although choosing the backup to restore took much longer, and the restore restarted.  However at approximately the same point as above, the bar graph disappeared and within less than a minute, the system rebooted!  Using Partition Magic I found the new partition I had created labeled "MAIN" and formatted NTFS had been replaced  by a partition with no label and formatted "Type 7" (whatever that is).  Among the workarounds I have tried:

    1.    Using the original Restore CD that came with the installation package.  It progressed fine, then rebooted at the same point as above.
    2.    The only thread I could find on the MS forums referred to a similar problem in the beta copy of the new restore software last spring.  There was an explanation that the restore software was trying to compare the CD with WHS.  Consequently I copied the ClientRestoreWizard.exe file from \system32 folder on the new CD to the \programs\Windows Home Server folder on WHS (after renaming the original file which had the same size, version, date, but a slightly different time)

    So the principle function for which I purchased and set up WHS is dead in the water.  I appear to have find backups but cannot do a full volume restore.  I do have another backup (BackupMyPC) which I had refreshed before wiping the drive, but I will then have to reinstall Windows, then BUMP, the do that restore.  This is the awkwardness I was trying to avoid.  I do have an old Ghost backup from my son's predecessor machine which I might be able to install, then refresh from BUMP.

    I am an unhappy WHS customer.  Does anyone, especially from Microsoft, have a solution for this critical problem?  Thanks.

    -Ted Shoemaker

    Wednesday, December 24, 2008 11:55 PM

All replies

  • Hi Ted,
    sometimes the network or mass storage drivers in Windows PE are not doing well in certain environments or are not included and hard to get. Did you try to extract the drivers from the folder Windows Home Server drivers for Restore from a backup of the affected client and provide them via USB stick?
    Also using 3rd party software to create the target partitions could be a potential reason for failing operations. For this you have disk management in the recovery environment.

    If you have a second client PC, you can try, if the method described in the linked FAQ helps you to complete the restore.

    Best greetings from Germany, good luck with your restore and merry Christmas
    Thursday, December 25, 2008 12:16 AM
  • Thanks for the quick response.

    1.  I did extracted the drivers from the backup for the affected system on WHS and put them on my USB key.  I had the Restore Wizard scan for them.

    2.  I thought about possible problems with using Partition Magic although it has been very useful in most circumstances.  However, the disk management in recovery seemed very limited.  I  could not figure out how to have it partition/format the drive.

    3.  I looked at your FAQ.  Since the drive to be restored is SATA and every other system we have is PATA it would require the USB to SATA cable.  I am hesitant because I can foresee going through all the work of buying the cable and moving the drive, only to end up with the same result. 

    Why do you think that the Restore Wizard is generating this bogus message?

    Have a great holiday!

    -Ted Shoemaker

    Thursday, December 25, 2008 2:51 PM
  • Hi Ted,
    you have a wired connection to the network or is it wireless (the last is not a good environment for restore)?
    How much memory does the system you wish to restore have? If it has only 512 MB, did you try the boot selection of the recovery CD for systems with less than 512 MB?
    The time assumed for a restore can be realistic, dependent of the system backed up and the network speed. A virtual machine with Windows XP and not much else on it restored within 5 minutes in a test. (Also you may know - Microsofts calculations of the  time beeing are sometimes a bit incorrect - so in a difference btw 0 seconds and 2 years to the reality I have seen all, even if not specially in a Windows Home Server context.)

    To create a partition with disk management, right click in the right frame representing the disk space or volume you wish to handle and select the appropriate actions from Context menu (i.e. Create volume, Format, mark as active).

    That there is no other system with SATA connectors is an unfortunate scenario. Although these cables are not too expansive, for a one time use without guaranteed outcome they are.

    • Why the message is be created I can only answer with speculations, especially since you said that restore started. Some of them could potentially be:
    • The drivers could consume more and more resources (maybe a memory leak in one of them, causing the bidirectional communication to fail at some point.
    • The backup is not consistent, and if reaching this inconsistent point causes restore to mess up. (There is a menu item Repair database on the WHS console in Settings/Backup, but this is not recommended to use as long as you don't have made a backup copy of the backup database, while that one client is down. Because in this situation the backups could also disappear from the database.)
    • The disk on server or client has an issue (i.e. damaged sector) causing a time out condition, if the restore wizard fails to write in a certain time.

    What you can try: Can you open the relevant backup via WHS console from another client and copy files/folders from there to that second PC manually? If this works for all folders of the backup you can assume, that the backup itself is not damaged and you have still the chance to restore at least the data after reinstalling the client system.
    It may be also worth a try (although I don't think this will be the solution, to be honest, but I don't want to leave a potential factor out), to logon locally or via Remote Desktop to the Windows Home Server desktop, open Control Panel / Add or Remove Programs, toggle Show Updates and uninstall the November Update for Windows Home Server (KB957825). After the subsequent reboot attempt the restore again.
    While logged in into the server, in Control Panel/Administrative Tools open the Event Viewer and check, if there are errors (red) and warnings (yellow) in one of the logs during the time of the attempted restore or other failure events, which should not be there (like ntfs errors).

    Best greetings from Germany
    Thursday, December 25, 2008 4:56 PM