none
SyncToy 2.0: Cannot sync some pairs to network drive RRS feed

  • Question

  • Hi,

    I'm just bought a new Vista Ultimate x64 laptop. My old XP x86 laptop used SyncToy 1.4 to keep a couple of folders in sync with a Server 2008 x64 network share. Since the move to the new laptop and SyncToy 2.0, I have been experiencing problems. (I've tried both the x86 and x64 versions with the same results.)

    With one folder pair, once I'd created the target folder on the new laptop, SyncToy 2.0 happily pulled all the content off the network onto the laptop and now keeps them in sync well.

    However, with another pair I get the following unexpected behaviour:

    • With no files on the laptop and lots in the server, SyncToy 2.0 reports there is no work to be done (which is different to the first folder pair I mentioned above)
    • So I copied the files manually from the server to the laptop and tried again, now it claims that all the files on the client are new

    Up to this point, it is as if SyncToy cannot see the files on the network, but I can work with them via Explorer just fine. They are all permissioned for full access for everyone, as are the folders and the shares.

    If I try and let it run and copy the files back from the laptop to the server as it wants, I get the following errors:

    • For the files that it thinks are new: "Error: Cannot write to the destination file. The file exists. (Exception from HRESULT: 0x80070050)"
    • For the folders it thinks it has to create: "Error: Cannot write to the destination file. The process cannot access the file because it is being used by another process. (Exception from HRESULT: 0x80070020)"

    At this point, SyncToy 2.0 is simply not working for me. I tried the old 1.4 version (I have the MSI lying around) but it just crashes when I run it; presumably it's not compatible with x64.

    Any pointers would be gratefully received because this is now seriously constraining my "mobility" as I can't take my network files with me and work on them when away from home very easily.

    Many thanks.

    Saturday, March 7, 2009 10:02 PM

All replies

  • Does anybody have any ideas? :-(
    Tuesday, March 10, 2009 4:50 PM
  • Hi -

    This really looks like SyncToy is unable to see the files on the network. Can you take a look at the permissions on the root folder and see if there is anythign wierd about that? Also, take a look at the SyncToy log which will tell you the number of files that we analyzed and if that is zero for the network side - it confirms that we cannot see the files.

    I am sorry we have not seen this problem before - unless it is messed up permissions on some folder.

    Thanks
    Deepa
    Deepa ( Microsoft Sync Framework)
    Tuesday, March 10, 2009 8:04 PM
    Moderator
  • Hi,

    Thanks for the reply. I'm pretty sure it's not a permissions problem. I've checked that the share and the underlying files and folders are all set for everyone full control. And, as I mentioned, I can manipulate the files just fine through Windows Explorer.

    Where will I find the log files to check?

    Thanks,

    Danny.
    Tuesday, March 10, 2009 11:13 PM
  • Hi,

    I found a log file in C:\Documents and Settings\danny\Local Settings\application data\microsoft\SyncToy\2.0. I hope that's the right one.

    The relevant bit doesn't look very useful to me:

    SYNC: 03/10/2009 23:15:07:869: -------------------------------------------------------------------------
    SYNC: 03/10/2009 23:15:07:872: Starting SyncToy, version 2.0.100.0, built 12/08/2008 15:07:12.
    SYNC: 03/10/2009 23:38:43:231: Started scanning directory : \\forestmead.com\Media\
    SYNC: 03/10/2009 23:38:43:232: Started scanning directory : D:\Network\Media\
    SYNC: 03/10/2009 23:38:43:516: Stopped scanning directory : \\forestmead.com\Media\
    SYNC: 03/10/2009 23:38:48:550: Stopped scanning directory : D:\Network\Media\
    SYNC: 03/10/2009 23:38:58:473: Preview of Media (D:\Network\Media\, \\forestmead.com\Media\) in time 00:00:15:232.
    SyncToy action was 'Synchronize'
    Found 11375 actions to perform.
    Found 0 files that did not require action.

    But for this run the folder on the local disk and on the network have identical content (the network folder was copied to the local disk using Explorer).

    For comparison, here's a successful run on a working folder pair from earlier in the evening:

    SYNC: 03/10/2009 20:37:52:563: Started scanning directory : D:\Network\Money\
    SYNC: 03/10/2009 20:37:52:563: Started scanning directory : \\forestmead.com\Users\profiles\danny\My Documents\Personal\Money\
    SYNC: 03/10/2009 20:37:52:736: Stopped scanning directory : \\forestmead.com\Users\profiles\danny\My Documents\Personal\Money\
    SYNC: 03/10/2009 20:37:52:858: Stopped scanning directory : D:\Network\Money\
    SYNC: 03/10/2009 20:37:53:036: Preview of Money (D:\Network\Money\, \\forestmead.com\Users\profiles\danny\My Documents\Personal\Money\) in time 00:00:00:474.
    SyncToy action was 'Synchronize'
    Found 4 actions to perform.
    Found 0 files that did not require action.

    SYNC: 03/10/2009 20:38:18:591: SyncToy run of Money (D:\Network\Money\, \\forestmead.com\Users\profiles\danny\My Documents\Personal\Money\) completed at 10/03/2009 20:38:18.
    SyncToy action was 'Synchronize'.
    SyncToy options were:
     Active for run all
     Files included: *.mny
     No files excluded
     Do not check file contents
     Include read-only files
     Include hidden files
     Include system files
     Backup older files (send to Recycle Bin)
     All subfolders included
    SyncToy run took 00:00:13:862.
    Copied 37,048,320 bytes in 2 files in 00:00:13:862.
    Bytes per second 2,672,489.6, files per second 0.1.

    Tuesday, March 10, 2009 11:50 PM
  • Were those details from the right log file? Is there a debug flag I can turn on to gather more useful information? Or a debug build I can install?
    Wednesday, March 11, 2009 11:31 PM
  • Right then, I'm making some progress and now I'm convinced this is a bug in SyncToy (or the underlying infrastructure).

    \\forestmead.com\Media is a domain-level DFS root. Under this are 3 namespaces: photos, videos and music. If I try and sync to \\forestmead.com\Media I get the problems mentioned. If I set up three separate sync pairs, one for each namespace, it works fine.

    In the previously mentioned example that worked, \\forestmead.com\Users is also a DFS root and profiles under that is a namespace.

    So it would seem that the problem is related to pointing to a DFS root and expecting it to sync the namespaces beneath that.

    This is clearly a bug in SyncToy 2.0 because a) 1.4 didn't have this problem, b) Explorer doesn't have this problem.

    I hope that's sufficient detail for you guys to investigate.
    Thursday, March 12, 2009 8:02 PM
  • So is it safe to assume nobody cares about this bug?
    Monday, March 16, 2009 6:01 PM
  • Hi Danny,

    I have experienced a somewhat similar problem with SynToy 2.0 x64. I could manually copy files from one directory to another on my workgroup but SyncToy would say "access denied". Same user on both computers, shared folders, full permissions.

    I did not have that problem with SyncToy 1.4 over XP

    So, yes, I do care about this bug.

    Antonio
    Saturday, March 28, 2009 4:04 PM
  • Hello Danny,
    I also care about your bug! I'm struggling with my own related problems with this software. In my case, I'm using synctoy 2.0.100.0 built 8/12/2008. I have a HP Pavilion laptop running Vista, with all updates and bug fixes applied (version 6, SP1). I also have a new (December 2008) Dell desktop PC, again with the latest build of Vista(SP1). I want to sync two folders that contain a few thousand picture files (primarily jpg and cr2, but with some other formats included).
    The problem is - synctoy constantly hangs in mid session with an error message of 'error when synchronising' or very similar wording.
    Annoyingly, it also seems to lock up the program and prevents a restart by claiming the program is already running, but will not shut down either. (I have tried to clear the lockup from the task manager, kill the application, kill the process synctoy.exe) but  still the only way to restart synctoy is a full reboot of both systems. It then runs normally for another 50 or so files before locking up again.
    On both systems I have messed with permissions, shares etc, but nothing seems to work consistantly. Both systems are using Norton 360 firewall and AV software. I've tried disabling both firewalls (laptop and desk pc) but it still hangs.
    Any help appreciated.
    Regards .... Alastair

    Sunday, March 29, 2009 9:36 AM
  • I came across your thread while searching for an answer for a problem I'm having with SyncToy 2.0 on Vista x64 in which a large (600GB) sync from a network drive to a local drive just hangs.  While this is slightly different from your problem, I just wanted to tell you that an alternative for you would be Cygwin's rsync utility.  While SyncToy hangs, rsync works fine.  Check it out at http://www.cygwin.com/.

    While I prefer SyncToy for ease of use, rsync seems to be more bulletproof.
    Friday, June 26, 2009 1:09 AM