locked
Workflow - Send E-Mail Step formatting issues RRS feed

  • Question

  • Sorry for the length of this post!  

    I am looking to see if anyone is experiencing odd behavior with the Send E-Mail step in workflows? 

    We are on CRM 2011 UR17 on-premise, running windows 8.1 and IE11 for the clients on our machines.

    Recently I was asked to change some long running workflows, so after looking at them I decided to chain several child workflows together to allow more flexibility in making changes to this process later.

    When recreating these, I added several steps to send out e-mails to users.  I hand-typed the body of the e-mails in the editor window, saved, closed and tested.

    All e-mails were formatted in the editor to use Arial size 10 font, according to the WYSIWG editor.

    When I tested, the e-mails are coming through with Times Roman font on two and Arial one the other two.  The line spacing is off of two also.

    So, I went back in and made changes to the two that were formatted wrong.  Deleted out extra spacing for the lines and changed the font again.  When I went to delete the extra spaces using the delete key, the editor actually added spaces.

    So I deleted the whole step from the workflow and manually recreated it again.

    The same results happened as the original test after activating them again.

    We do have IE running in compatibility mode and the CRM site has been added to the list.

    The last thing I tried was using an old Windows 7 PC with IE10.  Logged in as the Admin account, changed the font and spacing again in the workflow, published and tested.

    It worked fine, the e-mail font was what I selected and the spacing was correct.

    Has anyone else experienced anything like this?

    Thursday, December 4, 2014 8:03 PM